aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-09-01 07:59:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-09-01 07:59:07 +0000
commit24d0f3d72bd711687fa2dc41ea12e6ced1b4f964 (patch)
treef937c4c766f72284fb71bdbdac099cccc2b89e7e /emulators
parent2505b8d5d971794c02f19a0626cc871e36f01563 (diff)
downloadports-24d0f3d72bd711687fa2dc41ea12e6ced1b4f964.tar.gz
ports-24d0f3d72bd711687fa2dc41ea12e6ced1b4f964.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fceu/Makefile16
-rw-r--r--emulators/fceu/distinfo4
-rw-r--r--emulators/fceu/files/patch-src-movie.c8
-rw-r--r--emulators/fceux/Makefile16
-rw-r--r--emulators/fceux/distinfo4
-rw-r--r--emulators/fceux/files/patch-src-movie.c8
6 files changed, 18 insertions, 38 deletions
diff --git a/emulators/fceu/Makefile b/emulators/fceu/Makefile
index f1330009a7d1..a60627a9034a 100644
--- a/emulators/fceu/Makefile
+++ b/emulators/fceu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.11
+PORTVERSION= 0.98.12
CATEGORIES= emulators
MASTER_SITES= http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
@@ -26,24 +26,14 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
DOCS= cheat.html faq.html fceultra.html fcm.txt fcs.txt protocol.txt
TECHDOCS= README.now README.sound UNIF_current.txt nsfspec.txt
-TECHCPUDOC= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
+TECHCPUDOCS= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
TECHEXPDOCS= SMB2j.txt mmc5-e.txt mmc5_bank_switch.txt namco.txt taito.txt \
tengen.txt vrcvi.txt vrcvii.txt
TECHPPUDOCS= "2C02_technical_operation.TXT" loopy1.txt loopy2.txt
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_FLAGS)
-CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
-.if (${ARCH} == "i386")
-CFLAGS+= -ffast-math -mfancy-math-387
-.endif # i386
-.endif
-
pre-everything::
-.if !defined(WITH_OPTIMIZED_FLAGS)
- @${ECHO_MSG} "You can optimize by setting WITH_OPTIMIZED_FLAGS=yes."
-.endif
.if !defined(NOPORTDOCS) && !defined(TECH_DOC_INSTALL)
@${ECHO_MSG} "You can install technical documents"
@${ECHO_MSG} "by defining TECH_DOC_INSTALL"
@@ -77,7 +67,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Documentation/tech/${docs} ${DOCSDIR}/tech
.endfor
@${MKDIR} ${DOCSDIR}/tech/cpu
-.for docs in ${TECHCPUDOC}
+.for docs in ${TECHCPUDOCS}
${INSTALL_DATA} ${WRKSRC}/Documentation/tech/cpu/${docs} \
${DOCSDIR}/tech/cpu
.endfor
diff --git a/emulators/fceu/distinfo b/emulators/fceu/distinfo
index a34b5f65c1a8..f2921d305c91 100644
--- a/emulators/fceu/distinfo
+++ b/emulators/fceu/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.11.src.tar.bz2) = fda762a06c0167b903e4278beccc4760
-SIZE (fceu-0.98.11.src.tar.bz2) = 556643
+MD5 (fceu-0.98.12.src.tar.bz2) = 0fd2175b1f929e8b4d456789c4d7fc2b
+SIZE (fceu-0.98.12.src.tar.bz2) = 559571
diff --git a/emulators/fceu/files/patch-src-movie.c b/emulators/fceu/files/patch-src-movie.c
index c172724e893a..8b883957a406 100644
--- a/emulators/fceu/files/patch-src-movie.c
+++ b/emulators/fceu/files/patch-src-movie.c
@@ -1,5 +1,5 @@
---- src/movie.c.orig Sat Aug 14 07:13:51 2004
-+++ src/movie.c Sat Aug 14 07:15:58 2004
+--- src/movie.c.orig Tue Aug 31 07:35:21 2004
++++ src/movie.c Tue Aug 31 07:35:57 2004
@@ -154,7 +154,7 @@
void FCEUMOV_AddJoy(uint8 *js)
@@ -9,10 +9,10 @@
if(!current) return; /* Not playback nor recording. */
-@@ -190,7 +190,7 @@
- tmp >>= 5;
+@@ -191,7 +191,7 @@
tmp &= 0x3;
ti=0;
+
- int tmpfix = tmp;
+ tmpfix = tmp;
while(tmp--) { nextts |= fgetc(slots[-1 - current]) << (ti * 8); ti++; }
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index f1330009a7d1..a60627a9034a 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.11
+PORTVERSION= 0.98.12
CATEGORIES= emulators
MASTER_SITES= http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
@@ -26,24 +26,14 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
DOCS= cheat.html faq.html fceultra.html fcm.txt fcs.txt protocol.txt
TECHDOCS= README.now README.sound UNIF_current.txt nsfspec.txt
-TECHCPUDOC= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
+TECHCPUDOCS= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
TECHEXPDOCS= SMB2j.txt mmc5-e.txt mmc5_bank_switch.txt namco.txt taito.txt \
tengen.txt vrcvi.txt vrcvii.txt
TECHPPUDOCS= "2C02_technical_operation.TXT" loopy1.txt loopy2.txt
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_FLAGS)
-CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
-.if (${ARCH} == "i386")
-CFLAGS+= -ffast-math -mfancy-math-387
-.endif # i386
-.endif
-
pre-everything::
-.if !defined(WITH_OPTIMIZED_FLAGS)
- @${ECHO_MSG} "You can optimize by setting WITH_OPTIMIZED_FLAGS=yes."
-.endif
.if !defined(NOPORTDOCS) && !defined(TECH_DOC_INSTALL)
@${ECHO_MSG} "You can install technical documents"
@${ECHO_MSG} "by defining TECH_DOC_INSTALL"
@@ -77,7 +67,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Documentation/tech/${docs} ${DOCSDIR}/tech
.endfor
@${MKDIR} ${DOCSDIR}/tech/cpu
-.for docs in ${TECHCPUDOC}
+.for docs in ${TECHCPUDOCS}
${INSTALL_DATA} ${WRKSRC}/Documentation/tech/cpu/${docs} \
${DOCSDIR}/tech/cpu
.endfor
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index a34b5f65c1a8..f2921d305c91 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.11.src.tar.bz2) = fda762a06c0167b903e4278beccc4760
-SIZE (fceu-0.98.11.src.tar.bz2) = 556643
+MD5 (fceu-0.98.12.src.tar.bz2) = 0fd2175b1f929e8b4d456789c4d7fc2b
+SIZE (fceu-0.98.12.src.tar.bz2) = 559571
diff --git a/emulators/fceux/files/patch-src-movie.c b/emulators/fceux/files/patch-src-movie.c
index c172724e893a..8b883957a406 100644
--- a/emulators/fceux/files/patch-src-movie.c
+++ b/emulators/fceux/files/patch-src-movie.c
@@ -1,5 +1,5 @@
---- src/movie.c.orig Sat Aug 14 07:13:51 2004
-+++ src/movie.c Sat Aug 14 07:15:58 2004
+--- src/movie.c.orig Tue Aug 31 07:35:21 2004
++++ src/movie.c Tue Aug 31 07:35:57 2004
@@ -154,7 +154,7 @@
void FCEUMOV_AddJoy(uint8 *js)
@@ -9,10 +9,10 @@
if(!current) return; /* Not playback nor recording. */
-@@ -190,7 +190,7 @@
- tmp >>= 5;
+@@ -191,7 +191,7 @@
tmp &= 0x3;
ti=0;
+
- int tmpfix = tmp;
+ tmpfix = tmp;
while(tmp--) { nextts |= fgetc(slots[-1 - current]) << (ti * 8); ti++; }