aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /emulators
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417166
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pcemu/Makefile2
-rw-r--r--emulators/pcemu/files/patch-ae17
-rw-r--r--emulators/yabause/Makefile2
-rw-r--r--emulators/yabause/files/patch-src__core.h2
4 files changed, 11 insertions, 12 deletions
diff --git a/emulators/pcemu/Makefile b/emulators/pcemu/Makefile
index a16b9744e54e..00512d0143f0 100644
--- a/emulators/pcemu/Makefile
+++ b/emulators/pcemu/Makefile
@@ -16,6 +16,8 @@ RUN_DEPENDS= mkfontdir:x11-fonts/mkfontdir \
mkfontscale:x11-fonts/mkfontscale
USE_XORG= x11 xext
+USES= dos2unix
+DOS2UNIX_FILES= programs/config.sys
MAKE_ENV= FILESDIR=${FILESDIR} STAGEDIR=${STAGEDIR}
MAKE_ARGS= CC="${CC}"
diff --git a/emulators/pcemu/files/patch-ae b/emulators/pcemu/files/patch-ae
index 6ff371a2fc8c..5c745ccbbe82 100644
--- a/emulators/pcemu/files/patch-ae
+++ b/emulators/pcemu/files/patch-ae
@@ -1,10 +1,7 @@
-*** programs/config.sys.orig Mon Mar 27 21:27:23 1995
---- programs/config.sys Mon Mar 27 22:19:26 1995
-***************
-*** 1,2 ****
-! device=emufs.sys /
-! stacks 9,512
---- 1,3 ----
-! device=\emufs.sys /usr/local/lib/pcemu/C
-! stacks 9,512
-!
+--- programs/config.sys.orig 2016-06-20 15:48:12 UTC
++++ programs/config.sys
+@@ -1,2 +1,3 @@
+-device=emufs.sys /
++device=\emufs.sys /usr/local/lib/pcemu/C
+ stacks 9,512
++
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index 6d71b51b54cd..7c5eb8b866a2 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -12,7 +12,7 @@ COMMENT= Sega Saturn system emulator
LICENSE= GPLv2+
USES= cmake dos2unix openal:soft pkgconfig
-DOS2UNIX_FILES= src/qt/YabauseThread.cpp
+DOS2UNIX_FILES= src/qt/YabauseThread.cpp src/core.h
USE_XORG= xmu xrandr
USE_GL= gl glu glut
diff --git a/emulators/yabause/files/patch-src__core.h b/emulators/yabause/files/patch-src__core.h
index 30820f6aa7f6..fd63e919d7ca 100644
--- a/emulators/yabause/files/patch-src__core.h
+++ b/emulators/yabause/files/patch-src__core.h
@@ -9,5 +9,5 @@
#endif
+#endif
- #ifdef _MSC_VER
+ #ifdef _MSC_VER
# define BSWAP16(x) ((_byteswap_ushort((x) >> 16) << 16) | _byteswap_ushort((x)))