aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2016-06-10 14:41:14 +0000
committerBrooks Davis <brooks@FreeBSD.org>2016-06-10 14:41:14 +0000
commit978460fe076ceb10af0ad0b0218ba7f1a70c12a9 (patch)
treecf3266b78bc28d216cf7a133dffaaf48dc86e475 /emulators
parent21050b0bab4ead7ade06c81d31062a914147cbdb (diff)
downloadports-978460fe076ceb10af0ad0b0218ba7f1a70c12a9.tar.gz
ports-978460fe076ceb10af0ad0b0218ba7f1a70c12a9.zip
Update qemu-cheri* to a fresh snapshot.
Switch qemu-cheri128 to compressed 128-bit capabilities per the soon to be released ISA v5. Introduce a new qemu-cheri128m port which retains support for 128-bit capabilities that magically store 256-bit of data preserving semantic compatiblity with 256-bit capabilities while having 128-bit size and alignment requirments.
Notes
Notes: svn path=/head/; revision=416683
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/qemu-cheri/Makefile.snapshot4
-rw-r--r--emulators/qemu-cheri/distinfo4
-rw-r--r--emulators/qemu-cheri128/Makefile2
-rw-r--r--emulators/qemu-cheri128m/Makefile20
5 files changed, 26 insertions, 5 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 26eb2cefbd18..f6b56df47ba0 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -118,6 +118,7 @@
SUBDIR += qemu
SUBDIR += qemu-cheri
SUBDIR += qemu-cheri128
+ SUBDIR += qemu-cheri128m
SUBDIR += qemu-devel
SUBDIR += qemu-launcher
SUBDIR += qemu-sbruno
diff --git a/emulators/qemu-cheri/Makefile.snapshot b/emulators/qemu-cheri/Makefile.snapshot
index 462efa2f332b..756a909484d1 100644
--- a/emulators/qemu-cheri/Makefile.snapshot
+++ b/emulators/qemu-cheri/Makefile.snapshot
@@ -4,6 +4,6 @@
#
# Generated by: files/gen-Makefile.snapshot.sh.
#
-SNAPDATE= 20160514
+SNAPDATE= 20160610
-QEMU_COMMIT= afe5bbc23efd4093c1c35cd7d58e4cf8c1569143
+QEMU_COMMIT= 09b76d7d846b439c2af66947ed688f23e42ccc0a
diff --git a/emulators/qemu-cheri/distinfo b/emulators/qemu-cheri/distinfo
index aadac45b1da2..ef21a4e47324 100644
--- a/emulators/qemu-cheri/distinfo
+++ b/emulators/qemu-cheri/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CTSRD-CHERI-qemu-0.d20160514-afe5bbc23efd4093c1c35cd7d58e4cf8c1569143_GH0.tar.gz) = e15cbce6e52f6f4d6b4032c77e282ec65fdd92a0de61d1c80f78fd5aa22e7203
-SIZE (CTSRD-CHERI-qemu-0.d20160514-afe5bbc23efd4093c1c35cd7d58e4cf8c1569143_GH0.tar.gz) = 11141289
+SHA256 (CTSRD-CHERI-qemu-0.d20160610-09b76d7d846b439c2af66947ed688f23e42ccc0a_GH0.tar.gz) = 48d5fbe96de648bbc5fadf8dd996b8f24f04d7767b8e1138598704ffa9759f70
+SIZE (CTSRD-CHERI-qemu-0.d20160610-09b76d7d846b439c2af66947ed688f23e42ccc0a_GH0.tar.gz) = 11147193
diff --git a/emulators/qemu-cheri128/Makefile b/emulators/qemu-cheri128/Makefile
index 99cb8e79b2eb..554d9d742781 100644
--- a/emulators/qemu-cheri128/Makefile
+++ b/emulators/qemu-cheri128/Makefile
@@ -9,7 +9,7 @@ RUN_DEPENDS= qemu-system-cheri:emulators/qemu-cheri
MASTERDIR= ${.CURDIR}/../qemu-cheri
-EXTRA_CFLAGS= -DCHERI_MAGIC128
+EXTRA_CFLAGS= -DCHERI_128
PLIST= /dev/null
PLIST_FILES= bin/qemu-system-cheri128
diff --git a/emulators/qemu-cheri128m/Makefile b/emulators/qemu-cheri128m/Makefile
new file mode 100644
index 000000000000..45328348d743
--- /dev/null
+++ b/emulators/qemu-cheri128m/Makefile
@@ -0,0 +1,20 @@
+# Created by: Brooks Davis
+# $FreeBSD$
+
+PKGNAMESUFFIX= -cheri128m
+
+COMMENT= QEMU emulator with CHERI CPU support (128-bit, magic compression)
+
+RUN_DEPENDS= qemu-system-cheri:emulators/qemu-cheri
+
+MASTERDIR= ${.CURDIR}/../qemu-cheri
+
+EXTRA_CFLAGS= -DCHERI_MAGIC128
+PLIST= /dev/null
+PLIST_FILES= bin/qemu-system-cheri128m
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cheri-softmmu/qemu-system-cheri \
+ ${STAGEDIR}${PREFIX}/bin/qemu-system-cheri128m
+
+.include <${MASTERDIR}/Makefile>