aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-06-11 22:02:29 +0000
committerRene Ladan <rene@FreeBSD.org>2016-06-11 22:02:29 +0000
commitc1538cfa581f5dc2873c55c7fc38746de3b1eb0f (patch)
tree26390cd0c6a7452d37a8ccb2f8c9e44aeac83e96 /emulators
parentfd1bf1a623140ffabba3d7c1a09ecf7caf25407f (diff)
downloadports-c1538cfa581f5dc2873c55c7fc38746de3b1eb0f.tar.gz
ports-c1538cfa581f5dc2873c55c7fc38746de3b1eb0f.zip
Update the Spectrum Fuse ports to version 1.2.0
- Always include libaudiofile support, it was ON in fuse-utils but OFF in libspectrum - Bump version of libspectrum.so to 8.2.0 - New ulitity tape2pulses - Add missing LIB_DEPENDS / USES / USE_* [1] - Remove upstreamed patch - Pet portlint Reported by: poudriere [1]
Notes
Notes: svn path=/head/; revision=416760
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fuse-utils/Makefile21
-rw-r--r--emulators/fuse-utils/distinfo5
-rw-r--r--emulators/fuse-utils/pkg-plist10
-rw-r--r--emulators/fuse/Makefile15
-rw-r--r--emulators/fuse/distinfo5
-rw-r--r--emulators/fuse/files/patch-sound__aosound.c27
-rw-r--r--emulators/libspectrum/Makefile14
-rw-r--r--emulators/libspectrum/distinfo5
-rw-r--r--emulators/libspectrum/pkg-plist2
9 files changed, 36 insertions, 68 deletions
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index 0bf51c767b3f..cadb021e4438 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fuse-utils
-PORTVERSION= 1.1.1
-PORTREVISION= 3
+PORTVERSION= 1.2.0
CATEGORIES= emulators
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
@@ -13,23 +12,17 @@ COMMENT= Utilities from the Free Unix Spectrum Emulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
+LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
+ libgcrypt.so:security/libgcrypt \
+ libspectrum.so:emulators/libspectrum
+
+USES= gettext iconv pkgconfig
+USE_GNOME= glib20
-LIB_DEPENDS= libspectrum.so:emulators/libspectrum
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libspectrum-prefix=${LOCALBASE} \
--with-local-prefix=${LOCALBASE}
-OPTIONS_DEFINE= AUDIOTOOLS DOCS
-OPTIONS_DEFAULT= AUDIOTOOLS
-
-AUDIOTOOLS_DESC= Build audio <-> tape utilities
-
-OPTIONS_SUB= yes
-
-AUDIOTOOLS_CONFIGURE_WITH= audiofile
-AUDIOTOOLS_LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
-
# FIXME no way to specify ffmpeg1 paths to configure script
#FFMPEG_LIB_DEPENDS= libavformat1.so:multimedia/ffmpeg1
#FFMPEG_CONFIGURE_WITH= ffmpeg
diff --git a/emulators/fuse-utils/distinfo b/emulators/fuse-utils/distinfo
index 54ccd2ee9935..365fb421e970 100644
--- a/emulators/fuse-utils/distinfo
+++ b/emulators/fuse-utils/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fuse-utils-1.1.1.tar.gz) = 7c36c0b42805661a06c21aede3461ffc8ccdb5ce56fe232875bf86e79f77c93c
-SIZE (fuse-utils-1.1.1.tar.gz) = 505766
+TIMESTAMP = 1465508963
+SHA256 (fuse-utils-1.2.0.tar.gz) = 0a8d20d9c2a90619ab8e82dc33a5e91424c64a558728369dd9009435da1ef8be
+SIZE (fuse-utils-1.2.0.tar.gz) = 499785
diff --git a/emulators/fuse-utils/pkg-plist b/emulators/fuse-utils/pkg-plist
index fe4e94d1f2b5..66fd56c2e0f0 100644
--- a/emulators/fuse-utils/pkg-plist
+++ b/emulators/fuse-utils/pkg-plist
@@ -1,4 +1,4 @@
-%%AUDIOTOOLS%%bin/audio2tape
+bin/audio2tape
bin/createhdf
bin/fmfconv
bin/listbasic
@@ -10,7 +10,8 @@ bin/rzxtool
bin/scl2trd
bin/snap2tzx
bin/snapconv
-%%AUDIOTOOLS%%bin/tape2wav
+bin/tape2pulses
+bin/tape2wav
bin/tapeconv
bin/tzxlist
man/man1/createhdf.1.gz
@@ -27,8 +28,9 @@ man/man1/snapconv.1.gz
man/man1/tapeconv.1.gz
man/man1/tzxlist.1.gz
man/man1/profile2map.1.gz
-%%AUDIOTOOLS%%man/man1/audio2tape.1.gz
-%%AUDIOTOOLS%%man/man1/tape2wav.1.gz
+man/man1/audio2tape.1.gz
+man/man1/tape2pulses.1.gz
+man/man1/tape2wav.1.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 53f6565151ba..87445ca18c53 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fuse
-PORTVERSION= 1.1.1
-PORTREVISION= 9
+PORTVERSION= 1.2.0
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
@@ -12,13 +11,16 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= libspectrum.so:emulators/libspectrum \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgcrypt.so:security/libgcrypt \
libpng.so:graphics/png \
- libgcrypt.so:security/libgcrypt
+ libspectrum.so:emulators/libspectrum
GNU_CONFIGURE= yes
-USES= gmake localbase pkgconfig
-USE_GNOME= libxml2 glib20
+USES= gettext gmake localbase pkgconfig
+USE_GNOME= cairo libxml2 glib20
+USE_XORG= x11
CONFIGURE_ARGS+=--without-alsa --without-joystick
@@ -57,6 +59,7 @@ INSTALLS_ICONS= yes
post-extract:
${CP} ${WRKSRC}/roms/README.copyright ${WRKSRC}
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/emulators/fuse/distinfo b/emulators/fuse/distinfo
index 3e518283548b..67a83c8d767b 100644
--- a/emulators/fuse/distinfo
+++ b/emulators/fuse/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fuse-1.1.1.tar.gz) = a857d4bd62e01d18429897467508af15624cbaf343caed8b9ba1ab3a8879444e
-SIZE (fuse-1.1.1.tar.gz) = 1881332
+TIMESTAMP = 1465509349
+SHA256 (fuse-1.2.0.tar.gz) = 72621b23c31c69a31e97b698761c4a21a209b23f4d53f8b441291c14f6811acb
+SIZE (fuse-1.2.0.tar.gz) = 1622829
diff --git a/emulators/fuse/files/patch-sound__aosound.c b/emulators/fuse/files/patch-sound__aosound.c
deleted file mode 100644
index 67b03d0423f3..000000000000
--- a/emulators/fuse/files/patch-sound__aosound.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- sound/aosound.c.orig 2013-05-16 20:26:12 UTC
-+++ sound/aosound.c
-@@ -78,14 +78,14 @@ driver_error( void )
- }
- }
-
--static void
-+static int
- parse_driver_options( const char *device, int *driver_id, ao_option **options )
- {
- char *mutable, *option, *key, *value;
-
- /* Get a copy of the device string we can modify */
- if( !device || *device == '\0' )
-- return;
-+ return 0;
-
- mutable = utils_safe_strdup( device );
-
-@@ -119,6 +119,7 @@ parse_driver_options( const char *device
- }
-
- free( mutable );
-+ return 0;
- }
-
- int
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 7f95678c927d..349d80e13a60 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libspectrum
-PORTVERSION= 1.1.1
-PORTREVISION= 4
+PORTVERSION= 1.2.0
CATEGORIES= emulators devel
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
@@ -12,18 +11,13 @@ COMMENT= Handling of ZX-Spectrum emulator files formats
LICENSE= GPLv2
-LIB_DEPENDS= libgcrypt.so:security/libgcrypt
+LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
+ libgcrypt.so:security/libgcrypt
GNU_CONFIGURE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USES= gmake pkgconfig libtool
-
-OPTIONS_DEFINE= AUDIOFILE DOCS
-AUDIOFILE_DESC= Support loading from .wav files
-
-AUDIOFILE_LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
-AUDIOFILE_CONFIGURE_OFF= --without-libaudiofile
+USES= gettext gmake libtool pkgconfig
INSTALL_TARGET= install-strip
diff --git a/emulators/libspectrum/distinfo b/emulators/libspectrum/distinfo
index 0784f623fa55..6bfa8257ceb2 100644
--- a/emulators/libspectrum/distinfo
+++ b/emulators/libspectrum/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libspectrum-1.1.1.tar.gz) = 178d3607af2109b6b8dafac4f91912745b9f3c087319945c3a886bb7fe7989d5
-SIZE (libspectrum-1.1.1.tar.gz) = 502942
+TIMESTAMP = 1465507428
+SHA256 (libspectrum-1.2.0.tar.gz) = 5d08c624b181b18e708ca82183cae2162a9476dd524c421fbac52fe5ffba1e7a
+SIZE (libspectrum-1.2.0.tar.gz) = 509689
diff --git a/emulators/libspectrum/pkg-plist b/emulators/libspectrum/pkg-plist
index 9c2a627c1c4f..2391e033526f 100644
--- a/emulators/libspectrum/pkg-plist
+++ b/emulators/libspectrum/pkg-plist
@@ -2,7 +2,7 @@ include/libspectrum.h
lib/libspectrum.a
lib/libspectrum.so
lib/libspectrum.so.8
-lib/libspectrum.so.8.1.0
+lib/libspectrum.so.8.2.0
man/man3/libspectrum.3.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog