aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-11-05 16:32:39 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-11-05 16:32:39 +0000
commit4cba7c3bd72726e2f48ae28e6d4366ba30e1487a (patch)
treebd43ed84bba295e7bbd6807806a0c42b9995deae /emulators
parent351c384e88014a44bd0aa167717c1faf198abcdf (diff)
downloadports-4cba7c3bd72726e2f48ae28e6d4366ba30e1487a.tar.gz
ports-4cba7c3bd72726e2f48ae28e6d4366ba30e1487a.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fceux/Makefile42
-rw-r--r--emulators/fceux/distinfo6
-rw-r--r--emulators/fceux/files/patch-SConstruct33
-rw-r--r--emulators/fceux/files/patch-configure57
-rw-r--r--emulators/fceux/files/patch-configure.ac13
-rw-r--r--emulators/fceux/files/patch-src-drivers-common-vidblit.c11
-rw-r--r--emulators/fceux/files/patch-src-mappers-simple.c11
-rw-r--r--emulators/fceux/pkg-descr6
-rw-r--r--emulators/fceux/pkg-plist30
9 files changed, 89 insertions, 120 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index b69563468fb2..23322520f1f8 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -5,48 +5,40 @@
# $FreeBSD$
#
-PORTNAME= fceu
-PORTVERSION= 0.98.13
-PORTREVISION= 4
+PORTNAME= fceux
+PORTVERSION= 2.1.1
CATEGORIES= emulators
-MASTER_SITES= SF/${PORTNAME}ltra/Source%20Code/${PORTVERSION}-pre
-DISTNAME= ${PORTNAME}-${PORTVERSION}-pre.src
+MASTER_SITES= SF/fceultra/Source%20Code/${PORTVERSION}%20src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= chris@officialunix.com
COMMENT= A portable NES/Famicom emulator based on Bero's original FCE
USE_BZIP2= yes
-USE_GMAKE= yes
+USE_SCONS= yes
USE_SDL= sdl
+USE_DOS2UNIX= yes
+USE_LUA= yes
WRKSRC= ${WRKDIR}/fceu
-GNU_CONFIGURE= yes
+BUILD_DEPENDS+= zenity:${PORTSDIR}/x11/zenity
-MAN6= fceu.6
-
-PLIST_FILES= bin/fceu %%DOCSDIR%%/cheat.html %%DOCSDIR%%/faq.html \
- %%DOCSDIR%%/fceultra.html %%DOCSDIR%%/fcm.txt \
- %%DOCSDIR%%/fcs.txt %%DOCSDIR%%/protocol.txt
-PLIST_DIRS= %%DOCSDIR%%
+MAN6= fceux.6
.include <bsd.port.pre.mk>
post-extract:
- ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' ${WRKSRC}/src/drivers/common/vidblit.c
-
-pre-build:
- @${CP} ${WRKSRC}/Documentation/fceu-sdl.6 ${WRKSRC}/Documentation/fceu.6
+ ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
+ ${WRKSRC}/src/drivers/common/vidblit.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/fceu ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/Documentation/fceu.6 ${PREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/fceux ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/documentation/fceux.6 ${PREFIX}/man/man6
+ ${RM} ${WRKSRC}/documentation/fceux.6
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/cheat.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/faq.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/fceultra.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/fcm.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/fcs.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/protocol.txt ${DOCSDIR}
+ cd ${WRKSRC}/documentation && ${COPYTREE_SHARE} . ${DOCSDIR}/
+.endif
.include <bsd.port.post.mk>
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index e8d78187e9f1..3563dd79d5f8 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,3 +1,3 @@
-MD5 (fceu-0.98.13-pre.src.tar.bz2) = 1977214a15a341a4fd8bad14eda76866
-SHA256 (fceu-0.98.13-pre.src.tar.bz2) = a227f2d8a3b79462a895435be26c1622f03c5978d2e3e5456d6284592e88a6c2
-SIZE (fceu-0.98.13-pre.src.tar.bz2) = 570842
+MD5 (fceux-2.1.1.src.tar.bz2) = d669309a3fb15c002fffb24a801c2a9b
+SHA256 (fceux-2.1.1.src.tar.bz2) = 5f668de5870e28e4b52fcf8816c17831c0f9597307bd643c226a616a1766bdab
+SIZE (fceux-2.1.1.src.tar.bz2) = 3263945
diff --git a/emulators/fceux/files/patch-SConstruct b/emulators/fceux/files/patch-SConstruct
new file mode 100644
index 000000000000..ce2f68157ba2
--- /dev/null
+++ b/emulators/fceux/files/patch-SConstruct
@@ -0,0 +1,33 @@
+--- SConstruct.bak 2009-10-22 02:59:15.000000000 -0500
++++ SConstruct 2009-10-22 03:01:00.000000000 -0500
+@@ -14,7 +14,7 @@
+ BoolVariable('LOGO', 'Enable a logoscreen when creating avis (SDL only)', '1')
+ )
+
+-env = Environment(options = opts)
++env = Environment(ENV = os.environ, options = opts)
+
+ # LSB_FIRST must be off for PPC to compile
+ if platform.system == "ppc":
+@@ -35,6 +35,8 @@
+ env.Append(CCFLAGS = os.environ['CFLAGS'].split())
+ if os.environ.has_key('LDFLAGS'):
+ env.Append(LINKFLAGS = os.environ['LDFLAGS'].split())
++ env['CPPPATH'] = Split(env['CPPPATH'])
++ env['LIBPATH'] = Split(env['LIBPATH'])
+
+ print "platform: ", env['PLATFORM']
+
+@@ -51,9 +53,9 @@
+ env.Append(LIBS = ["rpcrt4", "comctl32", "vfw32", "winmm", "ws2_32", "comdlg32", "ole32", "gdi32", "htmlhelp"])
+ else:
+ conf = Configure(env)
+- if not conf.CheckLib('SDL'):
+- print 'Did not find libSDL or SDL.lib, exiting!'
+- Exit(1)
++### if not conf.CheckLib('SDL'):
++### print 'Did not find libSDL or SDL.lib, exiting!'
++### Exit(1)
+ if not conf.CheckLib('z', autoadd=1):
+ print 'Did not find libz or z.lib, exiting!'
+ Exit(1)
diff --git a/emulators/fceux/files/patch-configure b/emulators/fceux/files/patch-configure
deleted file mode 100644
index 16d3c59c5218..000000000000
--- a/emulators/fceux/files/patch-configure
+++ /dev/null
@@ -1,57 +0,0 @@
---- configure.orig Wed Sep 15 20:31:55 2004
-+++ configure Mon Feb 28 08:45:42 2005
-@@ -308,7 +308,7 @@
- # include <unistd.h>
- #endif"
-
--ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CPP CCAS CCASFLAGS CXX CXXFLAGS ac_ct_CXX CXXDEPMODE CXXCPP WIN32_TRUE WIN32_FALSE UNIX_TRUE UNIX_FALSE USE_SEXYAL_TRUE USE_SEXYAL_FALSE NATIVEWIN32_TRUE NATIVEWIN32_FALSE OPENGL_TRUE OPENGL_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE EGREP SDL_CONFIG SDL_CFLAGS SDL_LIBS C80x86_TRUE C80x86_FALSE LIBOBJS LTLIBOBJS'
-+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CPP CCAS CCASFLAGS CXX CXXFLAGS ac_ct_CXX CXXDEPMODE CXXCPP WIN32_TRUE WIN32_FALSE UNIX_TRUE UNIX_FALSE USE_SEXYAL_TRUE USE_SEXYAL_FALSE NATIVEWIN32_TRUE NATIVEWIN32_FALSE OPENGL_TRUE OPENGL_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE EGREP SDL_CONFIG SDL_CFLAGS SDL_LIBS LIBOBJS LTLIBOBJS'
- ac_subst_files=''
-
- # Initialize some variables set by options.
-@@ -5130,21 +5130,11 @@
- fi
-
-
--if expr match "$target_cpu" 'i.86' > /dev/null; then
-+if echo ${target_cpu} | grep -q 'i.86' > /dev/null; then
- cat >>confdefs.h <<\_ACEOF
- #define C80x86 1
- _ACEOF
-
--
--
--if true; then
-- C80x86_TRUE=
-- C80x86_FALSE='#'
--else
-- C80x86_TRUE='#'
-- C80x86_FALSE=
--fi
--
- fi
-
- echo "$as_me:$LINENO: checking whether byte ordering is bigendian" >&5
-@@ -5589,13 +5579,6 @@
- Usually this means the macro was only invoked conditionally." >&2;}
- { (exit 1); exit 1; }; }
- fi
--if test -z "${C80x86_TRUE}" && test -z "${C80x86_FALSE}"; then
-- { { echo "$as_me:$LINENO: error: conditional \"C80x86\" was never defined.
--Usually this means the macro was only invoked conditionally." >&5
--echo "$as_me: error: conditional \"C80x86\" was never defined.
--Usually this means the macro was only invoked conditionally." >&2;}
-- { (exit 1); exit 1; }; }
--fi
-
- : ${CONFIG_STATUS=./config.status}
- ac_clean_files_save=$ac_clean_files
-@@ -6188,8 +6171,6 @@
- s,@SDL_CONFIG@,$SDL_CONFIG,;t t
- s,@SDL_CFLAGS@,$SDL_CFLAGS,;t t
- s,@SDL_LIBS@,$SDL_LIBS,;t t
--s,@C80x86_TRUE@,$C80x86_TRUE,;t t
--s,@C80x86_FALSE@,$C80x86_FALSE,;t t
- s,@LIBOBJS@,$LIBOBJS,;t t
- s,@LTLIBOBJS@,$LTLIBOBJS,;t t
- CEOF
diff --git a/emulators/fceux/files/patch-configure.ac b/emulators/fceux/files/patch-configure.ac
deleted file mode 100644
index d75bfb586ecd..000000000000
--- a/emulators/fceux/files/patch-configure.ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac.orig Sat Sep 11 14:32:25 2004
-+++ configure.ac Mon Feb 28 08:46:24 2005
-@@ -114,9 +114,8 @@
- fi
-
-
--if expr match "$target_cpu" 'i.86' > /dev/null; then
-+if echo ${target_cpu} | grep -q 'i.86' > /dev/null; then
- AC_DEFINE([C80x86])
-- AM_CONDITIONAL(C80x86, true)
- fi
-
- AC_C_BIGENDIAN([], [AC_DEFINE([LSB_FIRST])])
diff --git a/emulators/fceux/files/patch-src-drivers-common-vidblit.c b/emulators/fceux/files/patch-src-drivers-common-vidblit.c
deleted file mode 100644
index dd42323ab40f..000000000000
--- a/emulators/fceux/files/patch-src-drivers-common-vidblit.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/drivers/common/vidblit.c.orig Tue Dec 21 15:43:20 2004
-+++ src/drivers/common/vidblit.c Tue Dec 21 15:43:44 2004
-@@ -79,7 +79,7 @@
- {
- if(specfilt == 2 || specfilt == 4) // scale2x and scale3x
- {
-- int multi;
-+ int multi = 0;
-
- if(specfilt == 2) multi = 2 * 2;
- else if(specfilt == 4) multi = 3 * 3;
diff --git a/emulators/fceux/files/patch-src-mappers-simple.c b/emulators/fceux/files/patch-src-mappers-simple.c
deleted file mode 100644
index acd066cb5e96..000000000000
--- a/emulators/fceux/files/patch-src-mappers-simple.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mappers/simple.c.orig Tue Dec 21 13:34:28 2004
-+++ src/mappers/simple.c Tue Dec 21 13:35:20 2004
-@@ -283,7 +283,7 @@
-
- static void M185Sync(int version)
- {
-- int x;
-+ //int x;
-
- //printf("%02x\n",mapbyte1[0]);
- //if((mapbyte1[0]&3)==3)
diff --git a/emulators/fceux/pkg-descr b/emulators/fceux/pkg-descr
index e83ddac8d7f5..7980d32f856b 100644
--- a/emulators/fceux/pkg-descr
+++ b/emulators/fceux/pkg-descr
@@ -10,3 +10,9 @@ images, headerless and FWNES style FDS disk images, and NSF files.
FCE Ultra currently supports the following iNES mappers(many partially):
WWW: http://fceultra.sourceforge.net/
+
+Chris Petrik
+http://www.bsdjunk.com
+
+Chris Petrik
+http://www.bsdjunk.com
diff --git a/emulators/fceux/pkg-plist b/emulators/fceux/pkg-plist
new file mode 100644
index 000000000000..12e11670f824
--- /dev/null
+++ b/emulators/fceux/pkg-plist
@@ -0,0 +1,30 @@
+bin/fceux
+%%PORTDOCS%%%%DOCSDIR%%/snes9x-lua.html
+%%PORTDOCS%%%%DOCSDIR%%/fcs.txt
+%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
+%%PORTDOCS%%%%DOCSDIR%%/todo
+%%PORTDOCS%%%%DOCSDIR%%/Videolog.txt
+%%PORTDOCS%%%%DOCSDIR%%/fm2.txt
+%%PORTDOCS%%%%DOCSDIR%%/porting.txt
+%%PORTDOCS%%%%DOCSDIR%%/cheat.html
+%%PORTDOCS%%%%DOCSDIR%%/tech/readme.now
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/vrcvii.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/smb2j.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/tengen.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/mmc5-e.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/vrcvi.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/4017.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound-4th.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/dmc.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/nsfspec.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/readme.sound
+%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/loopy2.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/2c02 technical operation.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/loopy1.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/ppu
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/cpu
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/exp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech
+%%PORTDOCS%%@dirrm %%DOCSDIR%%