aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
commit9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (patch)
tree043d479b1d60668b1d77568d010f6178e25bd6ba /emulators
parentc4823e883be563337dde9dde23949cde6c3fce0f (diff)
downloadports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.tar.gz
ports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bsvc/Makefile8
-rw-r--r--emulators/libvm68k/Makefile8
-rw-r--r--emulators/qcl/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/emulators/bsvc/Makefile b/emulators/bsvc/Makefile
index 2b30ae37366d..187e78123e35 100644
--- a/emulators/bsvc/Makefile
+++ b/emulators/bsvc/Makefile
@@ -18,6 +18,12 @@ COMMENT= An extensible hardware simulation framework with MC68K support
RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_REINPLACE= yes
@@ -32,4 +38,4 @@ post-patch:
${FIND} ${WRKSRC} -name Makefile -exec \
${REINPLACE_CMD} -e 's/make/$(MAKE)/' \{\} \;
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/libvm68k/Makefile b/emulators/libvm68k/Makefile
index fac31af7a38c..0d39389b4bec 100644
--- a/emulators/libvm68k/Makefile
+++ b/emulators/libvm68k/Makefile
@@ -15,8 +15,14 @@ MASTER_SITES= ftp://ftp.hypercore.co.jp/vx68k/${PORTNAME}-${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= M68000 virtual machine library
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/qcl/Makefile b/emulators/qcl/Makefile
index bb04b66cfbce..b8b40edb2f35 100644
--- a/emulators/qcl/Makefile
+++ b/emulators/qcl/Makefile
@@ -14,9 +14,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= huntting@glarp.com
COMMENT= A quantum computer simulator
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
post-install:
strip ${PREFIX}/bin/qcl
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>