aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-15 14:04:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-15 14:04:16 +0000
commit186af9c0cf95aecd9fffd7da5db05249fa881bc1 (patch)
tree21e469798674956537fa97b08bc1189716fe3132 /emulators
parent375a8ede1b00de7b986d62d0464788ff126749ba (diff)
downloadports-186af9c0cf95aecd9fffd7da5db05249fa881bc1.tar.gz
ports-186af9c0cf95aecd9fffd7da5db05249fa881bc1.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xgs/files/patch-imgutil.c39
-rw-r--r--emulators/xgs/pkg-plist16
2 files changed, 47 insertions, 8 deletions
diff --git a/emulators/xgs/files/patch-imgutil.c b/emulators/xgs/files/patch-imgutil.c
new file mode 100644
index 000000000000..5c46eabcff08
--- /dev/null
+++ b/emulators/xgs/files/patch-imgutil.c
@@ -0,0 +1,39 @@
+--- imgutil.c.orig Wed Oct 15 15:54:20 2003
++++ imgutil.c Wed Oct 15 15:56:02 2003
+@@ -53,8 +53,8 @@
+
+ int getSource()
+ {
+- printf("
+-Enter the source filename below or press RETURN to abort.
++ printf("\n\
++Enter the source filename below or press RETURN to abort.\n\
+ : ");
+ fgets(sourcefile,256,stdin);
+ sourcefile[strlen(sourcefile)-1]='\0';
+@@ -63,8 +63,8 @@
+
+ int getDest()
+ {
+- printf("
+-Enter the destination filename below or press RETURN to abort.
++ printf("\n\
++Enter the destination filename below or press RETURN to abort.\n\
+ : ");
+ fgets(destfile,256,stdin);
+ destfile[strlen(destfile)-1]='\0';
+@@ -82,10 +82,10 @@
+ char last;
+ int size;
+
+- printf("
+-Enter a size for this image in bytes. You may also specify the size in
+-kilobytes or megabytes by adding a 'K' or 'M' to the end of your input.
+-You may enter any size between 16K and 32M. To abort, just press RETURN.
++ printf("\n\
++Enter a size for this image in bytes. You may also specify the size in\n\
++kilobytes or megabytes by adding a 'K' or 'M' to the end of your input.\n\
++You may enter any size between 16K and 32M. To abort, just press RETURN.\n\
+ : ");
+ fgets(buffer,256,stdin);
+ if (!strlen(buffer)) return 0;
diff --git a/emulators/xgs/pkg-plist b/emulators/xgs/pkg-plist
index 3bbbb25458a7..45cb43009a21 100644
--- a/emulators/xgs/pkg-plist
+++ b/emulators/xgs/pkg-plist
@@ -1,16 +1,16 @@
bin/imgconv
bin/imgutil
bin/xgs
-%%PORTDOCS%%share/doc/xgs/CHANGES.TXT
-%%PORTDOCS%%share/doc/xgs/COMPAT.TXT
-%%PORTDOCS%%share/doc/xgs/INSTALL.TXT
-%%PORTDOCS%%share/doc/xgs/IWM-DOC.TXT
-%%PORTDOCS%%share/doc/xgs/README.FreeBSD
-%%PORTDOCS%%share/doc/xgs/TODO.TXT
-%%PORTDOCS%%share/doc/xgs/XGS-FAQ.TXT
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.TXT
+%%PORTDOCS%%%%DOCSDIR%%/COMPAT.TXT
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.TXT
+%%PORTDOCS%%%%DOCSDIR%%/IWM-DOC.TXT
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%%%DOCSDIR%%/TODO.TXT
+%%PORTDOCS%%%%DOCSDIR%%/XGS-FAQ.TXT
share/xgs/xgs.ram
share/xgs/xgs.rom
share/xgs/xgs40.fnt
share/xgs/xgs80.fnt
@dirrm share/xgs
-%%PORTDOCS%%@dirrm share/doc/xgs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%