aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-24 13:50:07 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-24 13:50:07 +0000
commitde0bdb9af34617b858b4df841e4322ff2a4d55dc (patch)
tree73654e7190a7cd40482979523353aed8c505bd1c /emulators
parent168aaa06b0f91694c76b52df7573ef638a87b24d (diff)
downloadports-de0bdb9af34617b858b4df841e4322ff2a4d55dc.tar.gz
ports-de0bdb9af34617b858b4df841e4322ff2a4d55dc.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 453745b883dc..ff488a86a1d7 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -23,7 +23,8 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
-OPTIONS= AES "Enable support of AES CPU extensions" off \
+OPTIONS= ACPI "Enable ACPI emulation" off \
+ AES "Enable support of AES CPU extensions" off \
CDROM "Enable CDROM support" on \
CLGD54XX "Enable Cirrus Logic GD54xx video card" off \
DEBUGGER "Enable debugger and disassembler support" off \
@@ -74,6 +75,10 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--with-nogui
.endif
+.if defined(WITH_ACPI)
+CONFIGURE_ARGS+=--enable-acpi
+.endif
+
.if defined(WITH_AES)
CONFIGURE_ARGS+=--enable-aes
.endif