aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-18 01:54:38 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-18 01:54:38 +0000
commite8032f9812037c676543b6ec0bc332f553607ea4 (patch)
tree9bd8f73c18b117f08aee15a117738099d8d4e090 /emulators
parenta8e7ad43133c7300413d3bd60dbcecb95fbb6424 (diff)
downloadports-e8032f9812037c676543b6ec0bc332f553607ea4.tar.gz
ports-e8032f9812037c676543b6ec0bc332f553607ea4.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-gentoo-stage1/Makefile37
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile37
2 files changed, 38 insertions, 36 deletions
diff --git a/emulators/linux_base-gentoo-stage1/Makefile b/emulators/linux_base-gentoo-stage1/Makefile
index 810399054a75..a7729ed5e8c9 100644
--- a/emulators/linux_base-gentoo-stage1/Makefile
+++ b/emulators/linux_base-gentoo-stage1/Makefile
@@ -9,45 +9,46 @@ PORTNAME= linux_base-gentoo-stage1
PORTVERSION= 1.4
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_GENTOO}
+EXTRACT_ONLY=
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Files from Gentoo distribution, for Linux compatibility
+
+BROKEN= incorrect packing list
+RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
+
+ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
+
USE_BZIP2= y
+
.include <bsd.port.pre.mk>
-BROKEN= incorrect packing list
+
PORTARCH=${MACHINE_ARCH:S/64//}
.if (${PORTARCH} == "alpha")
MASTER_SITE_SUBDIR= experimental/alpha/stages
DISTNAME= stage1-alpha-20030721
-.endif
-.if (${PORTARCH} == "amd")
+.elif (${PORTARCH} == "amd")
BROKEN= "Linux emulation is not available on x86-64"
IGNORE= ${BROKEN}
MASTER_SITE_SUBDIR= experimental/amd64/stages
DISTNAME= stage1-amd64-20040124
-.endif
-.if (${PORTARCH} == "ia")
+.elif (${PORTARCH} == "ia")
MASTER_SITE_SUBDIR= experimental/ia64
DISTNAME= stage1-ia64-20030912
-.endif
-.if (${PORTARCH} == "i386")
+.elif (${PORTARCH} == "i386")
MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
DISTNAME= stage1-x86-20030910
-.endif
-.if (${PORTARCH} == "sparc")
+.elif (${PORTARCH} == "sparc")
MASTER_SITE_SUBDIR= experimental/sparc/stages/sparc64
DISTNAME= stage1-sparc64-20031011
.endif
-DIST_SUBDIR= gentoo-linux
-EXTRACT_ONLY=
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Files from Gentoo distribution, for Linux compatibility
+DIST_SUBDIR= gentoo-linux
MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
NO_BUILD= y
-ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
PLIST= ${WRKDIR}/pkg-plist
PREFIX= ${LINUXBASE}
-RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
-CONFLICTS=cle_base-* linux_base-6* linux_base-7* linux_base-8* linux_base-debia*
+CONFLICTS= linux_base-6* linux_base-7* linux_base-8* linux_base-debian*
pre-install:
${ECHO_CMD} etc/resolv.conf > ${PLIST}
@@ -65,7 +66,7 @@ do-install:
${RM} ${PREFIX}/dev/null ${PREFIX}/dev/stdout
mknod ${PREFIX}/dev/null c 2 2
mknod ${PREFIX}/dev/stdout c 22 1
- brandelf -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
+ ${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index 810399054a75..a7729ed5e8c9 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -9,45 +9,46 @@ PORTNAME= linux_base-gentoo-stage1
PORTVERSION= 1.4
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_GENTOO}
+EXTRACT_ONLY=
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Files from Gentoo distribution, for Linux compatibility
+
+BROKEN= incorrect packing list
+RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
+
+ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
+
USE_BZIP2= y
+
.include <bsd.port.pre.mk>
-BROKEN= incorrect packing list
+
PORTARCH=${MACHINE_ARCH:S/64//}
.if (${PORTARCH} == "alpha")
MASTER_SITE_SUBDIR= experimental/alpha/stages
DISTNAME= stage1-alpha-20030721
-.endif
-.if (${PORTARCH} == "amd")
+.elif (${PORTARCH} == "amd")
BROKEN= "Linux emulation is not available on x86-64"
IGNORE= ${BROKEN}
MASTER_SITE_SUBDIR= experimental/amd64/stages
DISTNAME= stage1-amd64-20040124
-.endif
-.if (${PORTARCH} == "ia")
+.elif (${PORTARCH} == "ia")
MASTER_SITE_SUBDIR= experimental/ia64
DISTNAME= stage1-ia64-20030912
-.endif
-.if (${PORTARCH} == "i386")
+.elif (${PORTARCH} == "i386")
MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
DISTNAME= stage1-x86-20030910
-.endif
-.if (${PORTARCH} == "sparc")
+.elif (${PORTARCH} == "sparc")
MASTER_SITE_SUBDIR= experimental/sparc/stages/sparc64
DISTNAME= stage1-sparc64-20031011
.endif
-DIST_SUBDIR= gentoo-linux
-EXTRACT_ONLY=
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Files from Gentoo distribution, for Linux compatibility
+DIST_SUBDIR= gentoo-linux
MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
NO_BUILD= y
-ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
PLIST= ${WRKDIR}/pkg-plist
PREFIX= ${LINUXBASE}
-RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
-CONFLICTS=cle_base-* linux_base-6* linux_base-7* linux_base-8* linux_base-debia*
+CONFLICTS= linux_base-6* linux_base-7* linux_base-8* linux_base-debian*
pre-install:
${ECHO_CMD} etc/resolv.conf > ${PLIST}
@@ -65,7 +66,7 @@ do-install:
${RM} ${PREFIX}/dev/null ${PREFIX}/dev/stdout
mknod ${PREFIX}/dev/null c 2 2
mknod ${PREFIX}/dev/stdout c 22 1
- brandelf -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
+ ${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}