aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-10 08:44:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-10 08:44:55 +0000
commit323fc53b9dd484e6a8ca44304957f8dd163522a8 (patch)
tree19265a8a4c0288dde4ff235c91bcdd83b8384383 /emulators
parentc1f5b107bcfb1c1a691940f7eb91381d864eb41a (diff)
downloadports-323fc53b9dd484e6a8ca44304957f8dd163522a8.tar.gz
ports-323fc53b9dd484e6a8ca44304957f8dd163522a8.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/qcl/Makefile29
-rw-r--r--emulators/qcl/distinfo2
-rw-r--r--emulators/qcl/files/patch-aa136
-rw-r--r--emulators/qcl/files/patch-qc-Makefile49
-rw-r--r--emulators/qcl/pkg-descr5
-rw-r--r--emulators/qcl/pkg-plist12
7 files changed, 0 insertions, 234 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 3103de21c85e..7f45271c2e74 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -81,7 +81,6 @@
SUBDIR += pearpc
SUBDIR += prodosemu
SUBDIR += psim-freebsd
- SUBDIR += qcl
SUBDIR += qemu
SUBDIR += quasi88
SUBDIR += raine
diff --git a/emulators/qcl/Makefile b/emulators/qcl/Makefile
deleted file mode 100644
index ca4ec25ab4aa..000000000000
--- a/emulators/qcl/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# ports collection makefile for: qcl
-# Date created: 23 May 2001
-# Whom: Brad Huntting <huntting@glarp.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= qcl
-PORTVERSION= 0.6.1
-CATEGORIES= science math
-MASTER_SITES= http://tph.tuwien.ac.at/~oemer/tgz/
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= huntting@glarp.com
-COMMENT= A quantum computer simulator
-
-USE_GETOPT_LONG=yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
-do-configure:
- echo 'PREFIX=${PREFIX}' >>${WRKSRC}/Makefile
- cd ${WRKSRC} && make dep
-
-.include <bsd.port.post.mk>
diff --git a/emulators/qcl/distinfo b/emulators/qcl/distinfo
deleted file mode 100644
index 4a5ed447cc80..000000000000
--- a/emulators/qcl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (qcl-0.6.1.tgz) = ec5def302a468f95370a4ccc9f8aa35a
-SIZE (qcl-0.6.1.tgz) = 130922
diff --git a/emulators/qcl/files/patch-aa b/emulators/qcl/files/patch-aa
deleted file mode 100644
index 8e8a53392ec3..000000000000
--- a/emulators/qcl/files/patch-aa
+++ /dev/null
@@ -1,136 +0,0 @@
---- Makefile.orig Mon Mar 29 15:24:31 2004
-+++ Makefile Tue Feb 1 01:37:09 2005
-@@ -14,25 +14,25 @@
-
- # Directory for Standard .qcl files
-
--QCLDIR = /usr/local/lib/qcl
-+QCLDIR = ${PREFIX}/share/qcl
-
- # Path for qcl binaries
-
--QCLBIN = /usr/local/bin
-+QCLBIN = ${PREFIX}/bin
-
- # Debugging options
-
- #DEBUG = -g -pg -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
--DEBUG = -O2 -g -DQCL_DEBUG -DQC_DEBUG
-+DEBUG = -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -O2
-
- # Plotting support
- #
- # Comment out if you don't have GNU libplotter and X
-
--PLOPT = -DQCL_PLOT
--PLLIB = -L/usr/X11/lib -lplotter -lXaw -lXmu -lXt -lXext -lXpm -lSM -lICE -lX11
-+#PLOPT = -DQCL_PLOT
-+#PLLIB = -L/usr/X11/lib -lplotter -lXaw -lXmu -lXt -lXext -lXpm -lSM -lICE -lX11
- #PLLIB = -L/usr/X11/lib -lplotter -lXaw -lXmu -lXt -lXext -lX11
- #PLLIB = -L/usr/X11/lib -lplotter -lXaw -lXmu -Xt -lSM -ICE -lXext -lX11
-
-@@ -42,8 +42,8 @@
- # explicit linking against libtermcap or libncurses may be required
-
- RLOPT = -DQCL_USE_READLINE
--#RLLIB = -lreadline
--RLLIB = -lreadline -lncurses
-+RLLIB = -lreadline
-+#RLLIB = -lreadline -lncurses
-
- # Interrupt support
- #
-@@ -51,12 +51,6 @@
-
- IRQOPT = -DQCL_IRQ
-
--# Replace with lex and yacc on non-GNU systems (untested)
--
--LEX = flex
--YACC = bison
--INSTALL = install
--
- ##### You shouldn't have to edit the stuff below #####
-
- DATE = `date +"%y.%m.%d-%H%M"`
-@@ -65,13 +59,11 @@
- QCLIB = $(QCDIR)/libqc.a
- QCLINC = lib
-
--CC = g++
--CPP = $(CC) -E
--CFLAGS = -c -Wall $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
--LFLAGS = -L$(QCDIR) $(DEBUG) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-+CXXFLAGS += $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
-+LDFLAGS += -L$(QCDIR) $(DEBUG) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-
--FILESCC = $(wildcard *.cc)
--FILESH = $(wildcard *.h)
-+FILESCC = *.cc
-+FILESH = *.h
-
- SOURCE = $(FILESCC) $(FILESH) qcl.lex qcl.y Makefile
-
-@@ -79,23 +71,11 @@
- lex.o yacc.o print.o quheap.o extern.o eval.o exec.o \
- parse.o options.o debug.o cond.o dump.o plot.o format.o
-
--all: do-it-all
-+all: build
-
--ifeq (.depend,$(wildcard .depend))
--include .depend
--do-it-all: build
--else
--do-it-all: dep
-- make
--endif
--
--#### Rules for depend
--
--dep: lex.cc yacc.cc yacc.h $(QCLIB)
-- for i in *.cc; do \
-- $(CPP) -I$(QCDIR) -MM $$i; \
-- echo -e '\t$(CC) $(CFLAGS)' $$i '\n'; \
-- done > .depend
-+
-+dep:
-+ mkdep ${CXXFLAGS} ${FILESCC}
-
- lex.cc: qcl.lex
- $(LEX) -olex.cc qcl.lex
-@@ -107,26 +87,26 @@
- mv yacc.*?h yacc.h
-
- $(QCLIB):
-- cd $(QCDIR) && make libqc.a
-+ +cd ${QCDIR} && ${MAKE} ${MAKEFLAGS} libqc.a
-
- #### Rules for build
-
- build: qcl $(QCLINC)/default.qcl
-
- qcl: $(OBJECTS) qcl.o $(QCLIB)
-- $(CC) $(OBJECTS) qcl.o $(LFLAGS) -o qcl
-+ $(CXX) $(OBJECTS) qcl.o $(LDFLAGS) -o qcl
-
- qcl-static: $(OBJECTS) qcl.o $(QCLIB)
-- $(CC) -static $(OBJECTS) qcl.o $(LFLAGS) -o qcl-static
-+ $(CXX) -static $(OBJECTS) qcl.o $(LDFLAGS) -o qcl-static
- strip qcl-static
-
- $(QCLINC)/default.qcl: extern.cc
- grep "^//!" extern.cc | cut -c5- > $(QCLINC)/default.qcl
-
- install: build
-- $(INSTALL) -m 0755 -d $(QCLBIN) $(QCLDIR)
-- $(INSTALL) -m 0755 ./qcl $(QCLBIN)
-- $(INSTALL) -m 0644 ./lib/*.qcl $(QCLDIR)
-+ umask 022; mkdir -p $(QCLDIR); chmod 0755 $(QCLDIR)
-+ ${INSTALL} -m 0755 ./qcl $(QCLBIN)
-+ ${INSTALL} -m 0644 ./lib/*.qcl $(QCLDIR)
-
- uninstall:
- rm -f $(QCLBIN)
diff --git a/emulators/qcl/files/patch-qc-Makefile b/emulators/qcl/files/patch-qc-Makefile
deleted file mode 100644
index ae6da3f42dc4..000000000000
--- a/emulators/qcl/files/patch-qc-Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
---- qc/Makefile.orig Mon Mar 29 15:24:31 2004
-+++ qc/Makefile Tue Feb 1 01:27:33 2005
-@@ -12,7 +12,7 @@
-
- # Debugging options
-
--DEBUG = -g -O2 -DQC_DEBUG
-+DEBUG = -DQC_DEBUG
- #DEBUG = -g -pg -DQC_DEBUG
- #DEBUG = -O2
-
-@@ -21,10 +21,8 @@
-
- #PRGOPT = -DQC_USE_RAND48
-
--CC = g++
--CFLAGS = -c -pedantic -Wall $(DEBUG) $(PRGOPT)
--
--LNKOPT = -L. -lm -lqc
-+CXXFLAGS += $(DEBUG) $(PRGOPT)
-+LDFLAGS += -L. -lm -lqc
-
- FILESCC = bitvec.cc terms.cc qustates.cc operator.cc
- FILESH = bitvec.h terms.h qustates.h operator.h qc.h
-@@ -36,23 +34,9 @@
- ar rc libqc.a bitvec.o terms.o qustates.o operator.o
- ranlib libqc.a
-
--bitvec.o: bitvec.cc bitvec.h
-- $(CC) bitvec.cc -o bitvec.o $(CFLAGS)
--
--terms.o: terms.cc terms.h bitvec.h
-- $(CC) terms.cc -o terms.o $(CFLAGS)
--
--qustates.o: qustates.cc qustates.h terms.h bitvec.h
-- $(CC) qustates.cc -o qustates.o $(CFLAGS)
--
--operator.o: operator.cc operator.h qustates.h terms.h bitvec.h
-- $(CC) operator.cc -o operator.o $(CFLAGS)
--
--shor.o: shor.cc qustates.h terms.h bitvec.h
-- $(CC) shor.cc -o shor.o $(CFLAGS)
-
- shor: shor.o libqc.a
-- $(CC) shor.o -o shor $(LNKOPT)
-+ $(CXX) shor.o -o shor $(LDFLAGS)
-
- # Other Functions
-
diff --git a/emulators/qcl/pkg-descr b/emulators/qcl/pkg-descr
deleted file mode 100644
index 272a6df15c1b..000000000000
--- a/emulators/qcl/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This is a port of qcl, a quantum computer simulator.
-
-WWW: http://tph.tuwien.ac.at/~oemer/qcl.html
-
-- brad.huntting@glarp.com
diff --git a/emulators/qcl/pkg-plist b/emulators/qcl/pkg-plist
deleted file mode 100644
index 5a6cf3f01213..000000000000
--- a/emulators/qcl/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/qcl
-share/qcl/default.qcl
-share/qcl/deutsch.qcl
-share/qcl/dft.qcl
-share/qcl/examples.qcl
-share/qcl/grover.qcl
-share/qcl/linalg.qcl
-share/qcl/modarith.qcl
-share/qcl/primes.qcl
-share/qcl/shor.qcl
-share/qcl/test.qcl
-@dirrm share/qcl