aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-15 19:42:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-15 19:42:31 +0000
commit5b6ced962c15b799b0d9f41f10f0402d2b21a594 (patch)
tree52182304aeb34063926067795559d06c0822a4c4 /emulators
parentbe85566a2b72363c8ea4bdb44136f80d87739c1d (diff)
downloadports-5b6ced962c15b799b0d9f41f10f0402d2b21a594.tar.gz
ports-5b6ced962c15b799b0d9f41f10f0402d2b21a594.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile7
-rw-r--r--emulators/xmame/files/patch-makefile.mes11
-rw-r--r--emulators/xmame/files/patch-src-unix-unix.mak11
3 files changed, 22 insertions, 7 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 72ffe4acfed8..7dc59d7fdb29 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -253,13 +253,6 @@ do-configure:
.endfor
${LN} -s ${WRKSRC}/src/png.h ${WRKSRC}/src/mame_png.h
-.if ${MAMEMESS} == "mess"
-.if ${OSVERSION} < 500000
- ${REINPLACE_CMD} -e "s@-Wl,--allow-multiple-definition@@" \
- ${WRKSRC}/makefile.mes ${WRKSRC}/src/unix/unix.mak
-.endif
-.endif
-
post-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
${GMAKE} doc/x${MAMEMESS}.6
diff --git a/emulators/xmame/files/patch-makefile.mes b/emulators/xmame/files/patch-makefile.mes
new file mode 100644
index 000000000000..18d003b1872b
--- /dev/null
+++ b/emulators/xmame/files/patch-makefile.mes
@@ -0,0 +1,11 @@
+--- makefile.mes.orig Mon Feb 14 18:03:35 2005
++++ makefile.mes Mon Feb 14 18:05:09 2005
+@@ -344,7 +344,7 @@
+ $(OBJ)/mess/windows/parallel.o \
+ $(OBJ)/mess/windows/strconv.o
+ @echo Linking $@...
+- $(LD) $(LDFLAGS) $(CONSOLE_PROGRAM) $^ -Wl,--allow-multiple-definition $(ZLIB) $(LIBS) -lwinmm -o $@
++ touch $@
+
+ # secondary libraries
+ $(OBJ)/libexpat.a: $(OBJ)/expat/xmlparse.o $(OBJ)/expat/xmlrole.o $(OBJ)/expat/xmltok.o
diff --git a/emulators/xmame/files/patch-src-unix-unix.mak b/emulators/xmame/files/patch-src-unix-unix.mak
new file mode 100644
index 000000000000..3638f4ff4dee
--- /dev/null
+++ b/emulators/xmame/files/patch-src-unix-unix.mak
@@ -0,0 +1,11 @@
+--- src/unix/unix.mak.orig Mon Feb 14 18:08:49 2005
++++ src/unix/unix.mak Mon Feb 14 18:09:12 2005
+@@ -599,7 +599,7 @@
+ $(OBJDIR)/sysdep/rc.o \
+ $(OBJDIR)/tststubs.o
+ $(CC_COMMENT) @echo 'Linking $@...'
+- $(CC_COMPILE) $(LD) $(LDFLAGS) $(MY_LIBS) $^ -Wl,--allow-multiple-definition -o $@
++ touch $@
+
+ $(OBJDIR)/tststubs.o: src/unix/tststubs.c
+ $(CC_COMPILE) $(CC) $(MY_CFLAGS) -o $@ -c $<