aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-18 20:02:20 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-18 20:02:20 +0000
commit9da2cce1582d6a43d1d87e0331c21fca7e8aa79f (patch)
treefe34af671290a2c8ca9b8492fade7cdc02e1800d /emulators
parent4f199494e62ee8949f000e84da2f8c3a57ff8df8 (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/q4wine/Makefile14
-rw-r--r--emulators/q4wine/files/patch-src_q4wine-gui_process.cpp11
2 files changed, 15 insertions, 10 deletions
diff --git a/emulators/q4wine/Makefile b/emulators/q4wine/Makefile
index 9479eed527d0..9d53f2741bee 100644
--- a/emulators/q4wine/Makefile
+++ b/emulators/q4wine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= q4wine
DISTVERSION= 1.1-r2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION:S/.r/-r/}/
@@ -11,6 +11,7 @@ MAINTAINER= koalative@gmail.com
COMMENT= QT4 front-end for WINE
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= icotool:${PORTSDIR}/graphics/icoutils
RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
@@ -20,11 +21,10 @@ RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
USES= cmake desktop-file-utils
CMAKE_ARGS+= -DMANPAGE_ENTRY_PATH=${MANPREFIX}/man
-USE_GCC= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_QT4= qmake_build rcc_build moc_build uic_build \
- linguist_build corelib gui sql network
+ linguisttools_build corelib gui sql sql-sqlite3_run network
ONLY_FOR_ARCHS= i386 amd64
PORTDOCS= AUTHORS ChangeLog README TODO
@@ -34,11 +34,9 @@ OPTIONS_DEFAULT= DBUS
OPTIONS_SUB= yes
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-
DBUS_CMAKE_ON= -DWITH_DBUS:BOOL=ON
DBUS_CMAKE_OFF= -DWITH_DBUS:BOOL=OFF
+DBUS_USE= QT4=dbus
.include <bsd.port.options.mk>
@@ -46,10 +44,6 @@ DBUS_CMAKE_OFF= -DWITH_DBUS:BOOL=OFF
RUN_DEPENDS+= wine:${PORTSDIR}/emulators/wine-devel
.endif
-.if ${PORT_OPTIONS:MDBUS}
-USE_QT4+= dbus
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/share/man|/man|' \
${WRKSRC}/src/CMakeLists.txt
diff --git a/emulators/q4wine/files/patch-src_q4wine-gui_process.cpp b/emulators/q4wine/files/patch-src_q4wine-gui_process.cpp
new file mode 100644
index 000000000000..73264d956d24
--- /dev/null
+++ b/emulators/q4wine/files/patch-src_q4wine-gui_process.cpp
@@ -0,0 +1,11 @@
+--- src/q4wine-gui/process.cpp.orig 2015-07-24 20:19:50 UTC
++++ src/q4wine-gui/process.cpp
+@@ -16,6 +16,8 @@
+ * *
+ ***************************************************************************/
+
++#include <locale.h>
++
+ #include "process.h"
+
+ Process::Process (QStringList args, QString exec, QString dir, QString info, QString caption, bool showErr, QStringList env, QWidget * parent, Qt::WFlags f)