aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-25 18:38:03 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-25 18:38:03 +0000
commitf2cf00459f6f1e3aa024c24f4639953065705e64 (patch)
tree9be265c97574e81661a5b87f2bfcbf32282cd971 /emulators
parentcbc6df9510a4b98a800caaa92016d318b661d46a (diff)
downloadports-f2cf00459f6f1e3aa024c24f4639953065705e64.tar.gz
ports-f2cf00459f6f1e3aa024c24f4639953065705e64.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/hercules/Makefile47
-rw-r--r--emulators/hercules/distinfo4
-rw-r--r--emulators/hercules/pkg-plist10
3 files changed, 19 insertions, 42 deletions
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index b6388a5a6e82..8c1d70cec92c 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -2,25 +2,31 @@
# $FreeBSD$
PORTNAME= hercules
-PORTVERSION= 3.08
+PORTVERSION= 3.09
CATEGORIES= emulators
MASTER_SITES= http://downloads.hercules-390.eu/
MAINTAINER= ports@FreeBSD.org
COMMENT= System/370, ESA/390, and z/Architecture Emulator
-OPTIONS_DEFINE= DEBUG NLS PTHREADS
-OPTIONS_DEFAULT= NLS PTHREADS
+OPTIONS_DEFINE= DEBUG PTHREADS OPTIMIZATIONS DOCS
+OPTIONS_DEFAULT= PTHREADS
PTHREADS_DESC= Build with pthreads instead of fthreads
+OPTIMIZATIONS_DESC= Enable optimizations
USE_AUTOTOOLS= libtool libltdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CFLAGS+= -I/usr/local/include
+LDFLAGS+= -L/usr/local/lib
+
PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DEBUG_CFLAGS= -g
+PTHREADS_CONFIGURE_ON= --disable-fthreads
+OPTIMIZATIONS_CONFIGURE_ON= --enable-optimization="yes"
+OPTIMIZATIONS_CONFIGURE_OFF= --enable-optimization="no"
post-extract:
@${RM} ${WRKSRC}/ltdl.*
@@ -28,39 +34,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's@SOL_TCP@IPPROTO_TCP@g' ${WRKSRC}/hscutl.c
-.if empty(PORT_OPTIONS:MDOCS)
- @${REINPLACE_CMD} -e 's,^SUBDIRS = decNumber m4 po util html man . crypto,SUBDIRS = decNumber m4 po util man . crypto,g' ${WRKSRC}/Makefile.in
-.else
@${REINPLACE_CMD} -e 's,^datadir = @datadir@,datadir = ${PREFIX}/share/doc/,' ${WRKSRC}/html/Makefile.in
-.endif
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
'/^libherc_la_LIBADD/s|=|= -lltdl |g'
-MAN1= cckddiag.1 dasdseq.1
-MAN4= cckd.4
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.if ${PORT_OPTIONS:MDEBUG}
-CFLAGS+= -g
-.endif
-
-.if ${PORT_OPTIONS:MPTHREADS}
-CONFIGURE_ARGS+= --disable-fthreads
-.endif
-
-.if empty(PORT_OPTIONS:MNLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= GETTEXT="@comment "
-.else
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
-USES+= gettext
-PLIST_SUB+= GETTEXT=""
-.endif
-
-.if defined(CFLAGS)
-CONFIGURE_ARGS+= --enable-optimization="no"
-.endif
-
.include <bsd.port.mk>
diff --git a/emulators/hercules/distinfo b/emulators/hercules/distinfo
index 2ff1c9e2a26a..40c7e1a18b71 100644
--- a/emulators/hercules/distinfo
+++ b/emulators/hercules/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hercules-3.08.tar.gz) = 85e217773587f2278d4b6cb6bc815e042cfc982d0fc14baa0da4a84dea399e9d
-SIZE (hercules-3.08.tar.gz) = 2684844
+SHA256 (hercules-3.09.tar.gz) = 98a6029d908943451635ba53acf97ed61fdf6ebafc4402be7137c620851fe4e7
+SIZE (hercules-3.09.tar.gz) = 2567052
diff --git a/emulators/hercules/pkg-plist b/emulators/hercules/pkg-plist
index d4b15286a8c1..6b93bc98f9e3 100644
--- a/emulators/hercules/pkg-plist
+++ b/emulators/hercules/pkg-plist
@@ -72,7 +72,10 @@ lib/hercules/hdteq.la
lib/hercules/hdteq.so
lib/hercules/hdtqeth.la
lib/hercules/hdtqeth.so
-@dirrm lib/hercules
+man/man1/cckddiag.1.gz
+man/man1/dasdseq.1.gz
+man/man1/hercules.1.gz
+man/man4/cckd.4.gz
%%DATADIR%%/TMOUNT.txt
%%DATADIR%%/awssl-v19g
%%DATADIR%%/awswrite.jcl
@@ -81,6 +84,5 @@ lib/hercules/hdtqeth.so
%%DATADIR%%/rawstape.jcl
%%DATADIR%%/tapeconv.jcl
%%DATADIR%%/zzsacard.bin
-@dirrm share/hercules
-%%GETTEXT%%share/locale/de/LC_MESSAGES/hercules.mo
-%%GETTEXT%%share/locale/nl/LC_MESSAGES/hercules.mo
+@dirrm %%DATADIR%%
+@dirrm lib/hercules