aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-14 05:17:09 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-14 05:17:09 +0000
commit67b8cfeeef1992497579b2585c64a9ce0154f979 (patch)
tree62287095b3684cca5442e55573d91a2d6da2555c /emulators
parentfb302a8778b0c1fae28ac3e7cd6a339601ae8e6c (diff)
downloadports-67b8cfeeef1992497579b2585c64a9ce0154f979.tar.gz
ports-67b8cfeeef1992497579b2585c64a9ce0154f979.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile5
-rw-r--r--emulators/qemu-devel/distinfo4
-rw-r--r--emulators/qemu-devel/files/patch-vl.c21
-rw-r--r--emulators/qemu/Makefile5
-rw-r--r--emulators/qemu/distinfo4
-rw-r--r--emulators/qemu/files/patch-vl.c21
6 files changed, 48 insertions, 12 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 0b398be15b96..b9450090fff5 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= qemu
-PORTVERSION= 0.7.2s.20051030
+PORTVERSION= 0.7.2s.20051112
PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
+ http://www.volny.cz/xnavara/qemu/:snapshot \
http://qemu.dad-answers.com/download/qemu/:snapshot
-DISTNAME= ${PORTNAME}-snapshot-2005-10-30_23
+DISTNAME= ${PORTNAME}-snapshot-2005-11-12_23
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
MAINTAINER= nox@jelal.kn-bremen.de
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index f08c3a161c2f..67275c763f8b 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (qemu-snapshot-2005-10-30_23.tar.bz2) = d41b56254cc8704aef80fd188e30e95a
-SIZE (qemu-snapshot-2005-10-30_23.tar.bz2) = 1162650
+MD5 (qemu-snapshot-2005-11-12_23.tar.bz2) = 27673ed3a6bc78b4be2933ddc63f8276
+SIZE (qemu-snapshot-2005-11-12_23.tar.bz2) = 1219984
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 85a521ba3bd0..5eff6568373b 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -1,4 +1,5 @@
-Index: qemu/vl.c
+--- vl.c.orig Mon Nov 14 15:55:56 2005
++++ vl.c Mon Nov 14 15:57:25 2005
@@ -40,6 +40,10 @@
#include <sys/socket.h>
#include <netinet/in.h>
@@ -10,7 +11,7 @@ Index: qemu/vl.c
#ifdef _BSD
#include <sys/stat.h>
#ifndef __APPLE__
-@@ -1280,7 +1284,7 @@
+@@ -1363,7 +1367,7 @@
return chr;
}
@@ -19,3 +20,19 @@ Index: qemu/vl.c
CharDriverState *qemu_chr_open_pty(void)
{
char slave_name[1024];
+@@ -1509,6 +1513,7 @@
+ return chr;
+ }
+
++#if defined(__linux__)
+ static int pp_ioctl(CharDriverState *chr, int cmd, void *arg)
+ {
+ int fd = (int)chr->opaque;
+@@ -1571,6 +1576,7 @@
+ chr->chr_ioctl = pp_ioctl;
+ return chr;
+ }
++#endif
+
+ #else
+ CharDriverState *qemu_chr_open_pty(void)
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 0b398be15b96..b9450090fff5 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= qemu
-PORTVERSION= 0.7.2s.20051030
+PORTVERSION= 0.7.2s.20051112
PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
+ http://www.volny.cz/xnavara/qemu/:snapshot \
http://qemu.dad-answers.com/download/qemu/:snapshot
-DISTNAME= ${PORTNAME}-snapshot-2005-10-30_23
+DISTNAME= ${PORTNAME}-snapshot-2005-11-12_23
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
MAINTAINER= nox@jelal.kn-bremen.de
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index f08c3a161c2f..67275c763f8b 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,2 +1,2 @@
-MD5 (qemu-snapshot-2005-10-30_23.tar.bz2) = d41b56254cc8704aef80fd188e30e95a
-SIZE (qemu-snapshot-2005-10-30_23.tar.bz2) = 1162650
+MD5 (qemu-snapshot-2005-11-12_23.tar.bz2) = 27673ed3a6bc78b4be2933ddc63f8276
+SIZE (qemu-snapshot-2005-11-12_23.tar.bz2) = 1219984
diff --git a/emulators/qemu/files/patch-vl.c b/emulators/qemu/files/patch-vl.c
index 85a521ba3bd0..5eff6568373b 100644
--- a/emulators/qemu/files/patch-vl.c
+++ b/emulators/qemu/files/patch-vl.c
@@ -1,4 +1,5 @@
-Index: qemu/vl.c
+--- vl.c.orig Mon Nov 14 15:55:56 2005
++++ vl.c Mon Nov 14 15:57:25 2005
@@ -40,6 +40,10 @@
#include <sys/socket.h>
#include <netinet/in.h>
@@ -10,7 +11,7 @@ Index: qemu/vl.c
#ifdef _BSD
#include <sys/stat.h>
#ifndef __APPLE__
-@@ -1280,7 +1284,7 @@
+@@ -1363,7 +1367,7 @@
return chr;
}
@@ -19,3 +20,19 @@ Index: qemu/vl.c
CharDriverState *qemu_chr_open_pty(void)
{
char slave_name[1024];
+@@ -1509,6 +1513,7 @@
+ return chr;
+ }
+
++#if defined(__linux__)
+ static int pp_ioctl(CharDriverState *chr, int cmd, void *arg)
+ {
+ int fd = (int)chr->opaque;
+@@ -1571,6 +1576,7 @@
+ chr->chr_ioctl = pp_ioctl;
+ return chr;
+ }
++#endif
+
+ #else
+ CharDriverState *qemu_chr_open_pty(void)