aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-01-26 03:20:55 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-01-26 03:20:55 +0000
commit70f8171c6a1634a284f92b93c42d771b5113fc17 (patch)
tree79cebf38b73eed85286ef4675482ec2ecb3ae432 /emulators
parenta87c66f8f69d2496ef7c7666873d1cb07163b6a1 (diff)
downloadports-70f8171c6a1634a284f92b93c42d771b5113fc17.tar.gz
ports-70f8171c6a1634a284f92b93c42d771b5113fc17.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/desmume/Makefile34
-rw-r--r--emulators/desmume/distinfo4
-rw-r--r--emulators/desmume/files/patch-src_gtk_glx_3Demu.cpp14
-rw-r--r--emulators/desmume/files/patch-src_utils_task.cpp22
-rw-r--r--emulators/desmume/pkg-plist3
5 files changed, 51 insertions, 26 deletions
diff --git a/emulators/desmume/Makefile b/emulators/desmume/Makefile
index a0399ae15f48..e870234c61c5 100644
--- a/emulators/desmume/Makefile
+++ b/emulators/desmume/Makefile
@@ -2,24 +2,27 @@
# $FreeBSD$
PORTNAME= desmume
-PORTVERSION= 0.9.8
+PORTVERSION= 0.9.10
CATEGORIES= emulators
MASTER_SITES= SF
-MAINTAINER= llc2w@virginia.edu
+MAINTAINER= hardy.schumacher@gmx.de
COMMENT= Nintendo DS emulator
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
+ libSoundTouch.so:${PORTSDIR}/audio/soundtouch
USE_GL= gl
USE_SDL= sdl
USE_GNOME= gtk20 libglade2
-USES= gettext gmake pkgconfig
+USES= dos2unix gettext gmake pkgconfig
+DOS2UNIX_FILES= src/utils/task.cpp
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= GMSGFMT=msgfmt DATADIRNAME=share
+CONFIGURE_ARGS= --enable-glade
USE_AUTOTOOLS= aclocal autoconf
ACLOCAL_ARGS=
@@ -29,23 +32,6 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -DGTKGLEXT_AVAILABLE \
-DHAVE_LIBGDKGLEXT_X11_1_0 -DHAVE_GL_GL_H -DHAVE_GL_GLU_H
CXXFLAGS+= ${CFLAGS}
-MAN1= desmume-cli.1 \
- desmume-glade.1 \
- desmume.1
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile on ia64
-.endif
-
-post-patch:
-# FreeBSD 7.x is missing strnlen(), adjusting this enables a builtin version of strnlen()
-.if ${OSVERSION} < 800000
- @${REINPLACE_CMD} -e 's|#ifdef __APPLE__|#if 1|g; \
- /AvailabilityMacros\.h/d' \
- ${WRKSRC}/src/utils/libfat/directory.cpp
-.endif
+BROKEN_ia64= Does not compile on ia64
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/desmume/distinfo b/emulators/desmume/distinfo
index be79145c1cb1..b70f192cf1d6 100644
--- a/emulators/desmume/distinfo
+++ b/emulators/desmume/distinfo
@@ -1,2 +1,2 @@
-SHA256 (desmume-0.9.8.tar.gz) = 78363468a2d5efba95de57739a9c81a3757ecd76c2a183ec68336e30d47a5e01
-SIZE (desmume-0.9.8.tar.gz) = 3677290
+SHA256 (desmume-0.9.10.tar.gz) = 8900a7a1fc849fdd33b014748dd97a6cda4c32548b8d2e06511e6ed8d5ba7445
+SIZE (desmume-0.9.10.tar.gz) = 4141586
diff --git a/emulators/desmume/files/patch-src_gtk_glx_3Demu.cpp b/emulators/desmume/files/patch-src_gtk_glx_3Demu.cpp
new file mode 100644
index 000000000000..48f770e8d5b4
--- /dev/null
+++ b/emulators/desmume/files/patch-src_gtk_glx_3Demu.cpp
@@ -0,0 +1,14 @@
+--- src/gtk/glx_3Demu.cpp.orig 2013-11-28 01:36:53.712615000 +0100
++++ src/gtk/glx_3Demu.cpp 2013-12-14 20:08:01.000000000 +0100
+@@ -41,11 +41,7 @@
+ glXDestroyContext(dpy, ctx);
+
+ XCloseDisplay(dpy);
+-
+- return true;
+ }
+-
+- return false;
+ }
+
+ int init_glx_3Demu(void)
diff --git a/emulators/desmume/files/patch-src_utils_task.cpp b/emulators/desmume/files/patch-src_utils_task.cpp
new file mode 100644
index 000000000000..9ae14e3e8a61
--- /dev/null
+++ b/emulators/desmume/files/patch-src_utils_task.cpp
@@ -0,0 +1,22 @@
+--- src/utils/task.cpp.orig 2013-11-28 01:37:27.373159000 +0100
++++ src/utils/task.cpp 2013-12-14 19:49:02.000000000 +0100
+@@ -26,6 +26,7 @@
+ #if defined HOST_LINUX || defined HOST_DARWIN
+ #include <unistd.h>
+ #elif defined HOST_BSD
++#include <iostream>
+ #include <sys/sysctl.h>
+ #endif
+ #endif // HOST_WINDOWS
+@@ -41,9 +42,8 @@
+ return sysconf(_SC_NPROCESSORS_ONLN);
+ #elif defined HOST_BSD
+ int cores;
+- const int mib[4] = { CTL_HW, HW_NCPU, 0, 0 };
+- const size_t len = sizeof(cores);
+- sysctl(mib, 2, &cores, &len, NULL, 0);
++ size_t len = sizeof(cores);
++ sysctlbyname("hw.ncpu", &cores, &len, NULL, 0);
+ return (cores < 1) ? 1 : cores;
+ #else
+ return 1;
diff --git a/emulators/desmume/pkg-plist b/emulators/desmume/pkg-plist
index 61881a3a8874..fd1f123b2004 100644
--- a/emulators/desmume/pkg-plist
+++ b/emulators/desmume/pkg-plist
@@ -1,6 +1,9 @@
bin/desmume
bin/desmume-cli
bin/desmume-glade
+man/man1/desmume-cli.1.gz
+man/man1/desmume-glade.1.gz
+man/man1/desmume.1.gz
share/applications/desmume-glade.desktop
share/applications/desmume.desktop
%%DATADIR%%/glade/DeSmuME.xpm