aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-27 19:55:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-27 19:55:11 +0000
commitd8ed500a4c696b5289d0acf51035c199e09738b1 (patch)
tree62c68ab3702ce04319650afcae492a657c2127bc /emulators
parent327b7a360d437b3525e77d7d536339c4b0f37d8b (diff)
downloadports-d8ed500a4c696b5289d0acf51035c199e09738b1.tar.gz
ports-d8ed500a4c696b5289d0acf51035c199e09738b1.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/hercules/Makefile18
-rw-r--r--emulators/hercules/files/patch-libtool61
-rw-r--r--emulators/hercules/pkg-plist3
3 files changed, 5 insertions, 77 deletions
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index ca23f98b3280..132fc159a601 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -3,36 +3,28 @@
PORTNAME= hercules
PORTVERSION= 3.10
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://downloads.hercules-390.eu/
MAINTAINER= ports@FreeBSD.org
COMMENT= System/370, ESA/390, and z/Architecture Emulator
-USES= iconv perl5 shebangfix
+# :keepla because port uses lt_dlopen
+USES= iconv libtool:keepla perl5 shebangfix
SHEBANG_FILES= util/bldlvlck
-USE_AUTOTOOLS= libtool libltdl
-CONFIGURE_ARGS= --enable-optimization="no"
USE_LDCONFIG= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-optimization
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-post-extract:
- @${RM} -f ${WRKSRC}/ltdl.h
-
post-patch:
@${REINPLACE_CMD} -e \
- '/LIBS/s|-lpthread|-pthread|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
's|SOL_TCP|IPPROTO_TCP|g' ${WRKSRC}/hscutl.c
@${REINPLACE_CMD} -e \
'/^pkgdatadir/s|=.*|= $$(docdir)|' ${WRKSRC}/html/Makefile.in
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- '/^libherc_la_LIBADD/s|=|= -lltdl |g'
.include <bsd.port.mk>
diff --git a/emulators/hercules/files/patch-libtool b/emulators/hercules/files/patch-libtool
deleted file mode 100644
index b0653d91a5b8..000000000000
--- a/emulators/hercules/files/patch-libtool
+++ /dev/null
@@ -1,61 +0,0 @@
---- Makefile.in.orig 2013-04-04 14:07:19.184726980 +0300
-+++ Makefile.in 2013-04-04 14:08:33.594716391 +0300
-@@ -370,10 +370,10 @@
- libhercu_la_DEPENDENCIES = $(am__DEPENDENCIES_1) libhercs.la
- am__libhercu_la_SOURCES_DIST = version.c hscutl.c hscutl2.c codepage.c \
- logger.c logmsg.c hdl.c hostinfo.c hsocket.c memrchr.c \
-- parser.c pttrace.c fthreads.c ltdl.c
-+ parser.c pttrace.c fthreads.c
- am__objects_5 = fthreads.lo
- @BUILD_FTHREADS_TRUE@am__objects_6 = $(am__objects_5)
--@OPTION_DYNAMIC_LOAD_TRUE@am__objects_7 = ltdl.lo
-+#@OPTION_DYNAMIC_LOAD_TRUE@am__objects_7 = ltdl.lo
- am_libhercu_la_OBJECTS = version.lo hscutl.lo hscutl2.lo codepage.lo \
- logger.lo logmsg.lo hdl.lo hostinfo.lo hsocket.lo memrchr.lo \
- parser.lo pttrace.lo $(am__objects_6) $(am__objects_7)
-@@ -833,8 +833,8 @@
- @BUILD_SHARED_TRUE@XSTATIC =
- @OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
- @OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
--@OPTION_DYNAMIC_LOAD_FALSE@LTDL =
--@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ltdl.c
-+#@OPTION_DYNAMIC_LOAD_FALSE@LTDL =
-+#@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ltdl.c
- @OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
- @OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
- @OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
-@@ -984,7 +984,7 @@
- parser.c \
- pttrace.c \
- $(FTHREADS) \
-- $(LTDL)
-+# $(LTDL)
-
- libhercu_la_LDFLAGS = $(LIB_LD_FLAGS)
- libhercu_la_LIBADD = $(LDADD) libhercs.la
-@@ -1059,7 +1059,7 @@
- $(dynamic_SRC) \
- $(extra_SRC) \
- $(dyndev_SRC) \
-- ltdl.c
-+# ltdl.c
-
- libherc_la_LDFLAGS = $(LIB_LD_FLAGS)
- libherc_la_LIBADD = libhercs.la \
-@@ -1302,7 +1302,6 @@
- hdl.h \
- crypto.h \
- sockdev.h \
-- ltdl.h \
- herc_getopt.h \
- service.h \
- chsc.h \
-@@ -1711,7 +1710,7 @@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logger.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logmsg.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/losc.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ltdl.Plo@am__quote@
-+#@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ltdl.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/machchk.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memrchr.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/omatape.Plo@am__quote@
diff --git a/emulators/hercules/pkg-plist b/emulators/hercules/pkg-plist
index 31045fb1144d..6b0c3624c00a 100644
--- a/emulators/hercules/pkg-plist
+++ b/emulators/hercules/pkg-plist
@@ -28,7 +28,6 @@ bin/hetupd
bin/tapecopy
bin/tapemap
bin/tapesplt
-lib/hercules/dyncrypt.a
lib/hercules/dyncrypt.la
lib/hercules/dyncrypt.so
lib/hercules/dyngui.la
@@ -59,7 +58,6 @@ lib/hercules/hdteq.la
lib/hercules/hdteq.so
lib/hercules/hdtqeth.la
lib/hercules/hdtqeth.so
-lib/libdecNumber.a
lib/libdecNumber.la
lib/libdecNumber.so
lib/libherc.la
@@ -72,7 +70,6 @@ lib/libherct.la
lib/libherct.so
lib/libhercu.la
lib/libhercu.so
-lib/libsoftfloat.a
lib/libsoftfloat.la
lib/libsoftfloat.so
man/man1/cckddiag.1.gz