aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-07-15 11:36:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-07-15 11:36:14 +0000
commit0271c4bcd606af8f301ee9f8b42e6f7a55ba90c5 (patch)
treebc6c5588210f9ae9c8b2afed1f8832cf946027c6 /emulators
parent8e7806a9f4bd1e24e2be9a346384f4b8fdfe5f3e (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ppsspp-devel/Makefile6
-rw-r--r--emulators/ppsspp-devel/distinfo8
-rw-r--r--emulators/ppsspp-devel/files/patch-Core_FileLoaders_HTTPFileLoader.cpp (renamed from emulators/ppsspp-devel/files/patch-Core_Loaders.cpp)13
3 files changed, 13 insertions, 14 deletions
diff --git a/emulators/ppsspp-devel/Makefile b/emulators/ppsspp-devel/Makefile
index e9f2a792d74f..3560bce18a02 100644
--- a/emulators/ppsspp-devel/Makefile
+++ b/emulators/ppsspp-devel/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
-DISTVERSION= 1.0.1-600
-DISTVERSIONSUFFIX= -gc27e634
+DISTVERSION= 1.0.1-757
+DISTVERSIONSUFFIX= -g73e9c3b
PORTREVISION= 0
PKGNAMESUFFIX= -devel
-GH_TAGNAME= e855bc7:lang ba829ad:native a0b878f:ext_armips
+GH_TAGNAME= e855bc7:lang ad53018:native a0b878f:ext_armips
CONFLICTS_INSTALL?= ${PORTNAME}-[0-9]*
diff --git a/emulators/ppsspp-devel/distinfo b/emulators/ppsspp-devel/distinfo
index 4adf84710103..f4fd6782429c 100644
--- a/emulators/ppsspp-devel/distinfo
+++ b/emulators/ppsspp-devel/distinfo
@@ -1,8 +1,8 @@
-SHA256 (hrydgard-ppsspp-v1.0.1-600-gc27e634_GH0.tar.gz) = 1f28f4122c64c0c0ee2631a8b6182f0ed9119e7a177ba9af4a3a318753b4bec2
-SIZE (hrydgard-ppsspp-v1.0.1-600-gc27e634_GH0.tar.gz) = 13519815
+SHA256 (hrydgard-ppsspp-v1.0.1-757-g73e9c3b_GH0.tar.gz) = 531e41a33f16020509d0c7a46108926ec316c614d6b2057886415b86ed49b23d
+SIZE (hrydgard-ppsspp-v1.0.1-757-g73e9c3b_GH0.tar.gz) = 13545189
SHA256 (hrydgard-ppsspp-lang-e855bc7_GH0.tar.gz) = be0e5762e1943f789a723bbcde7a8e4c37c0111e4dbaf87e4d19d1e37929e84b
SIZE (hrydgard-ppsspp-lang-e855bc7_GH0.tar.gz) = 200648
-SHA256 (hrydgard-native-ba829ad_GH0.tar.gz) = 5716b694d6acdf97977a24ebffbdd6a6d935ed61b257ed16d6b08232d067a4eb
-SIZE (hrydgard-native-ba829ad_GH0.tar.gz) = 1399345
+SHA256 (hrydgard-native-ad53018_GH0.tar.gz) = 04772fa654bf403db92a3044f08961da2768a63a5be3c1e6803feb32413e5457
+SIZE (hrydgard-native-ad53018_GH0.tar.gz) = 1399703
SHA256 (Kingcom-armips-a0b878f_GH0.tar.gz) = 64623bbddda609f9692904e6b6823b1d2d4dd0149349f2be9edcc600bf12bafa
SIZE (Kingcom-armips-a0b878f_GH0.tar.gz) = 136535
diff --git a/emulators/ppsspp-devel/files/patch-Core_Loaders.cpp b/emulators/ppsspp-devel/files/patch-Core_FileLoaders_HTTPFileLoader.cpp
index de1062fb80b9..ce9bd4122535 100644
--- a/emulators/ppsspp-devel/files/patch-Core_Loaders.cpp
+++ b/emulators/ppsspp-devel/files/patch-Core_FileLoaders_HTTPFileLoader.cpp
@@ -1,5 +1,5 @@
---- Core/Loaders.cpp.orig 2015-02-26 20:05:06 UTC
-+++ Core/Loaders.cpp
+--- Core/FileLoaders/HTTPFileLoader.cpp.orig 2015-07-11 22:44:11 UTC
++++ Core/FileLoaders/HTTPFileLoader.cpp
@@ -15,6 +15,9 @@
// Official git repository and contact information can be found at
// https://github.com/hrydgard/ppsspp and http://www.ppsspp.org/.
@@ -8,13 +8,12 @@
+#define _GLIBCXX_USE_C99 1
+
#include <algorithm>
- #include <cstdio>
-
-@@ -310,12 +313,7 @@ HTTPFileLoader::HTTPFileLoader(const std
- size_pos = header.find_first_not_of(' ', size_pos);
+ #include "base/stringutil.h"
+ #include "Common/Common.h"
+@@ -53,11 +56,7 @@ HTTPFileLoader::HTTPFileLoader(const std
}
if (size_pos != header.npos) {
-- // TODO: Find a way to get this to work right on Symbian?
+ // TODO: Find a way to get this to work right on Symbian?
-#ifndef __SYMBIAN32__
- filesize_ = atoll(&header[size_pos]);
-#else