aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-05-06 19:48:21 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-05-06 19:48:21 +0000
commit2fbafc1ba456a8fbaaa7ca7e362b7f6d4e1dd1ea (patch)
tree6aca1649a4eb784847161ce7770257be44c22fcb /emulators
parent123a564c91e842b82890832b15322c5670cd5b20 (diff)
downloadports-2fbafc1ba456a8fbaaa7ca7e362b7f6d4e1dd1ea.tar.gz
ports-2fbafc1ba456a8fbaaa7ca7e362b7f6d4e1dd1ea.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pipelight/Makefile11
-rw-r--r--emulators/pipelight/distinfo10
-rw-r--r--emulators/pipelight/files/patch-Makefile10
-rw-r--r--emulators/pipelight/pkg-descr2
4 files changed, 17 insertions, 16 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index 499bb584f623..caec2dac1767 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pipelight
-DISTVERSION= 0.2.7.3
-PORTREVISION= 7
+DISTVERSION= 0.2.8.1
CATEGORIES= emulators
MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/ \
http://repos.fds-team.de/pluginloader/v${DISTVERSION}/:plg
@@ -28,7 +27,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/bin/flock:${PORTSDIR}/sysutils/flock \
${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
-WRKSRC= ${WRKDIR}/mmueller2012-pipelight-79b1b7ba0032
+WRKSRC= ${WRKDIR}/mmueller2012-pipelight-8a1bdc6c254f
USE_GCC= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -36,7 +35,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --wine-path=${LOCALBASE}/bin/wine --win32-prebuilt \
--win64-prebuilt --moz-plugin-path=${LOCALBASE}/lib/browser_plugins \
- --cxx=${CXX} --bash-interp=${LOCALBASE}/bin/bash
+ --cxx=${CXX} --bash-interp=${LOCALBASE}/bin/bash \
+ --gpg-exec=${LOCALBASE}/bin/gpg2
USE_XORG= x11
USES= compiler:gcc-c++11-lib gmake shebangfix
MAKE_JOBS_UNSAFE=yes
@@ -60,6 +60,9 @@ pre-configure:
${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz
${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz.sig ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz.sig
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pipelight/libpipelight.so
+
post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/pipelight-mkufs ${STAGEDIR}${PREFIX}/bin/
diff --git a/emulators/pipelight/distinfo b/emulators/pipelight/distinfo
index b8ea1365b497..39e77131efe7 100644
--- a/emulators/pipelight/distinfo
+++ b/emulators/pipelight/distinfo
@@ -1,6 +1,6 @@
-SHA256 (pipelight/v0.2.7.3.tar.gz) = db4585f44874c0b647e7cf611b5bf8efe308fe11573891cd74dd4fa5867e2e52
-SIZE (pipelight/v0.2.7.3.tar.gz) = 161967
-SHA256 (pipelight/pluginloader.tar.gz) = 015c6b73accb5319b5006b208dfea9b7c768f84faf40bb80676312a650967e6a
-SIZE (pipelight/pluginloader.tar.gz) = 423396
-SHA256 (pipelight/pluginloader.tar.gz.sig) = 66c08ab5b6105e8fe2fb1f604d0958e264e2796ac2310dd19827736c1aa8e816
+SHA256 (pipelight/v0.2.8.1.tar.gz) = 06d6c9c2b1c9b71d1298fc7be0cf7b8fdb85b61f04243187eb59742630b92029
+SIZE (pipelight/v0.2.8.1.tar.gz) = 153678
+SHA256 (pipelight/pluginloader.tar.gz) = eba80a1afe6b9a4de34070dfec27d358036326c7dbd487830d0616dd33f37c4d
+SIZE (pipelight/pluginloader.tar.gz) = 809672
+SHA256 (pipelight/pluginloader.tar.gz.sig) = ef5346c698c0889d28c2d28358461bfa95f7b343bd0c6c00e4ea73db07c90625
SIZE (pipelight/pluginloader.tar.gz.sig) = 543
diff --git a/emulators/pipelight/files/patch-Makefile b/emulators/pipelight/files/patch-Makefile
index f798e4ac728b..1862060b9bab 100644
--- a/emulators/pipelight/files/patch-Makefile
+++ b/emulators/pipelight/files/patch-Makefile
@@ -1,17 +1,17 @@
---- Makefile.orig 2015-01-13 14:39:12 UTC
+--- Makefile.orig 2015-05-06 04:16:57 UTC
+++ Makefile
-@@ -69,12 +69,12 @@ linux: config.make
+@@ -71,12 +71,12 @@ linux: config.make
.PHONY: prebuilt32
prebuilt32: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
- $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
+ $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" pluginloader-$(git_commit).tar.gz
- tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader.exe src/winecheck/winecheck.exe
+ tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader.exe src/windows/winecheck/winecheck.exe
.PHONY: prebuilt64
prebuilt64: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
- $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
+ $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" pluginloader-$(git_commit).tar.gz
- tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader64.exe src/winecheck/winecheck64.exe
+ tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader64.exe src/windows/winecheck/winecheck64.exe
- .PHONY: pluginloader32
+ .PHONY: windows32
diff --git a/emulators/pipelight/pkg-descr b/emulators/pipelight/pkg-descr
index 87eaadb1a7d6..3971ad8bb7ce 100644
--- a/emulators/pipelight/pkg-descr
+++ b/emulators/pipelight/pkg-descr
@@ -3,5 +3,3 @@ and therefore giving you the possibility to access services which
are otherwise not available for FreeBSD users.
WWW: http://www.pipelight.net/
-
-Kris Moore <kmoore@FreeBSD.org>