aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-12 22:13:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-03-12 22:13:25 +0000
commitff7888679105a16137c893e220628ad41e16cb42 (patch)
tree6147411eaa78d41f61d2f70e1029a9f8973f64a2 /emulators
parent733e9a8e4dfe8a7c264275211c9bd474686fcaeb (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/rpcs3/Makefile4
-rw-r--r--emulators/rpcs3/distinfo6
-rw-r--r--emulators/rpcs3/files/extra-patch-no-thread_local20
3 files changed, 25 insertions, 5 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 61c4ab0fdd29..ce0a21531188 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -2,8 +2,8 @@
PORTNAME= rpcs3
DISTVERSIONPREFIX= v
-DISTVERSION= 0.0.5-40
-DISTVERSIONSUFFIX= -g7bbadfd08
+DISTVERSION= 0.0.5-54
+DISTVERSIONSUFFIX= -gb8e920873
CATEGORIES= emulators
MAINTAINER= jbeich@FreeBSD.org
diff --git a/emulators/rpcs3/distinfo b/emulators/rpcs3/distinfo
index 385016099879..89492682973c 100644
--- a/emulators/rpcs3/distinfo
+++ b/emulators/rpcs3/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1520613059
-SHA256 (RPCS3-rpcs3-v0.0.5-40-g7bbadfd08_GH0.tar.gz) = 52baba63ba0dcf49eb942f2b68a986ad8557e0f1edabdf9a8ce9675dbb7773b1
-SIZE (RPCS3-rpcs3-v0.0.5-40-g7bbadfd08_GH0.tar.gz) = 4305270
+TIMESTAMP = 1520871412
+SHA256 (RPCS3-rpcs3-v0.0.5-54-gb8e920873_GH0.tar.gz) = 35425eac00c37bf2523eb40d8992a878b58d46c70c28b6e8cab1336a9b806037
+SIZE (RPCS3-rpcs3-v0.0.5-54-gb8e920873_GH0.tar.gz) = 4305546
SHA256 (RPCS3-hidapi-hidapi-0.8.0-rc1-25-gca39ce8_GH0.tar.gz) = e50e4f4e9035e891e16867e995f44aac87ce734a9dde169f02fc9719b2ce3642
SIZE (RPCS3-hidapi-hidapi-0.8.0-rc1-25-gca39ce8_GH0.tar.gz) = 105623
SHA256 (RPCS3-yaml-cpp-release-0.5.3-62-g017626a_GH0.tar.gz) = 1d4b32443f137c23b68d3cb183ba6fb48eb76be2b0b30016970adff5c770d841
diff --git a/emulators/rpcs3/files/extra-patch-no-thread_local b/emulators/rpcs3/files/extra-patch-no-thread_local
index 36fd10c96e35..0641b38a33d2 100644
--- a/emulators/rpcs3/files/extra-patch-no-thread_local
+++ b/emulators/rpcs3/files/extra-patch-no-thread_local
@@ -1,6 +1,26 @@
FreeBSD 10.3 lacks __cxa_thread_atexit, so revert
https://github.com/RPCS3/rpcs3/commit/c1450ad61627
+--- rpcs3/Emu/VFS.cpp.orig 2018-03-12 20:29:35 UTC
++++ rpcs3/Emu/VFS.cpp
+@@ -18,7 +18,7 @@ bool vfs::mount(const std::string& dev_name, const std
+ {
+ const auto table = fxm::get_always<vfs_manager>();
+
+- safe_writer_lock lock(table->mutex);
++ writer_lock lock(table->mutex);
+
+ return table->mounted.emplace(dev_name, path).second;
+ }
+@@ -27,7 +27,7 @@ std::string vfs::get(const std::string& vpath, const s
+ {
+ const auto table = fxm::get_always<vfs_manager>();
+
+- safe_reader_lock lock(table->mutex);
++ reader_lock lock(table->mutex);
+
+ std::smatch match;
+
--- Utilities/Log.cpp.orig 2017-09-19 12:07:07 UTC
+++ Utilities/Log.cpp
@@ -255,7 +255,7 @@ void logs::message::broadcast(const char* fmt, const f