aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
commit4eb209da7d941e66e0cb065aead6bda76c9e97f3 (patch)
treec9cf2fdcee3885499960b9c706dacac0a0080f8e /emulators
parentb188150955302fdc3c1402eb0688a84d1f2cf451 (diff)
downloadports-4eb209da7d941e66e0cb065aead6bda76c9e97f3.tar.gz
ports-4eb209da7d941e66e0cb065aead6bda76c9e97f3.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile12
-rw-r--r--emulators/pcemu/Makefile10
-rw-r--r--emulators/vice/Makefile4
-rw-r--r--emulators/vmware-guestd4/Makefile4
-rw-r--r--emulators/vmware-guestd5/Makefile4
-rw-r--r--emulators/vmware-guestd6/Makefile4
-rw-r--r--emulators/vmware-tools3/Makefile4
-rw-r--r--emulators/vmware_xf4mod/Makefile2
-rw-r--r--emulators/xzx/Makefile2
9 files changed, 19 insertions, 27 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index d6553415a150..0ea3854a953a 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -16,6 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
+BUILD_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
+
USE_XLIB= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -36,13 +39,6 @@ MANCOMPRESSED= yes
MAN1= bochs.1 bochs-dlx.1 bxcommit.1 bximage.1
MAN5= bochsrc.5
-.include <bsd.port.pre.mk>
-
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS+= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS+= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
-
.if defined(WITH_BOCHS_PROCESSORS)
.if ${WITH_BOCHS_PROCESSORS} < 1 || ${WITH_BOCHS_PROCESSORS} > 15
.error "WITH_BOCHS_PROCESSORS must be an integer value between 1 and 15."
@@ -145,4 +141,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/pcemu/Makefile b/emulators/pcemu/Makefile
index 718e788af631..df6267fb8262 100644
--- a/emulators/pcemu/Makefile
+++ b/emulators/pcemu/Makefile
@@ -26,14 +26,10 @@ DISTNAME= pcemu1.01alpha
MAINTAINER= joerg@FreeBSD.org
COMMENT= An 8086 PC emulator, by David Hedley
-.include <bsd.port.pre.mk>
-
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
+BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
USE_XLIB= yes
MAKE_ENV= FILESDIR=${FILESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index d187beafabcd..fb01be1d26a8 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -45,8 +45,8 @@ MLINKS= vice.1 x64.1 \
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+BUILD_DEPENDS+= bdftopcf:${X_CLIENTS_PORT}
.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
diff --git a/emulators/vmware-guestd4/Makefile b/emulators/vmware-guestd4/Makefile
index a16399b41fff..8f55d3514a9c 100644
--- a/emulators/vmware-guestd4/Makefile
+++ b/emulators/vmware-guestd4/Makefile
@@ -52,7 +52,7 @@ UMOUNT= /sbin/umount
.if defined(VMWARE_X_PORTS)
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
PLIST_SUB+= INSTALLXSERVER3:=""
PLIST_SUB+= INSTALLXSERVER4:="@comment "
.else
@@ -121,7 +121,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${X11BASE}/bin
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
${INSTALL_PROGRAM} ${WRKSRC}/lib/configurator/XFree86-3/XF86_VMware_4.5 ${X11BASE}/bin/XF86_VMware
${INSTALL_DATA} ${WRKSRC}/lib/configurator/XFree86-3/XF86Config ${X11BASE}/etc/XF86Config_VMware
@${ECHO} ""
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index a16399b41fff..8f55d3514a9c 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -52,7 +52,7 @@ UMOUNT= /sbin/umount
.if defined(VMWARE_X_PORTS)
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
PLIST_SUB+= INSTALLXSERVER3:=""
PLIST_SUB+= INSTALLXSERVER4:="@comment "
.else
@@ -121,7 +121,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${X11BASE}/bin
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
${INSTALL_PROGRAM} ${WRKSRC}/lib/configurator/XFree86-3/XF86_VMware_4.5 ${X11BASE}/bin/XF86_VMware
${INSTALL_DATA} ${WRKSRC}/lib/configurator/XFree86-3/XF86Config ${X11BASE}/etc/XF86Config_VMware
@${ECHO} ""
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index a16399b41fff..8f55d3514a9c 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -52,7 +52,7 @@ UMOUNT= /sbin/umount
.if defined(VMWARE_X_PORTS)
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
PLIST_SUB+= INSTALLXSERVER3:=""
PLIST_SUB+= INSTALLXSERVER4:="@comment "
.else
@@ -121,7 +121,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${X11BASE}/bin
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
${INSTALL_PROGRAM} ${WRKSRC}/lib/configurator/XFree86-3/XF86_VMware_4.5 ${X11BASE}/bin/XF86_VMware
${INSTALL_DATA} ${WRKSRC}/lib/configurator/XFree86-3/XF86Config ${X11BASE}/etc/XF86Config_VMware
@${ECHO} ""
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index 5198adbb3288..0539f216dbcb 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -42,7 +42,7 @@ UMOUNT= /sbin/umount
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
PLIST_SUB+= INSTALLXSERVER:=""
.else
PLIST_SUB+= INSTALLXSERVER:="@comment "
@@ -82,7 +82,7 @@ post-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin
-.if ${XFREE86_VERSION} == 3
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
${INSTALL_PROGRAM} ${WRKSRC}/XF86_VMware ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/XF86Config.dist ${PREFIX}/etc/XF86Config_VMware
@${ECHO} ""
diff --git a/emulators/vmware_xf4mod/Makefile b/emulators/vmware_xf4mod/Makefile
index 8161fc72a706..758e05738fc3 100644
--- a/emulators/vmware_xf4mod/Makefile
+++ b/emulators/vmware_xf4mod/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= A XFree86 4.x driver module for VMware guests
-RUN_DEPENDS= XFree86:${PORTSDIR}/x11/XFree86-4
+RUN_DEPENDS= XFree86:${X_SERVER_PORT}
NO_WRKSUBDIR= yes
diff --git a/emulators/xzx/Makefile b/emulators/xzx/Makefile
index 30fb7a410bde..7cfa2bc2e242 100644
--- a/emulators/xzx/Makefile
+++ b/emulators/xzx/Makefile
@@ -20,7 +20,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= ZX Spectrum (48K/128K/+3) Emulator for X11
# xmkmf is used in configure script; USE_IMAKE makes the build unhappy
-BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake-4
+BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
USE_MOTIF= yes
USE_X_PREFIX= yes