aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2011-08-07 12:58:59 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2011-08-07 12:58:59 +0000
commit7ab85aab70ef4791b4d39b384edd71006037b36c (patch)
tree799efe518124cc0bd05002ff841fe672e681b6b8 /emulators
parentf86d70b88f75905f1d77c7f14072a292a9df0090 (diff)
downloadports-7ab85aab70ef4791b4d39b384edd71006037b36c.tar.gz
ports-7ab85aab70ef4791b4d39b384edd71006037b36c.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 3d937f904641..262789e02fdb 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bochs
PORTVERSION= 2.4.6
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -14,6 +15,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
+LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
+
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
@@ -68,7 +71,7 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
X86_64 "Enable AMD x86-64 support" off \
XPM "Enable XPM library support" off
-CFLAGS+= -fno-exceptions -fomit-frame-pointer
+CFLAGS+= -fno-exceptions -fomit-frame-pointer ${CPPFLAGS}
CXXFLAGS+= -fno-rtti
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -211,7 +214,7 @@ CONFIGURE_ARGS+=--enable-long-phy-address
CONFIGURE_ARGS+=--disable-long-phy-address
.endif
-.if defined(WITH_MISALIGNDSSE)
+.if defined(WITH_MISALIGNEDSSE)
CONFIGURE_ARGS+=--enable-misaligned-sse
.else
CONFIGURE_ARGS+=--disable-misaligned-sse