aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-15 18:05:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-15 18:05:41 +0000
commita091f24b78c69ab2244c183749e553bbebeb6d3c (patch)
tree44ce970f2802af1c34ce120071ce5d42616e1e06 /emulators
parentd72b40ab344d6ac292da4e440a8097209a3f4e22 (diff)
downloadports-a091f24b78c69ab2244c183749e553bbebeb6d3c.tar.gz
ports-a091f24b78c69ab2244c183749e553bbebeb6d3c.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile61
-rw-r--r--emulators/xmame/distinfo7
-rw-r--r--emulators/xmame/pkg-plist23
-rw-r--r--emulators/xmess/Makefile3
4 files changed, 39 insertions, 55 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 24b18300e24d..367e4c538315 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.60.1
+PORTVERSION?= 0.61.1
CATEGORIES= emulators
-MASTER_SITES= http://x.mame.net/download/ \
- http://www.mame.net/zips/ \
- http://cheat.retrogames.com/ \
- http://www.win.tue.nl/~stijn/xmame/
-DISTNAME= xmame-${XMAMEVERSION:S/p/pre/}
+MASTER_SITES= http://x.mame.net/download/:xmame \
+ http://www.sys2064.com/files/util/:history \
+ http://www.sys2064.com/files/mame/:highscore \
+ http://cheat.retrogames.com/:cheat \
+ http://www.win.tue.nl/~stijn/xmame/:history,highscore,cheat
+DISTNAME= xmame-${XMAMEVERSION:S/.p/-pr/}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:xmame
DIST_SUBDIR= xmame
MAINTAINER?= stijn@win.tue.nl
@@ -48,7 +50,10 @@ SPOOLGAMES?= /var/games
# Docs list
GENERALDOCS= changes.unix \
+ ctrlr.txt \
+ dga2.txt \
liesmich.unix \
+ listinfo.txt \
multiplayer-readme.txt \
xmame-doc-1.html \
xmame-doc-2.html \
@@ -57,7 +62,10 @@ GENERALDOCS= changes.unix \
xmame-doc-5.html \
xmame-doc-6.html \
xmame-doc-7.html \
+ xmame-doc-8.html \
xmame-doc.html \
+ xmame-doc.lyx \
+ xmame-doc.txt \
xmame-gdoc-1.html \
xmame-gdoc-2.html \
xmame-gdoc-3.html \
@@ -65,28 +73,19 @@ GENERALDOCS= changes.unix \
xmame-gdoc-5.html \
xmame-gdoc-6.html \
xmame-gdoc-7.html \
+ xmame-gdoc-8.html \
xmame-gdoc.html \
- xmame-doc.lyx \
- xmame-doc.txt
+ xmame.css
XMAMEDOCS= changes.mame \
- ctrlr.txt \
gamelist.mame \
- readme.mame \
- xmame-doc-8.html \
- xmame-gdoc-8.html \
- xmame.css \
- dga2.txt
+ readme.mame
XMESSDOCS= changes.mess \
credits.mess \
gamelist.mess \
- readme.mess \
- messroms.txt \
imgtool.txt \
+ messhelp.txt \
messroms.txt \
- xmame-doc-8.html \
- xmame-gdoc-8.html \
- xmame.css \
- dga2.txt
+ old-changes.mess
PINMAMEDOCS= pinmame/simulation.txt \
pinmame/whatsnew.txt \
pinmame/pinmame.txt \
@@ -122,17 +121,18 @@ PLIST_SUB+= DATFILES=""
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-HIVER= 7
+HIVER= 795
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
- hsdat${HIVER}.zip history.zip cheat.zip
+DISTFILES+= uhsdat${HIVER}.zip:highscore history.dat.zip:history \
+ cheat.zip:cheat
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
post-extract:
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/hsdat${HIVER}.zip hiscore.dat
+ unzip -q ${DISTDIR}/${DIST_SUBDIR}/uhsdat${HIVER}.zip \
+ hiscore.dat
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/history.zip history.dat
+ unzip -q ${DISTDIR}/${DIST_SUBDIR}/history.dat.zip history.dat
cd ${WRKDIR} && \
unzip -q ${DISTDIR}/${DIST_SUBDIR}/cheat.zip cheat.dat
.else
@@ -248,16 +248,6 @@ pre-everything::
${ECHO_MSG} '-------------------------------------------------------------------------';)
.endif
-# Some simple patches that don't warrant a separate patch
-post-patch:
- ${PERL} -pi -e 's@SDL/@SDL11/@' ${WRKSRC}/src/unix/video-drivers/SDL.c
- ${PERL} -pi -e 's@png.h@../../png.h@' \
- ${WRKSRC}/src/unix/video-drivers/glexport.c
- ${PERL} -pi -e 's@malloc.h@stdlib.h@' \
- ${WRKSRC}/src/unix/video-drivers/gljpg.c
- ${PERL} -pi -e 's@asm/io.h@machine/cpufunc.h@' \
- ${WRKSRC}/src/unix/video-drivers/twkuser.c
-
# The large number of sed regexes here is intended to make this port a whole
# lot easier to maintain - please don't convert them into a patch.
do-configure:
@@ -267,6 +257,7 @@ do-configure:
-e "s@/usr/X11R6@${X11BASE}@g" \
-e "s@-g bin@-g wheel@g" \
-e "s@^ARCH = linux@ARCH = freebsd@g" \
+ -e "s@# X11_XV@X11_XV@g" \
-e "s@# X11_DGA@X11_DGA@g" \
-e "s@= x11@= ${DISPLAY_METHOD}@g" \
-e "s@= mame@= ${MAMEMESS}@g" \
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
index 99364fb09ce7..d34d26b96e4e 100644
--- a/emulators/xmame/distinfo
+++ b/emulators/xmame/distinfo
@@ -1,7 +1,6 @@
-MD5 (xmame/xmame-0.60.1.tar.bz2) = 887e3956e410b06b92165637ba219070
+MD5 (xmame/xmame-0.61.1.tar.bz2) = 8d0babde89ff1af4280c76f36750a457
MD5 (xmame/xmame-0.59.2.tar.bz2) = f35a5f9a79da963c157867015c284562
-MD5 (xmame/xmame-0.56.2.tar.bz2) = e43dd5e087f954351948fb9848485924
MD5 (xmame/cheat.zip) = b745ea4df1a3a517c00fedae1ee49a14
-MD5 (xmame/history.zip) = 69da5c33e6a78092c6cd75cbeb737c6a
-MD5 (xmame/hsdat7.zip) = 9e4a7e36448895f13128a675327e34e4
+MD5 (xmame/history.dat.zip) = 8c758537d5f5bc90fc3224b19421ae12
+MD5 (xmame/uhsdat795.zip) = c30956e15cd8218f558f41013a47f22e
MD5 (xmame/xmame-0.59.2-pinmame-1.20.b.patch.gz) = aeefd4f6593d389cddbb7081cfc4eb42
diff --git a/emulators/xmame/pkg-plist b/emulators/xmame/pkg-plist
index a870472cdbca..6ee1ca84b204 100644
--- a/emulators/xmame/pkg-plist
+++ b/emulators/xmame/pkg-plist
@@ -2,6 +2,8 @@ bin/%%MAMEMESS%%
etc/%%MAMEMESS%%rc.sample
share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%PORTDOCS%%share/doc/%%MAMEMESS%%/changes.unix
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/ctrlr.txt
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/dga2.txt
%%PORTDOCS%%share/doc/%%MAMEMESS%%/liesmich.unix
%%PORTDOCS%%share/doc/%%MAMEMESS%%/multiplayer-readme.txt
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-1.html
@@ -11,7 +13,10 @@ share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-5.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-6.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-7.html
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-8.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc.html
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc.lyx
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc.txt
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc-1.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc-2.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc-3.html
@@ -21,30 +26,20 @@ share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc-7.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc-8.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-gdoc.html
-%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc.lyx
-%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc.txt
-%%PORTDOCS%%share/doc/%%MAMEMESS%%/dga2.txt
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame.css
%%MAMEONLY%%%%DATFILES%%share/xmame/hiscore.dat
%%MAMEONLY%%%%DATFILES%%share/xmame/history.dat
%%MAMEONLY%%%%DATFILES%%share/xmame/cheat.dat
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/changes.mame
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/ctrlr.txt
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/gamelist.mame
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/readme.mame
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/xmame-doc-8.html
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/xmame-gdoc-8.html
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/xmame.css
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/dga2.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/changes.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/credits.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/gamelist.mess
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/readme.mess
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messroms.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/imgtool.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/xmame-doc-8.html
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/xmame-gdoc-8.html
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/xmame.css
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/dga2.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messhelp.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messroms.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/old-changes.mess
%%MESSONLY%%share/xmess/history.dat
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/simulation.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/whatsnew.txt
diff --git a/emulators/xmess/Makefile b/emulators/xmess/Makefile
index b2fca64493f5..fc54202c39c6 100644
--- a/emulators/xmess/Makefile
+++ b/emulators/xmess/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= xmess
-PORTVERSION= 0.56.2
+PORTVERSION= 0.61.1
MAINTAINER= stijn@win.tue.nl
MASTERDIR= ${.CURDIR}/../xmame
-PATCHDIR= ${.CURDIR}/files
COMMENT= ${.CURDIR}/pkg-comment
DESCR= ${.CURDIR}/pkg-descr