aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-08 18:23:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-08 18:23:15 +0000
commita9d9f7e5994d4920262e258a900c16f262ff3d66 (patch)
tree61b2ef107c1a681984243cad86465801ce6f45c7 /emulators
parentf46bb34e5f5c2649a691038e940ec5c97d9700e6 (diff)
downloadports-a9d9f7e5994d4920262e258a900c16f262ff3d66.tar.gz
ports-a9d9f7e5994d4920262e258a900c16f262ff3d66.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile40
-rw-r--r--emulators/wine-devel/pkg-plist12
2 files changed, 30 insertions, 22 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index f16e30f197eb..2d03b02ed201 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -17,12 +17,7 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms2.so:${PORTSDIR}/graphics/lcms2 \
- libpng15.so:${PORTSDIR}/graphics/png \
- libxml2.so:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
CONFLICTS_INSTALL= i386-wine-* wine-1.4* wine-1.6*
@@ -32,12 +27,10 @@ USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --without-dbus \
- --with-fontconfig --with-glu \
--without-gphoto --without-gsm --without-gstreamer \
- --with-opengl --without-mpg123 --without-opencl \
+ --without-mpg123 --without-opencl \
--with-oss --without-sane --without-tiff \
- --without-v4l --without-xcomposite --without-xinerama \
- --with-xinput2 --with-xrandr
+ --without-v4l --without-xcomposite --without-xinerama
CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
@@ -46,13 +39,13 @@ USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
ONLY_FOR_ARCHS= i386
USES= bison gmake
USE_BZIP2= yes
-USE_GL= glu
-USE_XORG= xcursor xi xpm xrandr xrender
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO
+OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO X11
+OPTIONS_DEFAULT=X11
+OPTIONS_SUB= yes
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
@@ -60,7 +53,7 @@ WINEMAKER_DESC= Fully support winemaker (requires Perl)
GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
-PORTDATA= fonts/ l_intl.nls wine.inf
+PORTDATA= l_intl.nls wine.inf
.include <bsd.port.pre.mk>
@@ -106,10 +99,8 @@ CONFIGURE_ARGS+= --without-xslt
.if ${PORT_OPTIONS:MOPENAL}
CONFIGURE_ARGS+= --with-openal
USE_OPENAL= yes
-PLIST_SUB+= OPENAL=""
.else
CONFIGURE_ARGS+= --without-openal
-PLIST_SUB+= OPENAL="@comment "
.endif
.if ${PORT_OPTIONS:MWINEMAKER}
@@ -124,6 +115,23 @@ RUN_DEPENDS+= ${DATADIR}/gecko/wine_gecko-2.24-x86.msi:${PORTSDIR}/emulators/win
RUN_DEPENDS+= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
.endif
+.if ${PORT_OPTIONS:MX11}
+USE_GL= glu
+USE_XORG= xcursor xi xpm xrandr xrender
+LIB_DEPENDS+= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpng15.so:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+=--with-fontconfig --with-glu --with-opengl \
+ --with-xinput2 --with-xrandr --with-freetype
+PORTDATA+= fonts/
+.else
+CONFIGURE_ARGS+=--without-x --without-fontconfig --without-glu \
+ --without-opengl --without-xinput2 --without-xrandr \
+ --without-freetype
+.endif
+
.if ${OSVERSION} < 800000
IGNORE= lacks required sound support on FreeBSD before 8.0
.endif
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index aaf7c552426d..6d4ce173cbc5 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -1095,7 +1095,7 @@ lib/wine/fakedlls/gameux.dll
lib/wine/fakedlls/gdi.exe16
lib/wine/fakedlls/gdi32.dll
lib/wine/fakedlls/gdiplus.dll
-lib/wine/fakedlls/glu32.dll
+%%X11%%lib/wine/fakedlls/glu32.dll
lib/wine/fakedlls/gphoto2.ds
lib/wine/fakedlls/gpkcsp.dll
lib/wine/fakedlls/hal.dll
@@ -1257,7 +1257,7 @@ lib/wine/fakedlls/olesvr32.dll
lib/wine/fakedlls/olethk32.dll
lib/wine/fakedlls/oleview.exe
%%OPENAL%%lib/wine/fakedlls/openal32.dll
-lib/wine/fakedlls/opengl32.dll
+%%X11%%lib/wine/fakedlls/opengl32.dll
lib/wine/fakedlls/pdh.dll
lib/wine/fakedlls/photometadatahandler.dll
lib/wine/fakedlls/pidgen.dll
@@ -1407,7 +1407,7 @@ lib/wine/fakedlls/winepath.exe
lib/wine/fakedlls/wineps.drv
lib/wine/fakedlls/wineps16.drv16
lib/wine/fakedlls/winevdm.exe
-lib/wine/fakedlls/winex11.drv
+%%X11%%lib/wine/fakedlls/winex11.drv
lib/wine/fakedlls/wing.dll16
lib/wine/fakedlls/wing32.dll
lib/wine/fakedlls/winhelp.exe16
@@ -1465,7 +1465,7 @@ lib/wine/gameux.dll.so
lib/wine/gdi.exe16.so
lib/wine/gdi32.dll.so
lib/wine/gdiplus.dll.so
-lib/wine/glu32.dll.so
+%%X11%%lib/wine/glu32.dll.so
lib/wine/gphoto2.ds.so
lib/wine/gpkcsp.dll.so
lib/wine/hal.dll.so
@@ -1796,7 +1796,7 @@ lib/wine/olesvr32.dll.so
lib/wine/olethk32.dll.so
lib/wine/oleview.exe.so
%%OPENAL%%lib/wine/openal32.dll.so
-lib/wine/opengl32.dll.so
+%%X11%%lib/wine/opengl32.dll.so
lib/wine/pdh.dll.so
lib/wine/photometadatahandler.dll.so
lib/wine/pidgen.dll.so
@@ -1946,7 +1946,7 @@ lib/wine/winepath.exe.so
lib/wine/wineps.drv.so
lib/wine/wineps16.drv16.so
lib/wine/winevdm.exe.so
-lib/wine/winex11.drv.so
+%%X11%%lib/wine/winex11.drv.so
lib/wine/wing.dll16.so
lib/wine/wing32.dll.so
lib/wine/winhelp.exe16.so