aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 07:35:36 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 07:35:36 +0000
commitf10920752de278a74de0212fb219a5ed68a59f20 (patch)
tree335f453f8525d3165695c78d667522a514f39a4e /emulators
parent31424eae3fcec0f2567c3496fc10571e37af5f61 (diff)
- Update to 0.7SP8
- Bump PORTREVISION. It's the same version but it has some improvements - Clean up - Take maintainership Approved by: tlp (maintainer via irc)
Notes
Notes: svn path=/head/; revision=201144
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64-glide/Makefile50
-rw-r--r--emulators/mupen64-glide/distinfo6
-rw-r--r--emulators/mupen64-glide/files/patch-Makefile62
-rw-r--r--emulators/mupen64-glide/files/patch-main.cpp41
-rw-r--r--emulators/mupen64-glide/files/patch-main.h13
-rw-r--r--emulators/mupen64-glide/pkg-descr15
-rw-r--r--emulators/mupen64-glide/pkg-message9
7 files changed, 60 insertions, 136 deletions
diff --git a/emulators/mupen64-glide/Makefile b/emulators/mupen64-glide/Makefile
index 401ce43c2ab6..7a277f29e641 100644
--- a/emulators/mupen64-glide/Makefile
+++ b/emulators/mupen64-glide/Makefile
@@ -5,59 +5,23 @@
# $FreeBSD$
#
-PORTNAME= mupen64
PORTVERSION= 0.7
-PORTREVISION= 3
-CATEGORIES+= emulators
-MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PORTREVISION= 4
PKGNAMESUFFIX= -glide
-DISTNAME= glide64_0_7_ME
-MAINTAINER?= tlp@LiquidX.org
COMMENT= Glide64 graphics plugin for Mupen64
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_SDL= sdl
-USE_GNOME= gtk12
-USE_XLIB= yes
USE_GL= yes
-USE_GCC= 3.4
-ONLY_FOR_ARCHS= i386
-PLUGIN_NAME= Glide64
-PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
-PLIST_FILES+= share/mupen64/plugins/${PLUGIN_NAME}.ini
-PLIST_DIRS= share/mupen64/plugins
-PLIST_DIRS+= share/mupen64
-
-FIXME2= wrapper/main.cpp
-
-do-configure:
-.for i in ${FIXME2}
- ${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}
-.endfor
+FIXFILES= #
-do-install:
- @${MKDIR} ${PREFIX}/share/mupen64/plugins
- ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
- ${PREFIX}/share/mupen64/plugins/
- ${INSTALL_DATA} ${WRKSRC}/${PLUGIN_NAME}.ini \
- ${PREFIX}/share/mupen64/plugins/
-
-.include <bsd.port.pre.mk>
-
-CFLAGS+= -Iwrapper/ `${SDL_CONFIG} --cflags`
-CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
-CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
-CFLAGS+= -DX86 -mcpu=athlon
-LDFLAGS+= -lGL -lGLU -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lc
+PLUGIN_NAME= Glide64
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+MASTERDIR= ${.CURDIR}/../mupen64-base
-post-install:
- @${CAT} ${PKGMESSAGE}
+OPTIONS= #
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64-glide/distinfo b/emulators/mupen64-glide/distinfo
index f4b0ee179187..59c2527a6daa 100644
--- a/emulators/mupen64-glide/distinfo
+++ b/emulators/mupen64-glide/distinfo
@@ -1,3 +1,3 @@
-MD5 (glide64_0_7_ME.tar.bz2) = 3078c5c3f960728f99af825ab0af69e0
-SHA256 (glide64_0_7_ME.tar.bz2) = 33c4805d01669b2342a2f8e6daf983c5fd0ddb56d233a0d8eb685afe6b01194a
-SIZE (glide64_0_7_ME.tar.bz2) = 231051
+MD5 (mupen64/glide64-0.7.SP8.tar.bz2) = feae89e1880309d9cdee2e925a1700cf
+SHA256 (mupen64/glide64-0.7.SP8.tar.bz2) = bdf260a3317a229622f5e84ce5af924246f174356fe6ab1fba45c1e17b6374b3
+SIZE (mupen64/glide64-0.7.SP8.tar.bz2) = 255222
diff --git a/emulators/mupen64-glide/files/patch-Makefile b/emulators/mupen64-glide/files/patch-Makefile
index 8e1dffb0fbec..5713a38e3bfa 100644
--- a/emulators/mupen64-glide/files/patch-Makefile
+++ b/emulators/mupen64-glide/files/patch-Makefile
@@ -1,19 +1,57 @@
---- Makefile.orig Sat Jul 3 23:07:06 2004
-+++ Makefile Thu Aug 12 17:06:38 2004
-@@ -1,11 +1,11 @@
+--- Makefile.orig 2005-08-26 13:53:25.000000000 -0500
++++ Makefile 2007-10-09 01:54:33.000000000 -0500
+@@ -1,22 +1,18 @@
+ ifneq ("$(shell grep GTK2 config.h)","\#define GTK2_SUPPORT 1")
+-GTK_FLAGS = `gtk-config --cflags`
+-GTK_LIBS = `gtk-config --libs`
++GTK_FLAGS = `${GTK_CONFIG} --cflags`
++GTK_LIBS = `${GTK_CONFIG} --libs`
+ else
+ GTK_FLAGS = `pkg-config gtk+-2.0 --cflags` -D_GTK2
+ GTK_LIBS = `pkg-config gtk+-2.0 --libs`
+ endif
+
-CC = gcc
-+#CC = gcc
- #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -g -mmmx -msse
- #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
--CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -g -mmmx -msse
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -g -Wall
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer
-CXX = g++
-+#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
-+#CXX = g++
++CC ?= gcc
++CXX ?= g++
++
++CFLAGS = -DUSE_GTK `${SDL_CONFIG} --cflags` $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops -fomit-frame-pointer
CPPFLAGS = $(CFLAGS)
-LD = g++
--LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
-+#LD = g++
-+#LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib `sdl-config --libs`
++LD = ${CXX}
++LDFLAGS = -lGL -lGLU `${SDL_CONFIG} --libs`
OBJECTS = Main.o \
rdp.o \
+@@ -41,11 +37,11 @@
+ wrapper/hq4x.o \
+ Config.o
+
+-all: Glide64.so instruction
++all: plugins/Glide64.so instruction
+
+-Glide64.so: font.h cursor.h $(OBJECTS)
++plugins/Glide64.so: font.h cursor.h $(OBJECTS)
++ mkdir -p plugins
+ $(LD) -shared -Wl,-Bsymbolic $(GTK_LIBS) $(LDFLAGS) -o $@ $(OBJECTS)
+- strip --strip-all $@
+
+ font.h: compiletex
+ ./compiletex font.tex font.h font
+@@ -60,7 +56,7 @@
+ nasm -f elf $<
+
+ instruction:
+- $(warning please copy Glide64.so AND Glide64.ini in the plugins/ folder of the emulator)
++ $(warning please copy plugins/Glide64.so AND Glide64.ini in the plugins/ folder of the emulator)
+
+ clean:
+ rm -rf $(OBJECTS) $(ALL) compiletex compiletex.o font.h cursor.h
diff --git a/emulators/mupen64-glide/files/patch-main.cpp b/emulators/mupen64-glide/files/patch-main.cpp
deleted file mode 100644
index 6cb9dc93c9b5..000000000000
--- a/emulators/mupen64-glide/files/patch-main.cpp
+++ /dev/null
@@ -1,41 +0,0 @@
---- wrapper/main.cpp.orig Fri Jul 2 21:57:48 2004
-+++ wrapper/main.cpp Fri Aug 13 21:21:15 2004
-@@ -3,7 +3,7 @@
- #include <stdarg.h>
- #include <string.h>
- #include <unistd.h>
--#include <SDL/SDL.h>
-+#include <SDL.h>
- #endif // _WIN32
- #include "glide.h"
- #include <stdlib.h>
-@@ -20,9 +20,13 @@
- #endif // _WIN32
-
-
-+#ifndef __FreeBSD__
- PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
-+#endif
- PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
-+#ifndef __FreeBSD__
- PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
-+#endif
- PFNGLFOGCOORDFPROC glFogCoordfEXT;
- #ifdef _WIN32
- PFNWGLGETEXTENSIONSSTRINGARBPROC wglGetExtensionsStringARB;
-@@ -501,6 +505,7 @@
- if (isExtensionSupported("GL_ARB_texture_mirrored_repeat") == FALSE)
- display_warning((unsigned char*)"Your video card doesn't support GL_ARB_texture_mirrored_repeat extension");
-
-+#ifndef __FreeBSD__
- #ifdef _WIN32
- glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)wglGetProcAddress("glActiveTextureARB");
- glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)wglGetProcAddress("glMultiTexCoord2fARB");
-@@ -508,6 +513,7 @@
- glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)SDL_GL_GetProcAddress("glActiveTextureARB");
- glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)SDL_GL_GetProcAddress("glMultiTexCoord2fARB");
- #endif // _WIN32
-+#endif
- glGetIntegerv(GL_MAX_TEXTURE_UNITS_ARB, &nbTextureUnits);
- if (nbTextureUnits == 1) display_warning((unsigned char*)"You need a video card that has at least 2 texture units");
-
diff --git a/emulators/mupen64-glide/files/patch-main.h b/emulators/mupen64-glide/files/patch-main.h
deleted file mode 100644
index aefbaa4f1fd0..000000000000
--- a/emulators/mupen64-glide/files/patch-main.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- wrapper/main.h.orig Sun Jun 20 21:08:48 2004
-+++ wrapper/main.h Fri Aug 13 21:17:22 2004
-@@ -16,8 +16,10 @@
- void updateCombinera(int i);
-
- //#ifdef _WIN32
-+#ifndef __FreeBSD__
- extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
- extern PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
-+#endif
- extern PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
- extern PFNGLFOGCOORDFPROC glFogCoordfEXT;
- //#endif // _WIN32
diff --git a/emulators/mupen64-glide/pkg-descr b/emulators/mupen64-glide/pkg-descr
deleted file mode 100644
index 7190eb7315dd..000000000000
--- a/emulators/mupen64-glide/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Glide64 graphics plugin for Mupen64
--
-Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
-on/for Linux originally but has already been ported successfully to other
-operating systems. The program can easily be ported to all operating systems
-supported by the SDL library.
-
-In its current state, the emulator is highly compatible and uses a plugin
-system. With the correct plugins ("correct" can be computer dependent), it
-can achieve nearly perfect graphics and sound in many games.
-
-WWW: http://mupen64.emulation64.com/
-
-- Travis Poppe
-tlp@liquidx.org
diff --git a/emulators/mupen64-glide/pkg-message b/emulators/mupen64-glide/pkg-message
deleted file mode 100644
index d53470396a22..000000000000
--- a/emulators/mupen64-glide/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
--------------------------------------------------------------------------------
-If you have installed/upgraded any new plugins or are upgrading from a previous
-version of Mupen64, please note that in order for these changes to take effect,
-you -must- backup and then remove ~/.mupen64 first. After you have removed the
-directory, run 'mupen64' to re-create it. Then, manually copy back your save
-files/other data you need from the backup if necessary.
-
-Enjoy!
--------------------------------------------------------------------------------