aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-04-04 23:16:43 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-04-04 23:16:43 +0000
commitfed51a4bc949b8025af0129f9c170aaa7c69eb92 (patch)
tree0c8f9a2ca0fa26b836921a33651f598455ed2f26 /emulators
parent53e60f4b39e2cf80bcb3823125a1d1a1aa87341f (diff)
downloadports-fed51a4bc949b8025af0129f9c170aaa7c69eb92.tar.gz
ports-fed51a4bc949b8025af0129f9c170aaa7c69eb92.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile3
-rw-r--r--emulators/qemu-devel/files/extra-patch-d62553b108aa27c0c020dbb771d29f8673807a3b13
2 files changed, 15 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 2b256079b6ce..4c7fe8ceda09 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -70,6 +70,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-freebsd-os-proc.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-05ee8495804599b52a88eb36b13ea9c06b3207cd
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-mips-target_arch_vmparam.h
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-inherit-interp_prefix
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-d62553b108aa27c0c020dbb771d29f8673807a3b
.endif
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
diff --git a/emulators/qemu-devel/files/extra-patch-d62553b108aa27c0c020dbb771d29f8673807a3b b/emulators/qemu-devel/files/extra-patch-d62553b108aa27c0c020dbb771d29f8673807a3b
new file mode 100644
index 000000000000..11da6554b90c
--- /dev/null
+++ b/emulators/qemu-devel/files/extra-patch-d62553b108aa27c0c020dbb771d29f8673807a3b
@@ -0,0 +1,13 @@
+diff --git a/bsd-user/mips/target_arch_sigtramp.h b/bsd-user/mips/target_arch_sigtramp.h
+index 5e3c69a..2ec591f 100644
+--- a/bsd-user/mips/target_arch_sigtramp.h
++++ b/bsd-user/mips/target_arch_sigtramp.h
+@@ -8,7 +8,7 @@ static inline abi_long setup_sigtramp(abi_ulong offset, unsigned sigf_uc,
+ {
+ int i;
+ uint32_t sigtramp_code[TARGET_SZSIGCODE/TARGET_INSN_SIZE] = {
+- /* 1 */ 0x67A40000 + sigf_uc, /* daddu $a0, $sp, (sigf_uc) */
++ /* 1 */ 0x27A40000 + sigf_uc, /* daddu $a0, $sp, (sigf_uc) */
+ /* 2 */ 0x24020000 + sys_sigreturn, /* li $v0, (sys_sigreturn) */
+ /* 3 */ 0x0000000C, /* syscall */
+ /* 4 */ 0x0000000D /* break */