aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2020-04-19 17:21:07 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2020-04-19 17:21:07 +0000
commitdcd3e81f33373190d5502c27371460e701ed8501 (patch)
tree71b1eed348edfd6f12bca1f9c831f3c0da93e944 /emulators
parent62514912d006e485fb696cf552e7cea367344254 (diff)
downloadports-dcd3e81f33373190d5502c27371460e701ed8501.tar.gz
ports-dcd3e81f33373190d5502c27371460e701ed8501.zip
MFH: r532092
emulators/emu64: extend patch to fix an issue with OSS This update is require to unbreak the port under FreeBSD. The issue was reported to upstream and the fix will be available in future releases. Background: In the upstream issue, it was revealed that the whole C64 emulation depends on the audio stream (for best sync) and initializing the audio stream failed when the SDL backend was OSS, because it needs a fragment size that is a power of two. The attached patch is the minimal change to 5.0.18 from the upstream commit that solved the problem. PR: 245395 Submitted by: Ingo <hylaios@online.de> Approved by: Felix Palmen <felix@palmen-it.de> (maintainer) Approved by: ports-secteam@
Notes
Notes: svn path=/branches/2020Q2/; revision=532136
Diffstat (limited to 'emulators')
-rw-r--r--emulators/emu64/Makefile1
-rw-r--r--emulators/emu64/files/patch-src_c64__class.cpp14
2 files changed, 14 insertions, 1 deletions
diff --git a/emulators/emu64/Makefile b/emulators/emu64/Makefile
index 0f8488545408..bca54acfc629 100644
--- a/emulators/emu64/Makefile
+++ b/emulators/emu64/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emu64
PORTVERSION= 5.0.18
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= felix@palmen-it.de
diff --git a/emulators/emu64/files/patch-src_c64__class.cpp b/emulators/emu64/files/patch-src_c64__class.cpp
index 33a7b1c6b2dd..5b144477789a 100644
--- a/emulators/emu64/files/patch-src_c64__class.cpp
+++ b/emulators/emu64/files/patch-src_c64__class.cpp
@@ -1,5 +1,17 @@
---- src/c64_class.cpp.orig 2020-04-03 11:33:28 UTC
+--- src/c64_class.cpp.orig 2020-04-11 10:05:13 UTC
+++ src/c64_class.cpp
+@@ -27,9 +27,9 @@ int SDLThreadWarp(void *userdat);
+ #define C64Takt 985248 // 50,124542Hz (Original C64 PAL)
+
+ #ifdef _WIN32
+- #define AudioPufferSize (882) // 882 bei 44.100 Khz
++ #define AudioPufferSize (1024) // 882 bei 44.100 Khz
+ #else
+- #define AudioPufferSize (882) // 882 bei 44.100 Khz
++ #define AudioPufferSize (1024) // 882 bei 44.100 Khz
+ #endif
+
+ #define RecPollingWaitStart 20
@@ -1757,7 +1757,7 @@ void C64Class::SetFullscreenAspectRatio(bool enable)
void C64Class::AnalyzeSDLEvent(SDL_Event *event)
{