aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-01 22:49:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-01 22:49:27 +0000
commit04aeb7c9c96c1b1f552ce337acc46c0f5991765f (patch)
treeb59e5de9efd7b40d4519287a7814097c67a37e8f /emulators
parent4dadb878874078f40064628acedca94be9f8cf63 (diff)
- Mark BROKEN: hits internal compiler bug on FreeBSD 5.X/amd64
Reported by: pointyhat
Notes
Notes: svn path=/head/; revision=210349
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mess/Makefile8
-rw-r--r--emulators/sdlmess/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index ed6455e8d98f..067948d6e8d1 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -24,6 +24,12 @@ MAKEFILE= makefile.sdl
SUB_FILES= ${PORTNAME} pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
+BROKEN= does not compile
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmess
@@ -47,4 +53,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index ed6455e8d98f..067948d6e8d1 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -24,6 +24,12 @@ MAKEFILE= makefile.sdl
SUB_FILES= ${PORTNAME} pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
+BROKEN= does not compile
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmess
@@ -47,4 +53,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>