aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-26 22:50:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-26 22:50:25 +0000
commit06a8d715bcf83148b8cb596456496f25626bf6f1 (patch)
tree56c63187ba0bdc1cd6ec50dca7d43baf8d59dd29 /emulators
parent08f59d6f798ac6a0600dd90958dcf896f904a41e (diff)
downloadports-06a8d715bcf83148b8cb596456496f25626bf6f1.tar.gz
ports-06a8d715bcf83148b8cb596456496f25626bf6f1.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux-mupen64/Makefile52
-rw-r--r--emulators/linux-mupen64/distinfo1
-rw-r--r--emulators/linux-mupen64/files/linux-mupen6414
-rw-r--r--emulators/linux-mupen64/files/linux-mupen64_install22
-rw-r--r--emulators/linux-mupen64/pkg-descr8
-rw-r--r--emulators/linux-mupen64/pkg-message18
-rw-r--r--emulators/linux-mupen64/pkg-plist27
8 files changed, 143 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 52cbdc658a13..18e1114b5115 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -42,6 +42,7 @@
SUBDIR += libspectrum
SUBDIR += libvm68k
SUBDIR += linux-ePSXe
+ SUBDIR += linux-mupen64
SUBDIR += linux-peops-softgpu
SUBDIR += linux-peops-spu
SUBDIR += linux-pete-mesagpu
diff --git a/emulators/linux-mupen64/Makefile b/emulators/linux-mupen64/Makefile
new file mode 100644
index 000000000000..1e061cb3ca23
--- /dev/null
+++ b/emulators/linux-mupen64/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: linux-mupen64
+# Date created: 04 Oct 2003
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.3
+CATEGORIES= emulators linux
+MASTER_SITES= http://mupen64.emulation64.com/files/
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= A Nintendo 64 emulator (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8 \
+ ${LINUXBASE}/usr/X11R6/lib/libXi.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+
+USE_BZIP2= yes
+
+ONLY_FOR_ARCHS= i386
+INSTALLS_SHLIB= yes
+NO_BUILD= yes
+
+# Linux binary should not be stripped by INSTALL_PROGRAM
+# because as a side effect it brands the binary as FreeBSD.
+STRIP=
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/linux-mupen64
+ ${MKDIR} ${PREFIX}/lib/linux-mupen64/lang
+ ${MKDIR} ${PREFIX}/lib/linux-mupen64/save
+ ${MKDIR} ${PREFIX}/lib/linux-mupen64/plugins
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mupen64.ini ${PREFIX}/lib/linux-mupen64/mupen64.ini
+ ${INSTALL_DATA} ${WRKSRC}/whatsnew.txt ${DOCSDIR}/whatsnew.txt
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lang/* ${PREFIX}/lib/linux-mupen64/lang
+ ${INSTALL_DATA} ${WRKSRC}/save/* ${PREFIX}/lib/linux-mupen64/save
+ ${INSTALL_DATA} ${WRKSRC}/plugins/* ${PREFIX}/lib/linux-mupen64/plugins
+ ${INSTALL_PROGRAM} ${WRKSRC}/mupen64 ${PREFIX}/lib/linux-mupen64/mupen64
+ ${INSTALL_SCRIPT} ${FILESDIR}/linux-mupen64 ${PREFIX}/bin/linux-mupen64
+ ${INSTALL_SCRIPT} ${FILESDIR}/linux-mupen64_install ${PREFIX}/bin/linux-mupen64_install
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/linux-mupen64/distinfo b/emulators/linux-mupen64/distinfo
new file mode 100644
index 000000000000..a4c8110f2486
--- /dev/null
+++ b/emulators/linux-mupen64/distinfo
@@ -0,0 +1 @@
+MD5 (mupen64-0.3.tar.bz2) = ba823b71a7ab1d4902480a4b2e2bc5f4
diff --git a/emulators/linux-mupen64/files/linux-mupen64 b/emulators/linux-mupen64/files/linux-mupen64
new file mode 100644
index 000000000000..6af60037b8a1
--- /dev/null
+++ b/emulators/linux-mupen64/files/linux-mupen64
@@ -0,0 +1,14 @@
+#!/bin/sh
+# linux-mupen64 - linux-Mupen64 wrapper
+#
+# 2003 Travis Poppe
+
+USERDIR=$HOME/.linux-mupen64
+
+if [ ! -x $USERDIR/mupen64 ]; then
+ echo "$USERDIR/mupen64 not found or not executable."
+ echo "You should run linux-mupen64_install"
+ exit 1
+fi
+
+cd $USERDIR && exec ./mupen64
diff --git a/emulators/linux-mupen64/files/linux-mupen64_install b/emulators/linux-mupen64/files/linux-mupen64_install
new file mode 100644
index 000000000000..5b6e9f9f089e
--- /dev/null
+++ b/emulators/linux-mupen64/files/linux-mupen64_install
@@ -0,0 +1,22 @@
+#!/bin/sh
+# linux-mupen64 - linux-Mupen64 user installation
+#
+# 2003 Travis Poppe
+
+if [ -x ~/.linux-mupen64 ]; then
+ echo "linux-Mupen64 user directory appears to already exist."
+ echo "Removing first..."
+ echo ""
+ rm -rf ~/.linux-mupen64
+fi
+
+mkdir ~/.linux-mupen64/
+mkdir ~/.linux-mupen64/lang
+mkdir ~/.linux-mupen64/save
+mkdir ~/.linux-mupen64/plugins
+cd ~/.linux-mupen64
+ln -s /usr/local/lib/linux-mupen64/plugins/* plugins/
+ln -s /usr/local/lib/linux-mupen64/lang/* lang/
+ln -s /usr/local/lib/linux-mupen64/mupen64* .
+echo "User installation of linux-Mupen64 complete!"
+echo "Run 'linux-mupen64' to start."
diff --git a/emulators/linux-mupen64/pkg-descr b/emulators/linux-mupen64/pkg-descr
new file mode 100644
index 000000000000..df3369ff420b
--- /dev/null
+++ b/emulators/linux-mupen64/pkg-descr
@@ -0,0 +1,8 @@
+Mupen 64 is a Nintendo 64 emulator.
+
+This is the Linux version.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/linux-mupen64/pkg-message b/emulators/linux-mupen64/pkg-message
new file mode 100644
index 000000000000..141203cd3abe
--- /dev/null
+++ b/emulators/linux-mupen64/pkg-message
@@ -0,0 +1,18 @@
+-------------------------------------------------------------------------------
+You must run 'linux-mupen64_install' as the user you intend to use mupen64 with
+before 'linux-mupen64' will work.
+
+Note:
+
+For some of the graphics plugins to work, you must have a working libGLU.so.1
+and libGLcore.so.1 file located in /compat/linux/usr/lib/
+
+If you're using the FreeBSD nVidia drivers, you can create a link to libGLU.so.1
+by issuing the following command as root:
+
+ln -s /compat/linux/usr/X11R6/lib/libGLU.so.1 /compat/linux/usr/lib/libGLU.so.1
+
+The other file should already be there. If not, look for it, and create a link.
+
+Enjoy!
+-------------------------------------------------------------------------------
diff --git a/emulators/linux-mupen64/pkg-plist b/emulators/linux-mupen64/pkg-plist
new file mode 100644
index 000000000000..c0b9304fcde2
--- /dev/null
+++ b/emulators/linux-mupen64/pkg-plist
@@ -0,0 +1,27 @@
+bin/linux-mupen64
+bin/linux-mupen64_install
+lib/linux-mupen64/mupen64
+lib/linux-mupen64/mupen64.ini
+lib/linux-mupen64/lang/dutch.lng
+lib/linux-mupen64/lang/english.lng
+lib/linux-mupen64/lang/french.lng
+lib/linux-mupen64/lang/german.lng
+lib/linux-mupen64/lang/italian.lng
+lib/linux-mupen64/lang/spanish.lng
+lib/linux-mupen64/save/empty
+lib/linux-mupen64/plugins/RiceDaedalus5.1.0.ini
+lib/linux-mupen64/plugins/blight_input-0.0.8.so
+lib/linux-mupen64/plugins/glNintendo64-0.3.1.so
+lib/linux-mupen64/plugins/mupen64_audio.so
+lib/linux-mupen64/plugins/mupen64_gfx.so
+lib/linux-mupen64/plugins/mupen64_hle_rsp.so
+lib/linux-mupen64/plugins/mupen64_input.so
+lib/linux-mupen64/plugins/ricedaedalus.so
+lib/linux-mupen64/plugins/tr64gl.so
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/linux-mupen64/plugins
+@dirrm lib/linux-mupen64/save
+@dirrm lib/linux-mupen64/lang
+@dirrm lib/linux-mupen64