aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-10 07:18:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-10 07:18:55 +0000
commit0ecea7d9d6fe5ec42d9d6a132c256840acc59ecd (patch)
tree683128c556da152a66f86979fec2b58af04bcb70 /emulators
parenteede100791e07e1ad872c7bc0fea24f2effc515d (diff)
Substitute BROKEN with IGNORE in cases where the port requires the src tree
to be present, or does not compile on certain versions of FreeBSD. This will potentially avoid needless compilations on bento, and has the added benefit of improving certain reporting tools. To most users, this change is a no-op. PR: 61090 Submitted by: linimon
Notes
Notes: svn path=/head/; revision=97845
Diffstat (limited to 'emulators')
-rw-r--r--emulators/rtc/Makefile4
-rw-r--r--emulators/vmware2/Makefile6
-rw-r--r--emulators/vmware3/Makefile6
3 files changed, 8 insertions, 8 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index e08e0ea1c14b..d622bd4f6298 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -33,11 +33,11 @@ SRC_BASE?= /usr/src
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400013
-BROKEN= "Systems prior to 400013 are out of support"
+IGNORE= "Systems prior to 400013 are out of support"
.endif
.if !exists(${SRC_BASE}/sys/Makefile)
-BROKEN= "Kernel source files required"
+IGNORE= "Kernel source files required"
.endif
do-fetch:
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 7244c5c3f642..5630434144e0 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -54,15 +54,15 @@ MODULES= vmmon vmnet
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400013
-BROKEN= "Systems prior to 400013 is out of support"
+IGNORE= "Systems prior to 400013 is out of support"
.endif
.if !defined(HAVE_LINPROCFS) && !exists(/modules/linprocfs.ko) && !exists(/boot/kernel/linprocfs.ko) && !exists(${PREFIX}/modules/linprocfs.ko)
-BROKEN= "This software absolutely requires Linux procfs support"
+IGNORE= "This software absolutely requires Linux procfs support"
.endif
.if !exists(/${SRC_BASE}/Makefile)
-BROKEN= "Kernel source files required"
+IGNORE= "Kernel source files required"
.endif
.if exists(${WRKDIRPREFIX}${.CURDIR}/work/Makefile.inc.net)
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index ec767464f176..380efe7e6433 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -51,15 +51,15 @@ MODULES= vmmon vmnet
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 480102
-BROKEN= "Systems prior to FreeBSD 480102 currently out of support"
+IGNORE= "Systems prior to FreeBSD 480102 currently out of support"
.endif
.if !defined(HAVE_LINPROCFS) && !exists(/modules/linprocfs.ko) && !exists(/boot/kernel/linprocfs.ko) && !exists(${PREFIX}/modules/linprocfs.ko)
-BROKEN= "This software absolutely requires Linux procfs support"
+IGNORE= "This software absolutely requires Linux procfs support"
.endif
.if !exists(${SRC_BASE}/Makefile)
-BROKEN= "Kernel source files required"
+IGNORE= "Kernel source files required"
.endif
.if ${OSVERSION} < 500023