aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 12:41:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 12:41:49 +0000
commit3d292c2447b9796d2cdaa124ae68c6fcf3ebe57a (patch)
tree87a2db27768c6a21c9679949c6b193540c1a976d /emulators
parentda0cd3bf1e65b6957acd9eac81b28c92926cae36 (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ia64sim/Makefile4
-rw-r--r--emulators/ia64sim/files/patch-ia64.h26
2 files changed, 25 insertions, 5 deletions
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 26e755c9ec13..ab469ac5d120 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -21,10 +21,6 @@ USE_ZIP= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501103
-BROKEN+= "and does not build with latest gcc"
-.endif
-
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
diff --git a/emulators/ia64sim/files/patch-ia64.h b/emulators/ia64sim/files/patch-ia64.h
index d1fc329e5b8b..761610a4626e 100644
--- a/emulators/ia64sim/files/patch-ia64.h
+++ b/emulators/ia64sim/files/patch-ia64.h
@@ -1,6 +1,30 @@
--- include/ia64.h.orig Sun May 6 11:39:29 2001
+++ include/ia64.h Sun May 6 11:35:10 2001
-@@ -31,2 +31,3 @@
+@@ -29,6 +29,7 @@
+ #include <ctype.h>
+ #include <string.h>
#include <elf.h>
+#include <sys/elf64.h>
+ #define TRUE 1
+ #define FALSE 0
+@@ -38,7 +39,7 @@
+ 0<=lo,hi<=63 and lo<=hi */
+
+ #define BITS(x,lo,hi) ( \
+- (uint32)(x##.q >> lo) & \
++ (uint32)(x.q >> lo) & \
+ ( (1<<(hi-lo+1)) - 1 ) \
+ )
+
+@@ -72,8 +73,8 @@
+ uint8 b[8];
+ } qword;
+
+-#define HI(x) (x##.d[1])
+-#define LO(x) (x##.d[0])
++#define HI(x) (x.d[1])
++#define LO(x) (x.d[0])
+
+ typedef struct {
+ qword dat;