aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
commit5005b67362a735dc18d3d85170eae34e1fb6feab (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /emulators
parente4eefd3f1e344c567f932fef63a6f04a0bb4eba4 (diff)
downloadports-5005b67362a735dc18d3d85170eae34e1fb6feab.tar.gz
ports-5005b67362a735dc18d3d85170eae34e1fb6feab.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gxmame/Makefile3
-rw-r--r--emulators/openmsx/Makefile2
-rw-r--r--emulators/prodosemu/Makefile3
-rw-r--r--emulators/stonx/Makefile2
-rw-r--r--emulators/tiemu3/Makefile3
-rw-r--r--emulators/tme/Makefile3
-rw-r--r--emulators/vmw/Makefile2
7 files changed, 18 insertions, 0 deletions
diff --git a/emulators/gxmame/Makefile b/emulators/gxmame/Makefile
index c596f74ecb27..ca1e104792c5 100644
--- a/emulators/gxmame/Makefile
+++ b/emulators/gxmame/Makefile
@@ -23,6 +23,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-xmame-dir=${LOCALBASE}/share/xmame
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 64436036d2f9..aff9de15ba27 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -33,6 +33,8 @@ PLIST_FILES= bin/openmsx
PORTDATA= *
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.ifdef NOPORTDATA
diff --git a/emulators/prodosemu/Makefile b/emulators/prodosemu/Makefile
index e07dbb4be06e..d5562e5c4531 100644
--- a/emulators/prodosemu/Makefile
+++ b/emulators/prodosemu/Makefile
@@ -20,6 +20,9 @@ PLIST_FILES= bin/prodos share/apple2/prodos-2e.rom
PLIST_DIRS= share/apple2
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
index 375dc721f765..f56a5a0501d9 100644
--- a/emulators/stonx/Makefile
+++ b/emulators/stonx/Makefile
@@ -37,6 +37,8 @@ DOCS= ../COPYING AUTHORS DEBUGGING INSTALL README RELEASE_NOTES \
FONTS= System0-iso.pcf System0.pcf System1-iso.pcf System1.pcf \
System2-iso.pcf System2.pcf
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
pre-build:
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
index f59d811db523..eb62f6377898 100644
--- a/emulators/tiemu3/Makefile
+++ b/emulators/tiemu3/Makefile
@@ -28,6 +28,9 @@ CONFIGURE_ARGS= --disable-gdb
MAN1= tiemu.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/emulators/tme/Makefile b/emulators/tme/Makefile
index fd07fa722c77..84ed1a8874f7 100644
--- a/emulators/tme/Makefile
+++ b/emulators/tme/Makefile
@@ -37,6 +37,9 @@ LDFLAGS+= -L${WRKSRC}/ic/ieee754/.libs
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
index 43c1dcb69db9..3f0d300cecb5 100644
--- a/emulators/vmw/Makefile
+++ b/emulators/vmw/Makefile
@@ -15,6 +15,8 @@ USES= iconv
SBINS= vmw vmshrink vmftp
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}