aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-16 00:07:20 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-16 00:07:20 +0000
commit5e8394428ba0f16d8e899dc4b31b66203a59f26d (patch)
tree7d85a04269e7ce066bf544a130843df8d1f7a449 /emulators
parentaac3282ed1bbc106102d1432640d14ba561b0f67 (diff)
downloadports-5e8394428ba0f16d8e899dc4b31b66203a59f26d.tar.gz
ports-5e8394428ba0f16d8e899dc4b31b66203a59f26d.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/Makefile12
-rw-r--r--emulators/open-vm-tools/files/patch-vmhgfs-Makefile16
-rw-r--r--emulators/open-vm-tools/files/pkg-message.in3
-rw-r--r--emulators/open-vm-tools/pkg-plist4
4 files changed, 29 insertions, 6 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 2815519098f1..b94fd0c5f2de 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,9 +4,9 @@
#
# $FreeBSD$
#
-
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
+PORTREVISION= 1
CATEGORIES= emulators kld
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-8.8.x
DISTNAME= open-vm-tools-${RELEASE_VER}-${BUILD_VER}
@@ -23,6 +23,7 @@ BUILD_VER= 471268
WRKSRC= ${WRKDIR}/open-vm-tools-${RELEASE_VER}-${BUILD_VER}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_AUTOMAKE= yes
CONFIGURE_ARGS+= --without-procps --sysconfdir=${LOCALBASE}/etc
.if defined(WITHOUT_X11)
@@ -58,6 +59,13 @@ PLIST_SUB+= FUSE=""
PLIST_SUB+= FUSE="@comment "
.endif
+.if defined(WITH_LOAD_HGFS)
+PLIST_SUB+= NOLOAD=""
+BROKEN= remove this line to install broken vmhgfs.ko
+.else
+PLIST_SUB+= NOLOAD="@comment "
+.endif
+
CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
SUB_FILES= pkg-message
@@ -89,7 +97,9 @@ post-install:
${MKDIR} ${PREFIX}/lib/vmware-tools/modules/input
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmmemctl.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmmemctl.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmxnet.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmxnet.ko
+.if defined(WITH_LOAD_HGFS)
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmhgfs.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmhgfs.ko
+.endif
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
@-kldxref ${PREFIX}/lib/vmware-tools/modules/drivers 2>/dev/null
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/open-vm-tools/files/patch-vmhgfs-Makefile b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
index fd267d3a573c..6eaae10cc489 100644
--- a/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
+++ b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
@@ -1,6 +1,15 @@
---- ./modules/freebsd/vmhgfs/Makefile.orig 2010-10-20 05:19:54.000000000 +0900
-+++ ./modules/freebsd/vmhgfs/Makefile 2010-11-11 23:06:07.000000000 +0900
-@@ -90,22 +90,7 @@
+--- modules/freebsd/vmhgfs/Makefile.orig 2011-09-15 02:03:28.000000000 +0000
++++ modules/freebsd/vmhgfs/Makefile 2012-01-08 16:11:28.000000000 +0000
+@@ -47,7 +47,7 @@
+ .endif
+
+ COMMON_HGFS_SRCS := debug.c
+-COMMON_HGFS_SRCS := bdhandler.c
++COMMON_HGFS_SRCS += bdhandler.c
+ COMMON_HGFS_SRCS += request.c
+ COMMON_HGFS_SRCS += worker.c
+ COMMON_HGFS_SRCS += fsutil.c
+@@ -93,22 +93,7 @@
CFLAGS += -Ishared
.endif
@@ -24,3 +33,4 @@
+.include <bsd.own.mk>
.include <bsd.kmod.mk>
+
diff --git a/emulators/open-vm-tools/files/pkg-message.in b/emulators/open-vm-tools/files/pkg-message.in
index ab2bf34dafe4..c2f78883f2d0 100644
--- a/emulators/open-vm-tools/files/pkg-message.in
+++ b/emulators/open-vm-tools/files/pkg-message.in
@@ -8,4 +8,7 @@ vmware_guest_vmmemctl_enable="YES"
vmware_guest_vmxnet_enable="YES"
vmware_guestd_enable="YES"
+NOTE: as of this writting, vmhfgs.ko load module is broken.
+To install and test/debug/fix this module, define WITH_LOAD_HGFS
+and remove BROKEN in Makefile
*******************************************************************
diff --git a/emulators/open-vm-tools/pkg-plist b/emulators/open-vm-tools/pkg-plist
index 14ff664614e8..bb1d716c7899 100644
--- a/emulators/open-vm-tools/pkg-plist
+++ b/emulators/open-vm-tools/pkg-plist
@@ -32,7 +32,7 @@ lib/libguestlib.so.0
libdata/pkgconfig/vmguestlib.pc
lib/vmware-tools/modules/drivers/linker.hints
lib/vmware-tools/modules/drivers/vmblock.ko
-lib/vmware-tools/modules/drivers/vmhgfs.ko
+%%NOLOAD%%lib/vmware-tools/modules/drivers/vmhgfs.ko
lib/vmware-tools/modules/drivers/vmmemctl.ko
lib/vmware-tools/modules/drivers/vmxnet.ko
include/vmGuestLib/includeCheck.h
@@ -59,7 +59,7 @@ share/vmware-tools/scripts/vmware/network
@unexec if test -f %D/lib/vmware-tools/modules/drivers/linker.hints; then rm -f %D/lib/vmware-tools/modules/drivers/linker.hints; fi
@unexec if test -f %D/share/vmware-tools/tools.conf; then rm -f %D/share/vmware-tools/tools.conf; fi
@unexec if test -h %D/etc/vmware-tools/plugins; then rm -f %D/etc/vmware-tools/plugins; fi
-etc/xdg/autostart/vmware-user.desktop
+%%X11%%etc/xdg/autostart/vmware-user.desktop
@dirrmtry etc/xdg/autostart
@dirrmtry etc/xdg
@dirrmtry lib/vmware-tools/modules/drivers