aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-19 18:43:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-19 18:43:53 +0000
commit751bc7254bc3dea90d2bea22cbe96cf376090220 (patch)
tree71de3476fb59b23aff78eaacf003af4e5a826083 /emulators
parent9fbd58c15f4072feead414f0bdc114f4639f4553 (diff)
downloadports-751bc7254bc3dea90d2bea22cbe96cf376090220.tar.gz
ports-751bc7254bc3dea90d2bea22cbe96cf376090220.zip
MFH: r542591
emulators/simh-hp3000: fix build on GCC architectures Use GCC when necessary. Builds with both GCC and Clang. Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=542592
Diffstat (limited to 'emulators')
-rw-r--r--emulators/simh-hp3000/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/simh-hp3000/Makefile b/emulators/simh-hp3000/Makefile
index c0527c833566..0b235ab19d50 100644
--- a/emulators/simh-hp3000/Makefile
+++ b/emulators/simh-hp3000/Makefile
@@ -22,7 +22,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${LOCALBASE}/share/doc/hpdoc/simh_doc.pdf:emulators/simh-hpdoc
-USES= gmake dos2unix zip
+USES= compiler gmake dos2unix zip
NO_WRKSUBDIR= yes
@@ -34,7 +34,7 @@ SUB_FILES= hp3000.1
.include <bsd.port.pre.mk>
do-build:
- (cd ${WRKSRC}; GCC=clang ${GMAKE} -C SCP hp3000)
+ (cd ${WRKSRC}; GCC=${CHOSEN_COMPILER_TYPE} ${GMAKE} -C SCP hp3000)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hp3000 ${STAGEDIR}${PREFIX}/bin