aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-11 19:49:34 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-11 19:49:34 +0000
commit88cc445eec383de75577690e2374f8ebf74a3a42 (patch)
treec78a5ce6068d38b94daf19ec8ef50438e8c4d264 /emulators
parent029231102cf82ab6236493c69a5427323b00651d (diff)
downloadports-88cc445eec383de75577690e2374f8ebf74a3a42.tar.gz
ports-88cc445eec383de75577690e2374f8ebf74a3a42.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile10
-rw-r--r--emulators/i386-wine-devel/Makefile.amd64 (renamed from emulators/i386-wine-devel/Makefile.inc)7
-rw-r--r--emulators/wine-devel/Makefile6
3 files changed, 8 insertions, 15 deletions
diff --git a/emulators/i386-wine-devel/Makefile b/emulators/i386-wine-devel/Makefile
index 1d7c8c7d8fa5..edfef0d13978 100644
--- a/emulators/i386-wine-devel/Makefile
+++ b/emulators/i386-wine-devel/Makefile
@@ -5,12 +5,6 @@
# - i386 specific port to be slave to ${PORTSDIR}/emulators/wine-devel
# - amd64 specific port to be normal port (based on binary package)
-.if !defined(ARCH)
-ARCH!= uname -p
-.endif
+ONLY_FOR_ARCHS= i386 amd64
-.if ${ARCH} == i386
-.include "${.CURDIR}/Makefile.i386"
-.else
-.include "${.CURDIR}/Makefile.inc"
-.endif
+.include <bsd.port.mk>
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.amd64
index c4db4516f004..357101813cac 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.amd64
@@ -32,8 +32,6 @@ EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude libdata/ldconfig32/${PKGNAMEPREFIX}${PORTNAME} \
-s '|/usr/local|${STAGEDIR}${PREFIX}|gs'
NO_BUILD= yes
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= wine only runs on x86 architecture
SLAVEDIR?= ${.CURDIR}
PKGINSTALL= ${SLAVEDIR}/files/pkg-install
PKGDEINSTALL= ${PKGINSTALL}
@@ -46,9 +44,6 @@ BUNDLE_LIBS= yes
GECKO_RUN_DEPENDS= ${DATADIR}/gecko/wine-gecko-2.47.1-x86.msi:emulators/wine-gecko-devel
MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-4.9.4.msi:emulators/wine-mono-devel
-# Included for OPSYS and OSVERSION
-.include <bsd.port.pre.mk>
-
.for osrel in 11 12 13
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
@@ -94,5 +89,3 @@ port-update:
${SED} -e '2,$${' -e '/^TIMESTAMP/d' -e '}' distinfo~ > ${SLAVEDIR}/distinfo
python ${FILESDIR}/mergeplist.py ${SLAVEDIR}/pkg-plist.* > ${PLIST}
${RM} ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
-
-.include <bsd.port.post.mk>
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 179136fe4dc3..a8ebc2360204 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -128,7 +128,11 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png
+# Include this only if it has not been already included by the
+# i386-wine-devel slave port.
+.ifndef PKGNAMEPREFIX
.include <bsd.port.pre.mk>
+.endif
.if ${ARCH} == amd64
# Wine is composed of three parts:
@@ -181,4 +185,6 @@ check-wine-devel-vs-staging:
fi \
done
+.ifndef PKGNAMEPREFIX
.include <bsd.port.post.mk>
+.endif