aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-04 15:52:41 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-04 15:52:41 +0000
commit9aae8cb6289f7b1d7a937c88b69f57830bc872b6 (patch)
tree1a67a2eeae4561900c3b53b7fe7e2513ba8ad5f9 /emulators
parente3054d58f95e8264b588a08217644c318c0cddc3 (diff)
downloadports-9aae8cb6289f7b1d7a937c88b69f57830bc872b6.tar.gz
ports-9aae8cb6289f7b1d7a937c88b69f57830bc872b6.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/zsnes/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 44b2ca85baf4..803e3b5c083c 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -33,14 +33,15 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= ALL
MAN1= zsnes.1
PLIST_FILES= bin/zsnes
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
@@ -49,6 +50,9 @@ CONFIGURE_ARGS+=--without-x
PKGNAMESUFFIX= -nox11
.else
CONFIGURE_ARGS+=--with-x
+CFLAGS+= -I${X11BASE}/include
+CPPFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
.endif
.if defined(WITH_OPENGL)
@@ -62,6 +66,8 @@ post-patch:
@${REINPLACE_CMD} -e \
's| -pipe||g ; \
s| -I/usr/local/include||g ; \
+ s|^VERSION=1.41|VERSION=${PORTVERSION}|; \
+ s| -D__FreeBSD__||g; \
s| -I/usr/include||g ; \
s| -O3 .* -s||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \