aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-02-06 14:58:27 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-02-06 14:58:27 +0000
commita065ee434169830100bacdd5eff155cc9efac7ca (patch)
tree4deef43b37944fe2bbdedafed7059692cde04732 /emulators
parent61cc487b4e61d3d665064c9f7d945469e63d6a8d (diff)
downloadports-a065ee434169830100bacdd5eff155cc9efac7ca.tar.gz
ports-a065ee434169830100bacdd5eff155cc9efac7ca.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile11
-rw-r--r--emulators/wine/Makefile11
2 files changed, 14 insertions, 8 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index d0c92d75ea54..9fa9f0390e0b 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -29,7 +29,7 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
+CONFIGURE_ARGS+=--datadir=${DATADIR} --verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
--without-v4l --without-mpg123 --without-sane \
@@ -37,7 +37,10 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
FLEX="${LOCALBASE}/bin/flex"
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
+WINELIBDIR?= ${PREFIX}/lib
+.if !defined(USE_LDCONFIG32)
+USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
+.endif
MAKE_JOBS_SAFE= yes
MAN1= msiexec.1 notepad.1 regedit.1 regsvr32.1 widl.1 wine.1 \
wineboot.1 winebuild.1 winecfg.1 wineconsole.1 winedbg.1 \
@@ -133,8 +136,8 @@ post-install:
${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
@-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
${MAN1PREFIX}/man/fr.UTF-8/man1
- ${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
+ ${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
+ ${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
.for i in README ANNOUNCE AUTHORS
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index d0c92d75ea54..9fa9f0390e0b 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -29,7 +29,7 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
+CONFIGURE_ARGS+=--datadir=${DATADIR} --verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
--without-v4l --without-mpg123 --without-sane \
@@ -37,7 +37,10 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
FLEX="${LOCALBASE}/bin/flex"
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
+WINELIBDIR?= ${PREFIX}/lib
+.if !defined(USE_LDCONFIG32)
+USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
+.endif
MAKE_JOBS_SAFE= yes
MAN1= msiexec.1 notepad.1 regedit.1 regsvr32.1 widl.1 wine.1 \
wineboot.1 winebuild.1 winecfg.1 wineconsole.1 winedbg.1 \
@@ -133,8 +136,8 @@ post-install:
${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
@-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
${MAN1PREFIX}/man/fr.UTF-8/man1
- ${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
+ ${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
+ ${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
.for i in README ANNOUNCE AUTHORS