aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-11-19 15:09:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-11-19 15:09:53 +0000
commitb7798a0c80899f47e80e7e07e98f7a416f477312 (patch)
tree0a9af7a6b34859dd93c8ddb4fb6c8ee0d042d426 /emulators
parent727e1e89576a06633d0ee504e199a9869e535e39 (diff)
downloadports-b7798a0c80899f47e80e7e07e98f7a416f477312.tar.gz
ports-b7798a0c80899f47e80e7e07e98f7a416f477312.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile1
-rw-r--r--emulators/bochs/files/patch-iodev-eth_fbsd.cc17
2 files changed, 18 insertions, 0 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 93f576f57ed8..459df5094ee8 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bochs
PORTVERSION= 2.3
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
diff --git a/emulators/bochs/files/patch-iodev-eth_fbsd.cc b/emulators/bochs/files/patch-iodev-eth_fbsd.cc
new file mode 100644
index 000000000000..644be5f5907f
--- /dev/null
+++ b/emulators/bochs/files/patch-iodev-eth_fbsd.cc
@@ -0,0 +1,17 @@
+--- iodev/eth_fbsd.cc.orig Sat Dec 10 19:37:35 2005
++++ iodev/eth_fbsd.cc Sun Nov 19 15:56:46 2006
+@@ -227,6 +227,14 @@
+ return;
+ }
+
++ v = 1;
++ if (ioctl(this->bpf_fd, BIOCIMMEDIATE, &v) < 0) {
++ BX_PANIC(("eth_freebsd: could not enable immediate mode"));
++ close(this->bpf_fd);
++ this->bpf_fd = -1;
++ return;
++ }
++
+ // Set up non-blocking i/o
+ v = 1;
+ if (ioctl(this->bpf_fd, FIONBIO, &v) < 0) {