aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 07:21:08 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 07:21:08 +0000
commiteea9d52af5696d462eac35339df89548f205f93e (patch)
treef171abb25882e33f1fa8a67f90f6c3b15e857ce1 /emulators
parentb8c73804570d1ebbe8ff6987c980517cb7a636f4 (diff)
downloadports-eea9d52af5696d462eac35339df89548f205f93e.tar.gz
ports-eea9d52af5696d462eac35339df89548f205f93e.zip
Add emulators/Elliott-803, Emulator and compilers for Elliott 803 computer
Submitted by: Christopher Hall <hsw@bitmark.com> Differential Revision: https://reviews.freebsd.org/D25517
Notes
Notes: svn path=/head/; revision=540929
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Elliott-803/Makefile22
-rw-r--r--emulators/Elliott-803/distinfo3
-rw-r--r--emulators/Elliott-803/pkg-descr7
-rw-r--r--emulators/Elliott-803/pkg-plist18
-rw-r--r--emulators/Makefile1
5 files changed, 51 insertions, 0 deletions
diff --git a/emulators/Elliott-803/Makefile b/emulators/Elliott-803/Makefile
new file mode 100644
index 000000000000..cb975e0352f6
--- /dev/null
+++ b/emulators/Elliott-803/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= Elliott-803
+PORTVERSION= 0.1.3
+DISTVERSIONPREFIX= v
+CATEGORIES= emulators
+
+MAINTAINER= hsw@bitmark.com
+COMMENT= Emulator and compilers for Elliott 803 computer
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= ncurses
+MAKEFILE= BSDmakefile
+MAKE_ARGS+= PREFIX="${PREFIX}" VERSION="${PKGVERSION}"
+MAKE_ENV+= LC_ALL=en_US.UTF-8
+
+USE_GITHUB= yes
+GH_ACCOUNT= hxw
+
+.include <bsd.port.mk>
diff --git a/emulators/Elliott-803/distinfo b/emulators/Elliott-803/distinfo
new file mode 100644
index 000000000000..c21ea92c7ae7
--- /dev/null
+++ b/emulators/Elliott-803/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1593512685
+SHA256 (hxw-Elliott-803-v0.1.3_GH0.tar.gz) = 8ee67531fa1d79ddf7518a2c8d3353cf8821973259950bdfb17634c29b5d9131
+SIZE (hxw-Elliott-803-v0.1.3_GH0.tar.gz) = 134490
diff --git a/emulators/Elliott-803/pkg-descr b/emulators/Elliott-803/pkg-descr
new file mode 100644
index 000000000000..25f0832d6de1
--- /dev/null
+++ b/emulators/Elliott-803/pkg-descr
@@ -0,0 +1,7 @@
+Elliott-803 contains an emulator for this 1960s 39 bit computer.
+Also provided are tape files of some programs, including:
+* The Algol60 compiler
+* Two versions of the H-Code compiler
+* T2 and T102 sources
+
+WWW: https://github.com/hxw/Elliott-803
diff --git a/emulators/Elliott-803/pkg-plist b/emulators/Elliott-803/pkg-plist
new file mode 100644
index 000000000000..1031429f252f
--- /dev/null
+++ b/emulators/Elliott-803/pkg-plist
@@ -0,0 +1,18 @@
+bin/emu803
+man/man1/emu803.1.gz
+%%DATADIR%%/Elliott-Algol60-A104/a104-tape-1.hex5
+%%DATADIR%%/Elliott-Algol60-A104/a104-tape-2.hex5
+%%DATADIR%%/Elliott-Algol60-A104/A104.md
+%%DATADIR%%/Elliott-Programs/com-208.hex5
+%%DATADIR%%/Elliott-Programs/README.markdown
+%%DATADIR%%/Elliott-Programs/t102-rel-add.elliott
+%%DATADIR%%/Elliott-Programs/t102-rel-add.hex5
+%%DATADIR%%/Elliott-Programs/t2-rel-add.elliott
+%%DATADIR%%/Elliott-Programs/t2-rel-add.hex5
+%%DATADIR%%/H-Code-Compilers/h-code-compiler-plus.hex5
+%%DATADIR%%/H-Code-Compilers/h-code-compiler.hex5
+%%DATADIR%%/H-Code-Compilers/README.markdown
+%%DATADIR%%/hello/hello-a60.script
+%%DATADIR%%/hello/hello-h-code.script
+%%DATADIR%%/hello/hello.a60
+%%DATADIR%%/hello/hello.hc
diff --git a/emulators/Makefile b/emulators/Makefile
index 8794c11d40f5..32fada287754 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -3,6 +3,7 @@
COMMENT = Emulators for other operating systems
+ SUBDIR += Elliott-803
SUBDIR += adamem
SUBDIR += advancemame
SUBDIR += advancemenu