aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-05-15 15:29:30 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-05-15 15:29:30 +0000
commit2297c4042d81ed5f39d3a2fce0558f817c37e392 (patch)
treec69b921e8518248e385e4b7bd2f5e8d8aed3007e /emulators
parent115b9be165967b2b8e735f102c5a03bf5a7178f8 (diff)
downloadports-2297c4042d81ed5f39d3a2fce0558f817c37e392.tar.gz
ports-2297c4042d81ed5f39d3a2fce0558f817c37e392.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/wine-gecko-devel/Makefile29
-rw-r--r--emulators/wine-gecko-devel/distinfo2
-rw-r--r--emulators/wine-gecko-devel/pkg-descr6
-rw-r--r--emulators/wine-gecko-devel/pkg-plist4
-rw-r--r--emulators/wine-gecko/Makefile29
-rw-r--r--emulators/wine-gecko/distinfo2
-rw-r--r--emulators/wine-gecko/pkg-descr6
-rw-r--r--emulators/wine-gecko/pkg-plist4
9 files changed, 83 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 1279724041bc..402135f86099 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -180,6 +180,7 @@
SUBDIR += wahcade
SUBDIR += wine
SUBDIR += wine-doors
+ SUBDIR += wine-gecko
SUBDIR += x48
SUBDIR += xbraitenberg
SUBDIR += xcpc
diff --git a/emulators/wine-gecko-devel/Makefile b/emulators/wine-gecko-devel/Makefile
new file mode 100644
index 000000000000..866104a6b033
--- /dev/null
+++ b/emulators/wine-gecko-devel/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wine_gecko
+# Date created: 2011-04-30
+# Whom: David Naylor <naylor.b.david@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wine-gecko
+DISTVERSION= 1.2.0
+CATEGORIES= emulators
+MASTER_SITES= SF/wine/Wine%20Gecko/${DISTVERSION}
+DISTNAME= wine_gecko-${DISTVERSION}-x86
+EXTRACT_SUFX= .msi
+EXTRACT_ONLY=
+
+MAINTAINER= naylor.b.david@gmail.com
+COMMENT= Gecko Layout Engine for Wine (HTML support)
+
+NO_BUILD= yes
+PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
+
+LICENSE= MPL GPLv2 GPLv3 LGPL21 LGPL3
+LICENSE_COMB= multi
+
+do-install:
+ ${MKDIR} ${DATADIR}/wine/gecko
+ ${INSTALL_DATA} ${DISTDIR}/wine_gecko-${DISTVERSION}-x86.msi ${DATADIR}/wine/gecko
+
+.include <bsd.port.mk>
diff --git a/emulators/wine-gecko-devel/distinfo b/emulators/wine-gecko-devel/distinfo
new file mode 100644
index 000000000000..5ad6af028ddd
--- /dev/null
+++ b/emulators/wine-gecko-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wine_gecko-1.2.0-x86.msi) = d6ccdb32b5867df207c7cd89513297ceb89cfa93696bece470467845c6c4d3ee
+SIZE (wine_gecko-1.2.0-x86.msi) = 12604928
diff --git a/emulators/wine-gecko-devel/pkg-descr b/emulators/wine-gecko-devel/pkg-descr
new file mode 100644
index 000000000000..d7c1d518c89b
--- /dev/null
+++ b/emulators/wine-gecko-devel/pkg-descr
@@ -0,0 +1,6 @@
+Wine implements its own version of Internet Explorer which is based on
+a custom version of Mozilla's Gecko Layout Engine. This engine is down-
+loaded automatically the first time a web page is loaded unless, as done
+by this port, the engine is pre-installed on the user's system.
+
+WWW: http://wiki.winehq.org/Gecko
diff --git a/emulators/wine-gecko-devel/pkg-plist b/emulators/wine-gecko-devel/pkg-plist
new file mode 100644
index 000000000000..0229a0fa0cef
--- /dev/null
+++ b/emulators/wine-gecko-devel/pkg-plist
@@ -0,0 +1,4 @@
+%%DATADIR%%/wine/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+@dirrm %%DATADIR%%/wine/gecko
+@dirrmtry %%DATADIR%%/wine
+@dirrmtry %%DATADIR%%
diff --git a/emulators/wine-gecko/Makefile b/emulators/wine-gecko/Makefile
new file mode 100644
index 000000000000..866104a6b033
--- /dev/null
+++ b/emulators/wine-gecko/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wine_gecko
+# Date created: 2011-04-30
+# Whom: David Naylor <naylor.b.david@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wine-gecko
+DISTVERSION= 1.2.0
+CATEGORIES= emulators
+MASTER_SITES= SF/wine/Wine%20Gecko/${DISTVERSION}
+DISTNAME= wine_gecko-${DISTVERSION}-x86
+EXTRACT_SUFX= .msi
+EXTRACT_ONLY=
+
+MAINTAINER= naylor.b.david@gmail.com
+COMMENT= Gecko Layout Engine for Wine (HTML support)
+
+NO_BUILD= yes
+PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
+
+LICENSE= MPL GPLv2 GPLv3 LGPL21 LGPL3
+LICENSE_COMB= multi
+
+do-install:
+ ${MKDIR} ${DATADIR}/wine/gecko
+ ${INSTALL_DATA} ${DISTDIR}/wine_gecko-${DISTVERSION}-x86.msi ${DATADIR}/wine/gecko
+
+.include <bsd.port.mk>
diff --git a/emulators/wine-gecko/distinfo b/emulators/wine-gecko/distinfo
new file mode 100644
index 000000000000..5ad6af028ddd
--- /dev/null
+++ b/emulators/wine-gecko/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wine_gecko-1.2.0-x86.msi) = d6ccdb32b5867df207c7cd89513297ceb89cfa93696bece470467845c6c4d3ee
+SIZE (wine_gecko-1.2.0-x86.msi) = 12604928
diff --git a/emulators/wine-gecko/pkg-descr b/emulators/wine-gecko/pkg-descr
new file mode 100644
index 000000000000..d7c1d518c89b
--- /dev/null
+++ b/emulators/wine-gecko/pkg-descr
@@ -0,0 +1,6 @@
+Wine implements its own version of Internet Explorer which is based on
+a custom version of Mozilla's Gecko Layout Engine. This engine is down-
+loaded automatically the first time a web page is loaded unless, as done
+by this port, the engine is pre-installed on the user's system.
+
+WWW: http://wiki.winehq.org/Gecko
diff --git a/emulators/wine-gecko/pkg-plist b/emulators/wine-gecko/pkg-plist
new file mode 100644
index 000000000000..0229a0fa0cef
--- /dev/null
+++ b/emulators/wine-gecko/pkg-plist
@@ -0,0 +1,4 @@
+%%DATADIR%%/wine/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+@dirrm %%DATADIR%%/wine/gecko
+@dirrmtry %%DATADIR%%/wine
+@dirrmtry %%DATADIR%%