aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:25:01 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:25:01 +0000
commitbb3b5d6cd8a5c6ebf17afe0f71c60f374e67245b (patch)
tree724b7fcac767151334f750cc1d1cf77acf8e84b8 /emulators
parentf523b21b61a3853563632cb09ef89b80788b261c (diff)
downloadports-bb3b5d6cd8a5c6ebf17afe0f71c60f374e67245b.tar.gz
ports-bb3b5d6cd8a5c6ebf17afe0f71c60f374e67245b.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vmware3/Makefile50
-rw-r--r--emulators/vmware3/distinfo3
-rw-r--r--emulators/vmware3/files/001.vmware.sh.in (renamed from emulators/vmware3/files/001.vmware.sh)8
-rw-r--r--emulators/vmware3/files/config9
-rw-r--r--emulators/vmware3/files/config.in9
-rw-r--r--emulators/vmware3/files/pkg-message.in4
-rw-r--r--emulators/vmware3/files/vmware-wizard.in (renamed from emulators/vmware3/files/vmware-wizard)8
-rw-r--r--emulators/vmware3/files/vmware.in (renamed from emulators/vmware3/files/vmware)8
8 files changed, 42 insertions, 57 deletions
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 3fb07fab77a1..6260e0604083 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -37,6 +37,14 @@ USE_SUBMAKE= yes
VMDIR= ${PREFIX}/lib/vmware
SRC_BASE?= /usr/src
+SUB_FILES= vmware vmware-wizard pkg-message config 001.vmware.sh
+SUB_LIST= BRIDGED="${VMNET_BRIDGED}" \
+ BRIDGE_INTF="${VMNET_BRIDGED_INTERFACE}" \
+ HOST_IP="${VMNET_HOST_IP}" \
+ NETMASK="${VMNET_NETMASK}" \
+ LINUXBASE="${LINUXBASE}" \
+ NETWORKING="${VMNET_NETWORKING}" \
+ VMNET1_MINOR="${VMNET1_MINOR}"
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
@@ -108,18 +116,17 @@ pre-patch:
@cd ${WRKSRC}/vmnet-only && ${PATCH} -p1 < ${WRKDIR}/vmnet-only.diff
.if exists(/sys/compat/linux/linux_ioctl.h)
- ${PERL} -i -pe 's,i386(/linux/linux_ioctl\.h),compat$$1,' \
+ ${REINPLACE_CMD} -i "" -e 's,i386(/linux/linux_ioctl\.h),compat$$1,' \
${WRKSRC}/vmnet-only/freebsd/vmnet_linux.c
.endif
.if exists(/usr/include/sys/selinfo.h)
- ${PERL} -i -pe 's,<sys/select\.h>,<sys/selinfo.h>,' \
+ ${REINPLACE_CMD} -i "" -e 's,<sys/select\.h>,<sys/selinfo.h>,' \
${WRKSRC}/vmmon-only/freebsd/*.c
.endif
cd ${WRKSRC}/vmmon-only/freebsd && ${TOUCH} bus_if.h device_if.h
.if ${OSVERSION} >= 500019
- ${PERL} -i -pe 's,<machine/ioctl_fd\.h>,<sys/fdcio.h>,' \
- ${WRKSRC}/vmmon-only/freebsd/*.c \
- ${WRKSRC}/vmware-distrib/vmmon-only/freebsd/*.c
+ ${REINPLACE_CMD} -i "" -e 's,<machine/ioctl_fd\.h>,<sys/fdcio.h>,' \
+ ${WRKSRC}/vmmon-only/freebsd/*.c
.endif
post-patch:
@@ -127,39 +134,14 @@ post-patch:
${CP} ${FILESDIR}/Makefile.vmmon ${WRKSRC}/vmmon-only/Makefile
${CP} ${FILESDIR}/Makefile.vmnet ${WRKSRC}/vmnet-only/Makefile
.if ${OSVERSION} < 500000
- ${CAT} ${FILESDIR}/freebsd4.patch | (cd ${WRKSRC} && ${PATCH}) > /dev/null 2>&1
+ cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/freebsd4.patch
.endif
.if ${OSVERSION} > 600000
- ${CAT} ${FILESDIR}/fbsd6-1.patch | (cd ${WRKSRC} && ${PATCH}) > /dev/null 2>&1
- ${CAT} ${FILESDIR}/fbsd6-2.patch | (cd ${WRKSRC} && ${PATCH}) > /dev/null 2>&1
+ cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/fbsd6-1.patch
+ cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/fbsd6-2.patch
.endif
-setoptions:
- ${SED} -e 's;@@PREFIX@@;${PREFIX};' \
- -e 's;@@BRIDGED@@;${VMNET_BRIDGED};' \
- -e 's;@@BRIDGE_INTF@@;${VMNET_BRIDGED_INTERFACE};' \
- -e 's;@@HOST_IP@@;${VMNET_HOST_IP};' \
- -e 's;@@NETMASK@@;${VMNET_NETMASK};' \
- ${FILESDIR}/config > ${WRKDIR}/config
-
- ${SED} -e 's;@@PREFIX@@;${PREFIX};' \
- -e 's;@@LINUXBASE@@;${LINUXBASE};' \
- -e 's;@@NETWORKING@@;${VMNET_NETWORKING};' \
- -e 's;@@VMNET1_MINOR@@;${VMNET1_MINOR};' \
- ${FILESDIR}/001.vmware.sh > ${WRKDIR}/001.vmware.sh
-
- ${SED} -e 's;@@PREFIX@@;${PREFIX};' \
- -e 's;@@LINUXBASE@@;${LINUXBASE};' \
- ${FILESDIR}/vmware > ${WRKDIR}/vmware
-
- ${SED} -e 's;@@PREFIX@@;${PREFIX};' \
- -e 's;@@LINUXBASE@@;${LINUXBASE};' \
- ${FILESDIR}/vmware-wizard > ${WRKDIR}/vmware-wizard
-
- ${SED} -e 's;@@PREFIX@@;${PREFIX};' \
- ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
-
-pre-install: setoptions
+pre-install:
${INSTALL_MAN} ${WRKSRC}/man/man1/vmware.1 ${MANPREFIX}/man/man1
${MKDIR} ${VMDIR}/modules
diff --git a/emulators/vmware3/distinfo b/emulators/vmware3/distinfo
index 80f01c15094c..3c737a264298 100644
--- a/emulators/vmware3/distinfo
+++ b/emulators/vmware3/distinfo
@@ -1,6 +1,9 @@
MD5 (VMware-workstation-3.2.1-2242.tar.gz) = 56dccf022582a374cf2eac06796115cf
+SHA256 (VMware-workstation-3.2.1-2242.tar.gz) = ec305ca65c2e513b5d809e59849176d15dcf6a8f88e3d9bc9ce8fdca59fc2dfc
SIZE (VMware-workstation-3.2.1-2242.tar.gz) = 12577292
MD5 (vmmon-only-3.2.1-20040727.tar.gz) = 5de4405befdca3a5e3db09c6a1eaa928
+SHA256 (vmmon-only-3.2.1-20040727.tar.gz) = 6241a5e59a18f39aeec1f75f36d7bc346f9484131d2fb40413f93683ec26e50b
SIZE (vmmon-only-3.2.1-20040727.tar.gz) = 52023
MD5 (vmnet-only-3.2.1-20040705.tar.gz) = a11022f353315b78ba5a782ce8c14e67
+SHA256 (vmnet-only-3.2.1-20040705.tar.gz) = 8d40e97be3d41867e11d61984401514d57be2b2195727652bb3f21189505d35f
SIZE (vmnet-only-3.2.1-20040705.tar.gz) = 7480
diff --git a/emulators/vmware3/files/001.vmware.sh b/emulators/vmware3/files/001.vmware.sh.in
index 381f8b400a62..865f32e64407 100644
--- a/emulators/vmware3/files/001.vmware.sh
+++ b/emulators/vmware3/files/001.vmware.sh.in
@@ -2,9 +2,9 @@
#
# Start or stop vmware
#
-# $FreeBSD: /tmp/pcvs/ports/emulators/vmware3/files/Attic/001.vmware.sh,v 1.2 2004-07-08 08:26:34 silby Exp $
+# $FreeBSD: /tmp/pcvs/ports/emulators/vmware3/files/Attic/001.vmware.sh.in,v 1.1 2006-05-15 07:25:01 lawrance Exp $
-vmware_config_file=@@PREFIX@@/etc/vmware/config
+vmware_config_file=%%PREFIX%%/etc/vmware/config
if [ ! -e $vmware_config_file ]; then
echo "$vmware_config_file does not exist!" >&2
@@ -23,9 +23,9 @@ vmware_config() {
vmware=`vmware_config vmware.fullpath`
vmware_libdir=`vmware_config libdir`
-networking=@@NETWORKING@@
+networking=%%NETWORKING%%
dev_vmnet1=/dev/vmnet1
-vmnet1_minor=@@VMNET1_MINOR@@
+vmnet1_minor=%%VMNET1_MINOR%%
if [ ! -x $vmware ]; then
echo "$vmware does not exist!" >&2
diff --git a/emulators/vmware3/files/config b/emulators/vmware3/files/config
deleted file mode 100644
index ae7c158a442f..000000000000
--- a/emulators/vmware3/files/config
+++ /dev/null
@@ -1,9 +0,0 @@
-vmware.fullpath = "@@PREFIX@@/lib/vmware/bin/vmware"
-wizard.fullpath = "@@PREFIX@@/lib/vmware/bin/vmware-wizard"
-dhcpd.fullpath = "@@PREFIX@@/lib/vmware/bin/vmnet-dhcpd"
-loop.fullpath = "@@PREFIX@@/lib/vmware/bin/vmware-loop"
-libdir = "@@PREFIX@@/lib/vmware"
-vmnet1.Bridged = "@@BRIDGED@@"
-vmnet1.BridgeInterface = "@@BRIDGE_INTF@@"
-vmnet1.HostOnlyAddress = "@@HOST_IP@@"
-vmnet1.HostOnlyNetMask = "@@NETMASK@@"
diff --git a/emulators/vmware3/files/config.in b/emulators/vmware3/files/config.in
new file mode 100644
index 000000000000..aa4883c0ec5a
--- /dev/null
+++ b/emulators/vmware3/files/config.in
@@ -0,0 +1,9 @@
+vmware.fullpath = "%%PREFIX%%/lib/vmware/bin/vmware"
+wizard.fullpath = "%%PREFIX%%/lib/vmware/bin/vmware-wizard"
+dhcpd.fullpath = "%%PREFIX%%/lib/vmware/bin/vmnet-dhcpd"
+loop.fullpath = "%%PREFIX%%/lib/vmware/bin/vmware-loop"
+libdir = "%%PREFIX%%/lib/vmware"
+vmnet1.Bridged = "%%BRIDGED%%"
+vmnet1.BridgeInterface = "%%BRIDGE_INTF%%"
+vmnet1.HostOnlyAddress = "%%HOST_IP%%"
+vmnet1.HostOnlyNetMask = "%%NETMASK%%"
diff --git a/emulators/vmware3/files/pkg-message.in b/emulators/vmware3/files/pkg-message.in
index fb49dbb83c6c..9edffa59f40c 100644
--- a/emulators/vmware3/files/pkg-message.in
+++ b/emulators/vmware3/files/pkg-message.in
@@ -6,7 +6,7 @@ In order to use VMware, you must follow these steps:
2) Make sure the Linux Compatibility module is loaded (use
'kldstat' to check) or built into the kernel.
-3) Run '@@PREFIX@@/etc/rc.d/001.vmware.sh start'
+3) Run '%%PREFIX%%/etc/rc.d/001.vmware.sh start'
to avoid rebooting.
4) Load the kernel module aio.ko or add it to the kernel
@@ -37,6 +37,6 @@ more information.
If you'd like to learn more on how to configure vmnet
interfaces for multiple instances of VMware, please read:
- @@PREFIX@@/share/doc/vmware/MultipleInstances.FreeBSD
+ %%PREFIX%%/share/doc/vmware/MultipleInstances.FreeBSD
************************************************************
diff --git a/emulators/vmware3/files/vmware-wizard b/emulators/vmware3/files/vmware-wizard.in
index 76f21bbcd9d9..d972e8d61a50 100644
--- a/emulators/vmware3/files/vmware-wizard
+++ b/emulators/vmware3/files/vmware-wizard.in
@@ -2,11 +2,11 @@
#
# Run vmware-wizard
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/emulators/vmware3/files/Attic/vmware-wizard.in,v 1.1 2006-05-15 07:25:01 lawrance Exp $
-if [ ! -e @@LINUXBASE@@/proc/cpuinfo ]; then
+if [ ! -e %%LINUXBASE%%/proc/cpuinfo ]; then
echo "************************************************************"
- echo "It seems Linux procfs is not mounted on @@LINUXBASE@@/proc."
+ echo "It seems Linux procfs is not mounted on %%LINUXBASE%%/proc."
echo "VMware does not work without Linux procfs mounted."
echo
echo "For details, see linprocfs(5) manpage."
@@ -23,4 +23,4 @@ if [ _$TMPDIR = _ ]; then
export TMPDIR
fi
-exec @@PREFIX@@/lib/vmware/bin/vmware-wizard "$@"
+exec %%PREFIX%%/lib/vmware/bin/vmware-wizard "$@"
diff --git a/emulators/vmware3/files/vmware b/emulators/vmware3/files/vmware.in
index 6693fad91f09..d48a7bd20bcd 100644
--- a/emulators/vmware3/files/vmware
+++ b/emulators/vmware3/files/vmware.in
@@ -2,11 +2,11 @@
#
# Run vmware
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/emulators/vmware3/files/Attic/vmware.in,v 1.1 2006-05-15 07:25:01 lawrance Exp $
-if [ ! -e @@LINUXBASE@@/proc/cpuinfo ]; then
+if [ ! -e %%LINUXBASE%%/proc/cpuinfo ]; then
echo "************************************************************"
- echo "It seems Linux procfs is not mounted on @@LINUXBASE@@/proc."
+ echo "It seems Linux procfs is not mounted on %%LINUXBASE%%/proc."
echo "VMware does not work without Linux procfs mounted."
echo
echo "For details, see linprocfs(5) manpage."
@@ -23,4 +23,4 @@ if [ _$TMPDIR = _ ]; then
export TMPDIR
fi
-exec @@PREFIX@@/lib/vmware/bin/vmware "$@"
+exec %%PREFIX%%/lib/vmware/bin/vmware "$@"