aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-05-01 18:47:10 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-05-01 18:47:10 +0000
commit356555b4a9039198370607c27a2edab655f63030 (patch)
treebcfd7e3525774c0884e31fd069d6c70bae6017d1 /emulators
parent729df3ac44c6abe6b96b7a952877cd8493cd7270 (diff)
downloadports-356555b4a9039198370607c27a2edab655f63030.tar.gz
ports-356555b4a9039198370607c27a2edab655f63030.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/pcap-patch14
3 files changed, 15 insertions, 7 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index cd3879c9caf5..648b7b0974e4 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.10.2
+PORTVERSION= 0.10.3
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index d5e0fcd2eb44..4071fd579742 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,3 @@
-MD5 (qemu/qemu-0.10.2.tar.gz) = 85a323cdf620687f39c5328f450a547d
-SHA256 (qemu/qemu-0.10.2.tar.gz) = fb93a49b2999a4572337fc9012c1b64be1095477446edda1a885b20387ec9a69
-SIZE (qemu/qemu-0.10.2.tar.gz) = 3658623
+MD5 (qemu/qemu-0.10.3.tar.gz) = 320d6c536c8a1288cdc6c809f487e6d7
+SHA256 (qemu/qemu-0.10.3.tar.gz) = 89540d7a8c880a6ae33f8a55d55d580f3f03c10b02e32b7323719b3354f7b077
+SIZE (qemu/qemu-0.10.3.tar.gz) = 3661566
diff --git a/emulators/qemu/files/pcap-patch b/emulators/qemu/files/pcap-patch
index a0b70c83ff67..33c60a44cb67 100644
--- a/emulators/qemu/files/pcap-patch
+++ b/emulators/qemu/files/pcap-patch
@@ -101,7 +101,7 @@ Index: net.c
#if defined(CONFIG_SLIRP)
#include "libslirp.h"
#endif
-@@ -450,6 +457,164 @@
+@@ -481,6 +488,172 @@
return max_len;
}
@@ -133,6 +133,14 @@ Index: net.c
+ pcap_dispatch(s->handle, 1, (pcap_handler)&pcap_callback, (u_char *)s->vc);
+}
+
++static void pcap_cleanup(VLANClientState *vc)
++{
++ PCAPState *s = vc->opaque;
++
++ pcap_close(s->handle);
++ qemu_free(s);
++}
++
+static int net_pcap_init(VLANState *vlan, const char *model, const char *name, char *ifname)
+{
+ PCAPState *s = NULL;
@@ -230,7 +238,7 @@ Index: net.c
+#endif /* HAVE_BPF */
+#endif /* _WIN32 */
+
-+ s->vc = qemu_new_vlan_client(vlan, model, name, pcap_receive, NULL, s);
++ s->vc = qemu_new_vlan_client(vlan, model, name, pcap_receive, NULL, pcap_cleanup, s);
+ snprintf(s->vc->info_str, sizeof(s->vc->info_str), "pcap redirector");
+
+#if defined(_WIN32)
@@ -266,7 +274,7 @@ Index: net.c
#if defined(CONFIG_SLIRP)
/* slirp network adapter */
-@@ -1681,6 +1846,16 @@
+@@ -1755,6 +1928,16 @@
are wanted */
ret = 0;
} else