aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2016-11-14 02:58:57 +0000
committerSean Bruno <sbruno@FreeBSD.org>2016-11-14 02:58:57 +0000
commit5558ef6556714b55605398a4c15a914103fbdb96 (patch)
tree018196c519d1abedc747aa420628c4538c691d38 /emulators
parent1c9c07f2175d9cdacbc07393d28d5ca07f3a5561 (diff)
downloadports-5558ef6556714b55605398a4c15a914103fbdb96.tar.gz
ports-5558ef6556714b55605398a4c15a914103fbdb96.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-sbruno/Makefile5
-rw-r--r--emulators/qemu-sbruno/files/patch-configure15
2 files changed, 16 insertions, 4 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index af360f7cea39..fea0b705447f 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.7.50.g20161111
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= GH \
LOCAL/nox:dtc \
@@ -250,12 +251,8 @@ PLIST_SUB+= LINUXBOOT_DMA="@comment "
PLIST_SUB+= LINUXBOOT_DMA=""
.endif
-# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
-# but it shouldn't matter much
post-patch:
@${MV} ${WRKDIR}/dtc ${WRKSRC}
- @${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
.if (${OSVERSION} < 1100000)
diff --git a/emulators/qemu-sbruno/files/patch-configure b/emulators/qemu-sbruno/files/patch-configure
new file mode 100644
index 000000000000..8a0ca6ab3a09
--- /dev/null
+++ b/emulators/qemu-sbruno/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig 2016-11-10 11:32:23.000000000 -0700
++++ configure 2016-11-13 09:06:21.654976000 -0700
+@@ -2977,10 +2977,10 @@
+ # curses probe
+ if test "$curses" != "no" ; then
+ if test "$mingw32" = "yes" ; then
+- curses_inc_list="$($pkg_config --cflags ncurses 2>/dev/null):"
++ curses_inc_list="$($pkg_config --cflags-only-I ncurses 2>/dev/null):"
+ curses_lib_list="$($pkg_config --libs ncurses 2>/dev/null):-lpdcurses"
+ else
+- curses_inc_list="$($pkg_config --cflags ncursesw 2>/dev/null):-I/usr/include/ncursesw:"
++ curses_inc_list="$($pkg_config --cflags-only-I ncursesw 2>/dev/null):-I/usr/include/ncursesw:"
+ curses_lib_list="$($pkg_config --libs ncursesw 2>/dev/null):-lncursesw:-lcursesw"
+ fi
+ curses_found=no