aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-02 15:41:47 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-02 15:41:47 +0000
commit99d6d12a388dab91f415ddebd52c6a57e3a6347a (patch)
treedecf1f7754d8060ee740cd0c0edc9a51c04a0ec1 /emulators
parent577806de96b111cab272c48a686bcca681cc6d4d (diff)
downloadports-99d6d12a388dab91f415ddebd52c6a57e3a6347a.tar.gz
ports-99d6d12a388dab91f415ddebd52c6a57e3a6347a.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dboxfe/Makefile3
-rw-r--r--emulators/higan/Makefile7
-rw-r--r--emulators/q4wine/Makefile3
-rw-r--r--emulators/qtemu/Makefile3
-rw-r--r--emulators/swine/Makefile3
-rw-r--r--emulators/yabause/Makefile12
6 files changed, 30 insertions, 1 deletions
diff --git a/emulators/dboxfe/Makefile b/emulators/dboxfe/Makefile
index 49cf66ff63ec..103a5c948493 100644
--- a/emulators/dboxfe/Makefile
+++ b/emulators/dboxfe/Makefile
@@ -12,6 +12,9 @@ COMMENT= Qt4 based configuration manager for DOSBox
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
RUN_DEPENDS= dosbox:emulators/dosbox
USES= qmake qt:4 tar:bzip2
diff --git a/emulators/higan/Makefile b/emulators/higan/Makefile
index e86dc5e49f39..fb67da4dafed 100644
--- a/emulators/higan/Makefile
+++ b/emulators/higan/Makefile
@@ -76,6 +76,13 @@ INPUT_SDL_VARS= INPUT_DRIVER+=input.sdl
INPUT_X_VARS= INPUT_DRIVER+=input.xlib
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
post-patch:
${REINPLACE_CMD} \
-e 's|%%VIDEO%%|${VIDEO_DRIVER}|' \
diff --git a/emulators/q4wine/Makefile b/emulators/q4wine/Makefile
index 55f480e833a9..4b5da353c70f 100644
--- a/emulators/q4wine/Makefile
+++ b/emulators/q4wine/Makefile
@@ -13,6 +13,9 @@ COMMENT= QT4 front-end for WINE
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
BUILD_DEPENDS= icotool:graphics/icoutils
RUN_DEPENDS= sudo:security/sudo \
wget:ftp/wget \
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 6ebddf983e49..f16e8cd7470b 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -12,6 +12,9 @@ COMMENT= Qt 4 based frontend for QEMU
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
USES= qmake qt:4 tar:bzip2
USE_QT= gui xml uic_build moc_build rcc_build
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
diff --git a/emulators/swine/Makefile b/emulators/swine/Makefile
index 951ef4353c9b..029fd3ff5a0b 100644
--- a/emulators/swine/Makefile
+++ b/emulators/swine/Makefile
@@ -12,6 +12,9 @@ COMMENT= Qt4 graphical Wine frontend
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
RUN_DEPENDS= xterm:x11/xterm \
cabextract:archivers/cabextract \
icotool:graphics/icoutils
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index be7c285eda90..cb5846605394 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yabause
PORTVERSION= 0.9.14
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= SF
@@ -25,7 +26,7 @@ SUB_FILES= pkg-message
OPTIONS_DEFINE= SDL2
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= GTK2 QT4 QT5
-OPTIONS_DEFAULT= QT4
+OPTIONS_DEFAULT= QT5
GTK2_LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
GTK2_USE= gnome=gtk20
@@ -44,6 +45,15 @@ SDL2_USE_OFF= sdl=sdl
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
+.if ${PORT_OPTIONS:MQT5}
+BROKEN= does not compile
+.endif
+
post-patch:
.if empty(PORT_OPTIONS:MSDL2)
@${REINPLACE_CMD} -e \