aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-11-18 08:51:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-11-18 08:51:08 +0000
commitc767f350f49e455f482714d554dca787372938ba (patch)
tree4c3b5713bf9854f5455a5dbce8e5bfb546f9cb9c /emulators
parentb15b1b5481103e9b4bf6aa970cbdf6711dbdba3a (diff)
downloadports-c767f350f49e455f482714d554dca787372938ba.tar.gz
ports-c767f350f49e455f482714d554dca787372938ba.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gxemul/Makefile30
-rw-r--r--emulators/gxemul/distinfo5
-rw-r--r--emulators/gxemul/files/patch-configure38
-rw-r--r--emulators/gxemul/files/patch-src_include_refcount__ptr.h11
-rw-r--r--emulators/gxemul/pkg-descr2
5 files changed, 52 insertions, 34 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index e8214400caad..8e89bc6890c7 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -2,27 +2,22 @@
# $FreeBSD$
PORTNAME= gxemul
-PORTVERSION= 0.6.0.1
-PORTREVISION= 6
+PORTVERSION= 0.6.0.2
CATEGORIES= emulators
-MASTER_SITES= http://gxemul.sourceforge.net/src/ \
- http://gavare.se/gxemul/src/
+MASTER_SITES= http://gavare.se/gxemul/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tobik@FreeBSD.org
COMMENT= Instruction-level machine emulator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GCC= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --without-unittests
-ALL_TARGET= build
-MAKE_JOBS_UNSAFE= yes
-
-# svgalib installs vga.h, which conflicts with gxemul when building with
-# a virtual VGA adaptor.
-CONFLICTS= svgalib-[0-9]*
+# Avoid auto-detecting Doxygen. We do not need source code documentation.
+# The handbook is quite comprehensive already.
+BINARY_ALIAS= doxygen=${FALSE}
+CONFIGURE_ARGS= --disable-valgrind --without-unittests
+CONFIGURE_ENV= CXX=${CXX} LOCALBASE=${LOCALBASE} PREFIX=${PREFIX}
PORTDOCS= *
PLIST_FILES= bin/gxemul man/man1/gxemul.1.gz
@@ -30,14 +25,9 @@ PLIST_FILES= bin/gxemul man/man1/gxemul.1.gz
OPTIONS_DEFINE= DOCS X11
OPTIONS_DEFAULT= X11
-X11_USE= xorg=x11
X11_CONFIGURE_OFF= --disable-x
-
-post-patch:
- @${REINPLACE_CMD} -Ee \
- 's|/usr/X11R6|${LOCALBASE}|g; \
- /CXXFLAGS=/s|-O[0-9]?||g; \
- /CXXFLAGS=/s|-f[a-zA-Z-]+||g' ${WRKSRC}/configure
+X11_RUN_DEPENDS= xterm:x11/xterm
+X11_USE= xorg=x11
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gxemul \
diff --git a/emulators/gxemul/distinfo b/emulators/gxemul/distinfo
index 49e5499cd444..45bab4f04cba 100644
--- a/emulators/gxemul/distinfo
+++ b/emulators/gxemul/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gxemul-0.6.0.1.tar.gz) = 0790823d8d7f8848c98318ace829f7a0159a5f9b79d80bd8c367fb17014dcda9
-SIZE (gxemul-0.6.0.1.tar.gz) = 5420978
+TIMESTAMP = 1542524977
+SHA256 (gxemul-0.6.0.2.tar.gz) = 0a0ceb4b5de6463487b28729d40e8e0a6e76ea955306e97aa5a5c74afaeb6636
+SIZE (gxemul-0.6.0.2.tar.gz) = 5498962
diff --git a/emulators/gxemul/files/patch-configure b/emulators/gxemul/files/patch-configure
new file mode 100644
index 000000000000..8cb11e97e73e
--- /dev/null
+++ b/emulators/gxemul/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig 2018-09-06 07:41:13 UTC
++++ configure
+@@ -360,10 +360,10 @@ if [ z$NOX11 = z ]; then
+
+ XOK=0
+
+- XINCLUDE=-I/usr/X11R6/include
++ XINCLUDE=-I${LOCALBASE}/include
+ $CXX $CXXFLAGS _test_x11.cc -c -o _test_x11.o $XINCLUDE 2> /dev/null
+
+- XLIB="-L/usr/X11R6/lib -lX11"
++ XLIB="-L${LOCALBASE}/lib -lX11"
+ $CXX $CXXFLAGS _test_x11.o -o _test_x11 $XLIB 2> /dev/null
+
+ if [ -x _test_x11 ]; then
+@@ -578,22 +578,6 @@ else
+ fi
+ fi
+ rm -f _testprog _testprog.error _testprog.stdout
+-
+-
+-# -O optimization for non-debug builds. Try -O and -O3.
+-if [ ! z"$DEBUG" = zYES ]; then
+- $CXX $CXXFLAGS -O _testprog.cc -o _testprog 2> /dev/null
+- if [ -x _testprog ]; then
+- rm -f _testprog
+- $CXX $CXXFLAGS -O3 _testprog.cc -o _testprog 2> /dev/null
+- if [ -x _testprog ]; then
+- CXXFLAGS="-O3 $CXXFLAGS"
+- else
+- CXXFLAGS="-O $CXXFLAGS"
+- fi
+- fi
+-fi
+-rm -f _testprog
+
+
+ # -fpeephole
diff --git a/emulators/gxemul/files/patch-src_include_refcount__ptr.h b/emulators/gxemul/files/patch-src_include_refcount__ptr.h
deleted file mode 100644
index 991a95cc9430..000000000000
--- a/emulators/gxemul/files/patch-src_include_refcount__ptr.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/include/refcount_ptr.h.orig 2014-08-17 08:45:13 UTC
-+++ src/include/refcount_ptr.h
-@@ -33,6 +33,8 @@ template <class T>
- class refcount_ptr;
-
-
-+#include <stddef.h>
-+
- /**
- * \brief Base class for reference countable objects.
- *
diff --git a/emulators/gxemul/pkg-descr b/emulators/gxemul/pkg-descr
index a92f8dfd257e..f8cc35851e93 100644
--- a/emulators/gxemul/pkg-descr
+++ b/emulators/gxemul/pkg-descr
@@ -17,4 +17,4 @@ emulated well enough to run at least one "guest OS":
* SuperH: Sega Dreamcast (NetBSD/dreamcast, Linux/dreamcast),
Landisk (OpenBSD/landisk)
-WWW: http://gxemul.sourceforge.net/
+WWW: http://gavare.se/gxemul/