aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 04:04:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 04:04:29 +0000
commitd62db648677c0f31e2428f11e00ee30419c766f6 (patch)
tree02e8012b85ce492b6f08e41d5849daa9b134bf43 /emulators
parent2356b8da502c740415f9788a110c879df35c964d (diff)
downloadports-d62db648677c0f31e2428f11e00ee30419c766f6.tar.gz
ports-d62db648677c0f31e2428f11e00ee30419c766f6.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/libvm68k/Makefile4
-rw-r--r--emulators/libvm68k/files/patch-vm68k_iterator.h38
2 files changed, 40 insertions, 2 deletions
diff --git a/emulators/libvm68k/Makefile b/emulators/libvm68k/Makefile
index 928b45c5345d..9cb91a971d4f 100644
--- a/emulators/libvm68k/Makefile
+++ b/emulators/libvm68k/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libvm68k
PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.hypercore.co.jp/vx68k/${PORTNAME}-${PORTVERSION:R}/
@@ -22,7 +22,7 @@ INSTALLS_SHLIB= yes
post-patch:
@${REINPLACE_CMD} -e '/^#define _POSIX_C_SOURCE 199506L/d' \
${WRKSRC}/memory.cc ${WRKSRC}/memory_map.cc ${WRKSRC}/version.cc
- ${REINPLACE_CMD} -e '/^LTLIBRELEASE=/d' \
+ @${REINPLACE_CMD} -e '/^LTLIBRELEASE=/d' \
-e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/emulators/libvm68k/files/patch-vm68k_iterator.h b/emulators/libvm68k/files/patch-vm68k_iterator.h
new file mode 100644
index 000000000000..c4f168cf6d3e
--- /dev/null
+++ b/emulators/libvm68k/files/patch-vm68k_iterator.h
@@ -0,0 +1,38 @@
+--- vm68k/iterator.h.orig Tue Jul 3 20:43:58 2001
++++ vm68k/iterator.h Fri Dec 3 18:09:53 2004
+@@ -127,7 +127,7 @@
+ /* Implementation of `class basic_uint16_iterator'. */
+
+ template <class T>
+- inline basic_uint16_iterator<T>::ref &
++ inline typename basic_uint16_iterator<T>::ref &
+ basic_uint16_iterator<T>::ref::operator=(const uint16_type &value)
+ {
+ p[0] = value >> 8;
+@@ -262,7 +262,7 @@
+ }
+
+ template <class T>
+- inline basic_uint16_iterator<T>::ref
++ inline typename basic_uint16_iterator<T>::ref
+ basic_uint16_iterator<T>::operator[](ptrdiff_t n)
+ {
+ return *(*this + n);
+@@ -287,7 +287,7 @@
+ /* Implementation of `class basic_uint32_iterator'. */
+
+ template <class T>
+- inline basic_uint32_iterator<T>::ref &
++ inline typename basic_uint32_iterator<T>::ref &
+ basic_uint32_iterator<T>::ref::operator=(const uint32_type &value)
+ {
+ p[0] = value >> 24;
+@@ -425,7 +425,7 @@
+ }
+
+ template <class T>
+- inline basic_uint32_iterator<T>::ref
++ inline typename basic_uint32_iterator<T>::ref
+ basic_uint32_iterator<T>::operator[](ptrdiff_t n)
+ {
+ return *(*this + n);