aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-19 14:53:58 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-19 14:53:58 +0000
commit25a9c5b380f1fc02315a244a53797d7a5331db1f (patch)
tree445897e5b7af413eae67e829fbc21b35a0ab453f /emulators
parent314b66f72ecd9f01a14e4e77e89f33459cab93cf (diff)
downloadports-25a9c5b380f1fc02315a244a53797d7a5331db1f.tar.gz
ports-25a9c5b380f1fc02315a244a53797d7a5331db1f.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/fceu-server/Makefile43
-rw-r--r--emulators/fceu-server/distinfo3
-rw-r--r--emulators/fceu-server/pkg-descr3
-rw-r--r--emulators/fceu-server/pkg-plist4
5 files changed, 54 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 1fb479e838aa..6778a76400fc 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -31,6 +31,7 @@
SUBDIR += e-uae
SUBDIR += extract-xiso
SUBDIR += fceu
+ SUBDIR += fceu-server
SUBDIR += fmsx
SUBDIR += frodo
SUBDIR += fuse
diff --git a/emulators/fceu-server/Makefile b/emulators/fceu-server/Makefile
new file mode 100644
index 000000000000..14ef50a2af8c
--- /dev/null
+++ b/emulators/fceu-server/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: fceu-server
+# Date created: 28 July 2007
+# Whom: Pontus Stenetorp <ninjin@kth.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fceu-server
+PORTVERSION= 0.0.5
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fceultra
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ninjin@kth.se
+COMMENT= The network play server for the NES/Famicom emulator fceu
+
+CFLAGS+= -DSOL_TCP=6
+USE_GMAKE= yes
+USE_SDL= sdl
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= does not build on FreeBSD 5.X
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/fceu-standard.conf|${PREFIX}/etc/${PORTNAME}/fceu-standard.conf|g' \
+ ${WRKSRC}/server.cpp
+
+do-install:
+ @${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/fceu-server.conf ${PREFIX}/etc/${PORTNAME}/fceu-server.conf.sample
+ @${INSTALL_PROGRAM} ${WRKSRC}/fceu-server ${PREFIX}/bin
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ @[ -f ${PREFIX}/etc/${PORTNAME}/fceu-standard.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/fceu-server.conf \
+ ${PREFIX}/etc/${PORTNAME}/fceu-standard.conf
+
+.include <bsd.port.post.mk>
diff --git a/emulators/fceu-server/distinfo b/emulators/fceu-server/distinfo
new file mode 100644
index 000000000000..ea56ba295f01
--- /dev/null
+++ b/emulators/fceu-server/distinfo
@@ -0,0 +1,3 @@
+MD5 (fceu-server-0.0.5.tar.gz) = 7c9e974864418a4aa0f42dc325f90600
+SHA256 (fceu-server-0.0.5.tar.gz) = c9e5b3f77e92364ae7a66e351012dc01d6373ea44a100d23ec028f00d5fc825f
+SIZE (fceu-server-0.0.5.tar.gz) = 18623
diff --git a/emulators/fceu-server/pkg-descr b/emulators/fceu-server/pkg-descr
new file mode 100644
index 000000000000..58d2c9cacb92
--- /dev/null
+++ b/emulators/fceu-server/pkg-descr
@@ -0,0 +1,3 @@
+This is a port of the FCE Ultra network play server.
+
+WWW: http://fceultra.sourceforge.net/
diff --git a/emulators/fceu-server/pkg-plist b/emulators/fceu-server/pkg-plist
new file mode 100644
index 000000000000..ed2305165bc5
--- /dev/null
+++ b/emulators/fceu-server/pkg-plist
@@ -0,0 +1,4 @@
+bin/fceu-server
+@unexec if cmp -s %%PREFIX%%/etc/fceu-server/fceu-standard.conf %%PREFIX%%/etc/fceu-server/fceu-server.conf.sample; then rm %%PREFIX%%/etc/fceu-server/fceu-standard.conf; fi
+etc/fceu-server/fceu-server.conf.sample
+@dirrmtry etc/fceu-server