aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-03 00:33:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-03 00:33:16 +0000
commit7f268d38adff995640d37476d77a8ab7cd4fe23b (patch)
tree4fd32a5b1ab9d0f94c24c32c8505938c4f829697 /emulators
parente5b1e2b129eb10ad52d8601dc25ce8080f04aece (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/cpmtools/Makefile13
-rw-r--r--emulators/cpmtools/files/patch-aa218
-rw-r--r--emulators/cpmtools/pkg-plist1
3 files changed, 5 insertions, 227 deletions
diff --git a/emulators/cpmtools/Makefile b/emulators/cpmtools/Makefile
index 3db9ec2301a9..42e9cc769003 100644
--- a/emulators/cpmtools/Makefile
+++ b/emulators/cpmtools/Makefile
@@ -12,15 +12,10 @@ MAINTAINER= joerg@FreeBSD.org
COMMENT= Utility to transfer files from/to CP/M (R) diskettes
WRKSRC= ${WRKDIR}/cpm
-MAN1= cpm.1
-USE_GCC= any
-
-#
-# need our own build target to pass PREFIX down to the make command
-#
-NO_STAGE= yes
-do-build:
- @(cd ${WRKSRC}; ${MAKE} PREFIX=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} all)
+CFLAGS+= -Wno-return-type
+MAKE_ARGS+= PREFIX=${PREFIX} DFLAG="${CFLAGS}" \
+ DEST="${STAGEDIR}${PREFIX}/bin" \
+ HELPFILEDIR="${STAGEDIR}${PREFIX}/lib"
.include <bsd.port.mk>
diff --git a/emulators/cpmtools/files/patch-aa b/emulators/cpmtools/files/patch-aa
deleted file mode 100644
index 2f2a9d80115b..000000000000
--- a/emulators/cpmtools/files/patch-aa
+++ /dev/null
@@ -1,218 +0,0 @@
-diff -c -N ../cpm.orig/Makefile.inc ./Makefile.inc
-*** ../cpm.orig/Makefile.inc Thu Jan 1 01:00:00 1970
---- ./Makefile.inc Mon Dec 26 10:17:54 1994
-***************
-*** 0 ****
---- 1 ----
-+ PREFIX ?= /usr/local
-diff -c -r ../cpm.orig/Makefile ./Makefile
-*** ../cpm.orig/Makefile Wed Jul 27 19:10:43 1983
---- ./Makefile Mon Dec 26 09:55:13 1994
-***************
-*** 1,13 ****
-! # Makefile 4.2 83/07/27
-! #
-! DESTDIR=
-
-! all:
-! cd src; make ${MFLAGS}
-!
-! install: all
-! cd src; make ${MFLAGS} DESTDIR=${DESTDIR} install
-! cd man; make ${MFLAGS} DESTDIR=${DESTDIR} install
-!
-! clean:
-! cd src; make ${MFLAGS} clean
---- 1,3 ----
-! SUBDIR = src man
-
-! .include <bsd.subdir.mk>
-diff -c -r ../cpm.orig/src/Makefile ./src/Makefile
-*** ../cpm.orig/src/Makefile Sat May 28 09:10:55 1994
---- ./src/Makefile Mon Dec 26 09:57:07 1994
-***************
-*** 1,128 ****
-! #
-! # Makefile 1.8 83/07/27
-! #
-! DEST = /usr/local/bin
-! DFLAG = -g -O2
-
-! HELPFILE = cpm.hlp
-! HELPFILEDIR = /usr/local/lib
-!
-! # CFLAGS = -O -DVAX ${DFLAG}
-! CFLAGS = ${DFLAG} -DHELPFILE=\"$(HELPFILEDIR)/$(HELPFILE)\" # -DDEBUG
-
-! EXTHDRS = /usr/include/ctype.h \
-! /usr/include/stdio.h
-!
-! HDRS = command.h \
-! cpmfio.h \
-! cpmio.h
-!
-! LDFLAGS =
-!
-! LIBLIST =
-!
-! LIST = ls -C
-!
-! LOADER = cc
-!
-! MAKEFILE = Makefile
-!
-! OBJS = bitmap.o \
-! blockio.o \
-! cclose.o \
-! ccreat.o \
-! cfillbuf.o \
-! cflsbuf.o \
-! cmdhdl.o \
-! copen.o \
-! copy.o \
-! cpm.o \
-! delete.o \
-! dirhdl.o \
-! extent.o \
-! ffc.o \
-! gensktab.o \
-! hexdmp.o \
-! interact.o \
-! physio.o \
-! pip.o \
-! rename.o
-!
-! PRINT = pr
-!
-! PROGRAM = cpm
-!
-! SRCS = bitmap.c \
-! blockio.c \
-! cclose.c \
-! ccreat.c \
-! cfillbuf.c \
-! cflsbuf.c \
-! cmdhdl.c \
-! copen.c \
-! copy.c \
-! cpm.c \
-! delete.c \
-! dirhdl.c \
-! extent.c \
-! ffc.c \
-! gensktab.c \
-! hexdmp.c \
-! interact.c \
-! physio.c \
-! pip.c \
-! rename.c
-!
-! $(PROGRAM): $(OBJS) $(LIBLIST)
-! @echo -n "Loading $(PROGRAM) ... "
-! @$(LOADER) $(LDFLAGS) $(OBJS) $(LIBLIST) -o $(PROGRAM)
-! @echo "done"
-!
-! debug:; @echo DFLAG = -g -DDEBUG > Makefile.tmp00
-! @cat makefile >>Makefile.tmp00
-! @make -f Makefile.tmp00
-! @rm -f Makefile.tmp00
-!
-! clean:; @rm -f $(OBJS)
-!
-! install: $(PROGRAM)
-! @echo Installing $(PROGRAM) in $(DEST)
-! @install -s $(PROGRAM) $(DEST)
-! @cp $(HELPFILE) $(HELPFILEDIR)
-!
-! depend:; @mkmf PROGRAM=$(PROGRAM) DEST=$(DEST)
-!
-! index:; @ctags -wx $(HDRS) $(SRCS)
-!
-! print:; @$(PRINT) $(HDRS) $(SRCS)
-!
-! program: $(PROGRAM)
-!
-! strip:; @strip $(PROGRAM)
-!
-! tags: $(SRCS); @ctags $(SRCS)
-!
-! update: $(DEST)/$(PROGRAM)
-!
-! $(DEST)/$(PROGRAM): $(SRCS) $(LIBLIST)
-! @make -f $(MAKEFILE) DEST=$(DEST) install
-! ###
-! bitmap.o: /usr/include/stdio.h cpmio.h
-! blockio.o: /usr/include/stdio.h cpmio.h
-! cclose.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! ccreat.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! cfillbuf.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! cflsbuf.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! cmdhdl.o: /usr/include/ctype.h /usr/include/stdio.h cpmio.h
-! copen.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! copy.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! cpm.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! delete.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! dirhdl.o: /usr/include/stdio.h cpmio.h
-! extent.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! gensktab.o: /usr/include/stdio.h cpmio.h
-! hexdmp.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! interact.o: /usr/include/stdio.h command.h
-! physio.o: /usr/include/stdio.h cpmio.h
-! pip.o: /usr/include/stdio.h cpmio.h cpmfio.h
-! rename.o: /usr/include/stdio.h cpmio.h cpmfio.h
---- 1,27 ----
-! # include path for man page
-
-! .include "${.CURDIR}/../Makefile.inc"
-
-! HELPFILE = cpm.hlp
-! HELPFILEDIR = ${PREFIX}/lib
-! BINDIR = ${PREFIX}/bin
-! FILEMODE = 444
-!
-! CFLAGS += -DHELPFILE=\"${HELPFILEDIR}/${HELPFILE}\"
-! #CLFAGS += -DDEBUG
-!
-! PROG = cpm
-! NOMAN = look at ${.CURDIR}/../man
-!
-! SRCS = bitmap.c blockio.c cclose.c ccreat.c cfillbuf.c \
-! cflsbuf.c cmdhdl.c copen.c copy.c cpm.c delete.c \
-! dirhdl.c extent.c ffc.c gensktab.c hexdmp.c interact.c \
-! physio.c pip.c rename.c
-!
-!
-! install:
-! ${INSTALL} -c -m ${FILEMODE} -o ${BINOWN} -g ${BINGRP} \
-! ${.CURDIR}/${HELPFILE} ${HELPFILEDIR}
-! ${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} \
-! ${PROG} ${BINDIR}
-! .include <bsd.prog.mk>
-*** man/Makefile.orig Sat May 28 12:56:44 1994
---- man/Makefile Thu Sep 12 21:48:32 2002
-***************
-*** 1,11 ****
-! all:;
-
-- #MANEXT=n
-- MANEXT=1
-- #MANDIR=/usr/man/man${MANEXT}
-- MANDIR=/usr/local/man/man${MANEXT}
-
-! install:
-! cp cpm.1 ${DESTDIR}/${MANDIR}/cpm.${MANEXT}
-
-! clean:;
---- 1,12 ----
-! .include "${.CURDIR}/../Makefile.inc"
-
-
-! MANDIR = ${PREFIX}/man/man
-
-! MAN1 = cpm.1
-!
-! NOMANCOMPRESS = Handled by the ports system.
-!
-! clean all depend:
-!
-! .include <bsd.prog.mk>
diff --git a/emulators/cpmtools/pkg-plist b/emulators/cpmtools/pkg-plist
index ad27f0f88f81..0dc858c5c4cb 100644
--- a/emulators/cpmtools/pkg-plist
+++ b/emulators/cpmtools/pkg-plist
@@ -1,2 +1,3 @@
bin/cpm
+man/man1/cpm.1.gz
lib/cpm.hlp