aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-21 13:59:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-21 13:59:20 +0000
commit556a038edeabc9796ab254458ddebec4838eb855 (patch)
tree66bf87aa183189607246a7dd456edca2468cae2b /emulators
parent34d7b2e51b531c462729945c4c9fc557db1f718c (diff)
downloadports-556a038edeabc9796ab254458ddebec4838eb855.tar.gz
ports-556a038edeabc9796ab254458ddebec4838eb855.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vba/Makefile29
-rw-r--r--emulators/vba/files/patch-src-sdl-SDL.cpp10
-rw-r--r--emulators/vba/pkg-message2
-rw-r--r--emulators/vba/pkg-plist2
4 files changed, 34 insertions, 9 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 889af7629eae..726b80a452eb 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -6,12 +6,13 @@
PORTNAME= vba
PORTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= VisualBoyAdvance-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arundel@h3c.de
COMMENT= Open Source Gameboy Advance emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
@@ -31,18 +32,22 @@ TARGET_DIR= ${PREFIX}/bin/
CFLAGS+= -O0
.endif
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on 4.x"
-.endif
-
.ifndef(PROFILING)
CONFIGURE_ARGS+= --without-profiling
.endif
+PLIST_SUB= INSTALL_DEBUGGER=""
+
+.ifndef(WITH_DEBUGGER)
+CONFIGURE_ARGS+= --disable-dev
+PLIST_SUB= INSTALL_DEBUGGER="@comment "
+.endif
+
CONFIGURE_ARGS+= LIBS=-L${LOCALBASE}/lib
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
-PROG_FILES= ${WRKSRC}/src/sdl/VisualBoyAdvance ${WRKSRC}/src/sdl/TestEmu
+PROG_FILES= ${WRKSRC}/src/sdl/VisualBoyAdvance
+DEBUG_FILES= ${WRKSRC}/src/sdl/TestEmu
DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
pre-everything::
@@ -50,15 +55,23 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can enable profiling by defining PROFILING."
.endif
+.ifndef(WITH_DEBUGGER)
@${ECHO_MSG} ""
- @${ECHO_MSG} "Due to a bug in gcc2 optimsations other than -O0 will be ignored on"
+ @${ECHO_MSG} "You can install the ARM/THUMB debugger by defining WITH_DEBUGGER."
+.endif
+
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Due to a bug in gcc2 optimizations other than -O0 will be ignored on"
@${ECHO_MSG} "FreeBSD releases that didn't ship with gcc3 (prior 500035)."
@${ECHO_MSG} ""
do-install:
${INSTALL} -d ${TARGET_DIR}
${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
- ${CP} ${DATA_FILES} ${DATA_FILES}-default
+.ifdef(WITH_DEBUGGER)
+ ${INSTALL_PROGRAM} ${DEBUG_FILES} ${TARGET_DIR}
+.endif
+ ${SED} -e 's|filter=0|filter=1|' ${DATA_FILES} > ${DATA_FILES}-default
${INSTALL_DATA} ${DATA_FILES}-default ${TARGET_DIR}
post-install:
diff --git a/emulators/vba/files/patch-src-sdl-SDL.cpp b/emulators/vba/files/patch-src-sdl-SDL.cpp
new file mode 100644
index 000000000000..165fd833b796
--- /dev/null
+++ b/emulators/vba/files/patch-src-sdl-SDL.cpp
@@ -0,0 +1,10 @@
+--- src/remote.cpp.old Thu May 20 19:24:47 2004
++++ src/remote.cpp Thu Aug 19 18:16:57 2004
+@@ -22,6 +22,7 @@
+
+ #ifndef WIN32
+ # include <unistd.h>
++# undef _BSD_SOCKLEN_T_
+ # include <sys/socket.h>
+ # include <netdb.h>
+ # ifdef HAVE_NETINET_IN_H
diff --git a/emulators/vba/pkg-message b/emulators/vba/pkg-message
index 8314d95ddd3b..70c24d2b35bc 100644
--- a/emulators/vba/pkg-message
+++ b/emulators/vba/pkg-message
@@ -1,3 +1,5 @@
+-----------------------------------------------------------------
The default configuration file has been installed as
X11BASE/bin/VisualBoyAdvance.cfg-default. Please copy it to
X11BASE/bin/VisualBoyAdvance.cfg before you start the emulator.
+-----------------------------------------------------------------
diff --git a/emulators/vba/pkg-plist b/emulators/vba/pkg-plist
index 52ba75740154..64458c182822 100644
--- a/emulators/vba/pkg-plist
+++ b/emulators/vba/pkg-plist
@@ -1,6 +1,6 @@
bin/VisualBoyAdvance
bin/VisualBoyAdvance.cfg-default
-bin/TestEmu
+%%INSTALL_DEBUGGER%%bin/TestEmu
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS