aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /emulators
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/advancemame/Makefile4
-rw-r--r--emulators/advancemenu/Makefile3
-rw-r--r--emulators/advancemess/Makefile4
-rw-r--r--emulators/atari800/Makefile3
-rw-r--r--emulators/bochs/Makefile5
-rw-r--r--emulators/cingb/Makefile5
-rw-r--r--emulators/dosbox/Makefile1
-rw-r--r--emulators/dynamips-community/Makefile3
-rw-r--r--emulators/dynamips-devel/Makefile3
-rw-r--r--emulators/dynamips/Makefile3
-rw-r--r--emulators/frodo/Makefile1
-rw-r--r--emulators/fuse/Makefile4
-rw-r--r--emulators/gbe/Makefile5
-rw-r--r--emulators/generator-cbiere/Makefile4
-rw-r--r--emulators/generator/Makefile4
-rw-r--r--emulators/gngb/Makefile5
-rw-r--r--emulators/gngeo/Makefile5
-rw-r--r--emulators/gnuboy/Makefile5
-rw-r--r--emulators/gxmame/Makefile2
-rw-r--r--emulators/hugo/Makefile2
-rw-r--r--emulators/jzintv/Makefile1
-rw-r--r--emulators/mednafen/Makefile1
-rw-r--r--emulators/mtools/Makefile3
-rw-r--r--emulators/o2em/Makefile2
-rw-r--r--emulators/open-vm-tools/Makefile4
-rw-r--r--emulators/pcsxr/Makefile1
-rw-r--r--emulators/qemu-devel/Makefile2
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/snes9x-gtk/Makefile4
-rw-r--r--emulators/snes9x/Makefile4
-rw-r--r--emulators/stella/Makefile4
-rw-r--r--emulators/tiemu3/Makefile1
-rw-r--r--emulators/tpm-emulator/Makefile4
-rw-r--r--emulators/vice/Makefile1
-rw-r--r--emulators/visualos/Makefile4
-rw-r--r--emulators/wine-devel/Makefile6
-rw-r--r--emulators/wine/Makefile6
-rw-r--r--emulators/x48/Makefile2
-rw-r--r--emulators/xcpc/Makefile3
-rw-r--r--emulators/xsystem35/Makefile4
-rw-r--r--emulators/zsnes/Makefile1
41 files changed, 57 insertions, 74 deletions
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
index f6187ed3c5ba..a53b9337a8bd 100644
--- a/emulators/advancemame/Makefile
+++ b/emulators/advancemame/Makefile
@@ -19,8 +19,8 @@ USE_GL= yes
USE_GMAKE= yes
USE_SDL= sdl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -idirafter ${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -idirafter ${LOCALBASE}/include
OPTIONS= FREETYPE "Enable FreeType2 support" off \
SLANG "Enable sLang support (for video driver)" off
diff --git a/emulators/advancemenu/Makefile b/emulators/advancemenu/Makefile
index 302590b10ced..f9423f847aad 100644
--- a/emulators/advancemenu/Makefile
+++ b/emulators/advancemenu/Makefile
@@ -19,7 +19,8 @@ USE_GL= yes
USE_GMAKE= yes
USE_SDL= sdl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS= FREETYPE "Enable FreeType2 support" off \
SLANG "Enable sLang support (for video driver)" off
diff --git a/emulators/advancemess/Makefile b/emulators/advancemess/Makefile
index ba9e25f919ab..a4ea872a7f00 100644
--- a/emulators/advancemess/Makefile
+++ b/emulators/advancemess/Makefile
@@ -20,8 +20,8 @@ USE_GL= yes
USE_GMAKE= yes
USE_SDL= sdl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -idirafter ${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -idirafter ${LOCALBASE}/include
OPTIONS= FREETYPE "Enable FreeType2 support" off \
SLANG "Enable sLang support (for video driver)" off
diff --git a/emulators/atari800/Makefile b/emulators/atari800/Makefile
index 9751b480dd34..7804e83c1741 100644
--- a/emulators/atari800/Makefile
+++ b/emulators/atari800/Makefile
@@ -26,12 +26,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAN1= atari800.1
CFLAGS+= -I${LOCALBASE}/include/libpng
-LDFLAGS= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
ATARI_XF= ataribas.rom atariosb.rom atarixl.rom demos1.xfd \
demos2.xfd dos25.xfd mydos45d.atr
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 262789e02fdb..461a54d7dd72 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
OPTIONS= A20_PIN "Enable support for A20 pin" on \
@@ -73,8 +72,8 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
CFLAGS+= -fno-exceptions -fomit-frame-pointer ${CPPFLAGS}
CXXFLAGS+= -fno-rtti
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MANCOMPRESSED= yes
MAN1= bochs.1 bochs-dlx.1 bxcommit.1 bximage.1
diff --git a/emulators/cingb/Makefile b/emulators/cingb/Makefile
index b1d386764d19..f2405e12937c 100644
--- a/emulators/cingb/Makefile
+++ b/emulators/cingb/Makefile
@@ -17,14 +17,13 @@ COMMENT= Yet another Nintendo GameBoy(tm) emulator
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11 xext
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= standard
PORTDOCS= README README.FAQ
PLIST_FILES= bin/cingb bin/cingb_conf
-CPPFLAGS= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS}
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index cb8521e13915..b216ead873c3 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -24,7 +24,6 @@ MAN1= dosbox.1
PKGMESSAGE= ${WRKDIR}/pkg-message
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS+= --enable-core-inline
post-patch:
diff --git a/emulators/dynamips-community/Makefile b/emulators/dynamips-community/Makefile
index 2545bcfa26ff..ca4022b19a06 100644
--- a/emulators/dynamips-community/Makefile
+++ b/emulators/dynamips-community/Makefile
@@ -32,8 +32,7 @@ MAKE_ENV= \
DYNAMIPS_CODE=${DYNAMIPS_CODE} \
DYNAMIPS_ARCH=${DYNAMIPS_ARCH} \
PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LIBS=${PTHREAD_LIBS} \
- LDFLAGS="${LDFLAGS}"
+ PTHREAD_LIBS=${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index f5ec350007c2..fa8d8713d02d 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -24,8 +24,7 @@ USE_GMAKE= yes
ALL_TARGET= ${PORTNAME} nvram_export
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
- PTHREAD_LIBS=${PTHREAD_LIBS}\
- LDFLAGS="${LDFLAGS}"
+ PTHREAD_LIBS=${PTHREAD_LIBS}
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME} bin/nvram_export
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
index 83b66e287cd9..518f12cc76a5 100644
--- a/emulators/dynamips/Makefile
+++ b/emulators/dynamips/Makefile
@@ -20,8 +20,7 @@ USE_GMAKE= yes
ALL_TARGET= ${PORTNAME} nvram_export
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
- PTHREAD_LIBS=${PTHREAD_LIBS}\
- LDFLAGS="${LDFLAGS}"
+ PTHREAD_LIBS=${PTHREAD_LIBS}
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME} bin/nvram_export
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index 41d733847c16..fdfd81fccbf6 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -22,7 +22,6 @@ ALL_TARGET= Frodo
WRKNAME= Frodo-4.1b
WRKSRC= ${WRKDIR}/${WRKNAME}/Src
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
.if !defined(WITHOUT_SDL)
USE_SDL= sdl
.endif
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 1047fe934b34..e83bdfcc43b8 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -24,8 +24,8 @@ GNU_CONFIGURE= yes
USE_GNOME= libxml2 glib20 gtk20
CONFIGURE_ARGS+=--without-alsa --without-joystick
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAN1= fuse.1
diff --git a/emulators/gbe/Makefile b/emulators/gbe/Makefile
index 6189f89e4085..1dbbe2dd121a 100644
--- a/emulators/gbe/Makefile
+++ b/emulators/gbe/Makefile
@@ -18,12 +18,11 @@ COMMENT= Nintendo GameBoy(tm) emulator with GNU source code
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/gbe
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gbe ${PREFIX}/bin
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index 2ffdb903e934..959ea7591095 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -32,8 +32,8 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
CONFIGURE_ARGS+=--with-gtk
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}-gtk
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index 9aab06cc0167..9ddc09479433 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -21,8 +21,8 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--with-gtk
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
index 0afd85672143..cbd1ca3cff45 100644
--- a/emulators/gngb/Makefile
+++ b/emulators/gngb/Makefile
@@ -17,12 +17,11 @@ COMMENT= GameBoy(tm) emulator
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/gngb
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gngb.1
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index bddebd630d0d..fcfc98ec0f40 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -21,11 +21,10 @@ USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name="" --disable-gp2x
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_JOBS_UNSAFE= yes
-CPPFLAGS= ${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
+CPPFLAGS+= ${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
+LDFLAGS+= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
SUB_FILES= pkg-message
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 6e2f9e0bf6ee..b2012efb2a3f 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -23,15 +23,14 @@ LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
USE_SDL= sdl
USE_XORG= x11
USE_AUTOTOOLS= autoconf
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-sdl
MAKE_JOBS_SAFE= yes
PORTDOCS= *
PLIST_FILES= bin/sdlgnuboy bin/sgnuboy bin/xgnuboy
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
do-install:
.for file in sdlgnuboy sgnuboy xgnuboy
diff --git a/emulators/gxmame/Makefile b/emulators/gxmame/Makefile
index 4b08f4fd7035..53ab5efd587d 100644
--- a/emulators/gxmame/Makefile
+++ b/emulators/gxmame/Makefile
@@ -23,7 +23,7 @@ USE_GNOME= gtk20 intlhack gnomehack gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-xmame-dir=${LOCALBASE}/share/xmame
.if defined(WITHOUT_NLS)
diff --git a/emulators/hugo/Makefile b/emulators/hugo/Makefile
index 2b5b9a22355e..e8912aff04a6 100644
--- a/emulators/hugo/Makefile
+++ b/emulators/hugo/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
.if !defined(WITHOUT_NETPLAY)
USE_SDL+= net
diff --git a/emulators/jzintv/Makefile b/emulators/jzintv/Makefile
index 75bfaeda6e3f..f63185db57eb 100644
--- a/emulators/jzintv/Makefile
+++ b/emulators/jzintv/Makefile
@@ -25,7 +25,6 @@ USE_SDL= sdl
USE_ZIP= yes
CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} `${SDL_CONFIG} --libs`
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= TOOLS "Install additional tools" off
TOOLS= as1600 crc32 dasm1600 dis1600 frombit_r gms2rom imvtoppm rom2bin \
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
index d976cbd3c8be..39eb2edf61a4 100644
--- a/emulators/mednafen/Makefile
+++ b/emulators/mednafen/Makefile
@@ -27,7 +27,6 @@ USE_XORG= x11
USE_GL= glut
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= pkg-message
diff --git a/emulators/mtools/Makefile b/emulators/mtools/Makefile
index a45d3f4f40b5..4434fe422d85 100644
--- a/emulators/mtools/Makefile
+++ b/emulators/mtools/Makefile
@@ -18,8 +18,7 @@ COMMENT= A collection of tools for manipulating MSDOS files
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- ac_cv_header_malloc_h=no
+CONFIGURE_ENV= ac_cv_header_malloc_h=no
CONFIGURE_ARGS= --enable-xdf
SUB_FILES= pkg-message
diff --git a/emulators/o2em/Makefile b/emulators/o2em/Makefile
index ed459c5ce6eb..8809c6ae295b 100644
--- a/emulators/o2em/Makefile
+++ b/emulators/o2em/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/o2em117src
MAKEFILE= Makefile.freebsd
USE_ZIP= yes
USE_GMAKE= yes
-MAKE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+LDFLAGS+= ${PTHREAD_LIBS}
post-extract:
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h|txt)" -print0 | \
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 344b627b924a..485d47b94081 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -42,8 +42,8 @@ CONFIGURE_ARGS+= --disable-unity
.endif
LIB_DEPENDS+= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
CONFIGURE_ARGS+= --with-x
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= x11 ice sm xext xineramaproto xinerama xrandr xrender \
xtst
USE_GNOME= gtk20 glib20
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 5c22eeef8710..75aa67f0b238 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -33,7 +33,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_CSTD= gnu89
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-opengl --enable-libcdio
USE_LDCONFIG= yes
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 038d2c0e795a..41aabe13e02e 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -30,7 +30,7 @@ USE_PYTHON= yes
USE_GNOME= glib20
USE_PERL5_BUILD= yes
PATCH_STRIP= -p1
-MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= BSD_MAKE="${MAKE}"
MAN1= qemu.1 qemu-img.1
MAN8= qemu-nbd.8
ONLY_FOR_ARCHS= amd64 i386 powerpc # XXX someone wants to debug sparc64 hosts?
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d99a5b77fc64..7badffb722dc 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -21,7 +21,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
PATCH_STRIP= -p1
-MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= BSD_MAKE="${MAKE}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= qemu-devel-[0-9]*
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 1c8c47ec268b..212bd8626c49 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -26,8 +26,8 @@ USE_GNOME= gtk20 desktopfileutils pkgconfig intltool libglade2 libxml2
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_SDL= sdl
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --without-alsa
WRKSRC= ${WRKDIR}/${DISTNAME}/gtk
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 449b5e87533a..5aecba0af2eb 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -23,8 +23,8 @@ USE_XORG= x11 sm ice xext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-extensions
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS= INCLUDES="-I${WRKSRC}/unzip -I${WRKSRC} -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}" LDLIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
OPTIMISE="${CXXFLAGS}"
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 0909f77f107c..0f3e6cdccddb 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -22,8 +22,8 @@ USE_SDL= sdl
USE_GMAKE= yes
HAS_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
index f727882bd47b..d1c77d41ca09 100644
--- a/emulators/tiemu3/Makefile
+++ b/emulators/tiemu3/Makefile
@@ -28,7 +28,6 @@ USE_SDL= sdl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -export-dynamic
CONFIGURE_ARGS= --disable-gdb
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAN1= tiemu.1
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 9f470fcb0f71..59abc44dabf2 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -32,8 +32,8 @@ INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
CMAKE_ENV= PREFIX=${PREFIX} ${CONFIGURE_ENV}
-CMAKE_ARGS= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
- -DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
+CMAKE_ARGS= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 0e0b3bd1aa7e..62a88cb92e93 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -56,7 +56,6 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ENV+= PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
CONFIGURE_ARGS+= --enable-fullscreen --enable-ipv6 --disable-dependency-tracking
MAN1= vice.1 c1541.1 petcat.1
diff --git a/emulators/visualos/Makefile b/emulators/visualos/Makefile
index b6e3e6386c20..dcc9279b8077 100644
--- a/emulators/visualos/Makefile
+++ b/emulators/visualos/Makefile
@@ -17,8 +17,8 @@ COMMENT= A visual simulator of an operating system to help understand how OSes w
USE_GNOME= gnomehack gnomeprefix libglade
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= VisualOS.1
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index c4d207792e50..3f278370a351 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
png.6:${PORTSDIR}/graphics/png \
xml2:${PORTSDIR}/textproc/libxml2
-CPPFLAGS= "-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --with-glu \
@@ -36,8 +37,7 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--with-opengl --without-mpg123 --with-oss --without-sane \
--without-v4l --without-xcomposite --without-xinerama \
--with-xinput2 --with-xrandr
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- FLEX="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index c4d207792e50..3f278370a351 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
png.6:${PORTSDIR}/graphics/png \
xml2:${PORTSDIR}/textproc/libxml2
-CPPFLAGS= "-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --with-glu \
@@ -36,8 +37,7 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--with-opengl --without-mpg123 --with-oss --without-sane \
--without-v4l --without-xcomposite --without-xinerama \
--with-xinput2 --with-xrandr
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- FLEX="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
diff --git a/emulators/x48/Makefile b/emulators/x48/Makefile
index 710ea2df0a4a..e416f90d1ef1 100644
--- a/emulators/x48/Makefile
+++ b/emulators/x48/Makefile
@@ -20,7 +20,7 @@ COMMENT= An HP48 SX/GX graphic calculator emulator
LICENSE= GPLv3
GNU_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= LIBS=-lutil
USE_GMAKE= yes
USE_XORG= x11 xext xt
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 9c61e3b65891..ebd6a1732576 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= pixel@hugbox.org
COMMENT= A portable Amstrad 464&/664/6128 emulator
HAS_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--prefix=${PREFIX}
USE_XORG= ice
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index b414c7a7b60e..187fab3783da 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -35,8 +35,8 @@ CONFIGURE_ARGS= --without-included-gettext \
--with-cachesize=20 \
--enable-midi=seq,extp,raw \
--enable-cdrom=bsd,mp3
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 02316eedb770..5fd614d4dd6b 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -36,7 +36,6 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-cpucheck
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= zsnes.1
PLIST_FILES= bin/zsnes