aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2018-05-19 07:59:57 +0000
committerStefan Eßer <se@FreeBSD.org>2018-05-19 07:59:57 +0000
commit8dc5f88137963705514fb826db51207257219afd (patch)
tree9ba5cde3c1f59717fafd743cc09ec87e5e9b5466 /emulators
parent66ccddb73f72c4b4ba29b429bb8e2a71198d637d (diff)
downloadports-8dc5f88137963705514fb826db51207257219afd.tar.gz
ports-8dc5f88137963705514fb826db51207257219afd.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-gecko-devel/Makefile4
-rw-r--r--emulators/wine-gecko/Makefile4
-rw-r--r--emulators/wine-mono-devel/Makefile4
-rw-r--r--emulators/wine-mono/Makefile4
4 files changed, 12 insertions, 4 deletions
diff --git a/emulators/wine-gecko-devel/Makefile b/emulators/wine-gecko-devel/Makefile
index c0614c2ae3a9..3a34dc229ac6 100644
--- a/emulators/wine-gecko-devel/Makefile
+++ b/emulators/wine-gecko-devel/Makefile
@@ -16,10 +16,12 @@ COMMENT= Gecko Layout Engine for Wine development branch (HTML support)
LICENSE= MPL20 GPLv2 GPLv3 LGPL21 LGPL3
LICENSE_COMB= multi
+CONFLICTS_INSTALL= wine-gecko-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+PLIST_FILES= ${DATADIR}/gecko/wine_gecko-${DISTVERSION}-x86.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/gecko
diff --git a/emulators/wine-gecko/Makefile b/emulators/wine-gecko/Makefile
index d7339a745bbd..2276ccdb1156 100644
--- a/emulators/wine-gecko/Makefile
+++ b/emulators/wine-gecko/Makefile
@@ -17,10 +17,12 @@ LICENSE_COMB= multi
PORTSCOUT= ignore:1 # for newer versions see emulators/wine-gecko-devel
+CONFLICTS_INSTALL= wine-gecko-devel-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
+PLIST_FILES= ${DATADIR}/gecko/wine_gecko-${DISTVERSION}-x86.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/gecko
diff --git a/emulators/wine-mono-devel/Makefile b/emulators/wine-mono-devel/Makefile
index a8a13e1d65d9..d2b8232cec0e 100644
--- a/emulators/wine-mono-devel/Makefile
+++ b/emulators/wine-mono-devel/Makefile
@@ -15,10 +15,12 @@ COMMENT= Mono .NET implementation for Wine development branch (HTML support)
LICENSE= MIT GPLv2 LGPL20
LICENSE_COMB= multi
+CONFLICTS_INSTALL= wine-mono-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= MONO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/mono/wine-mono-%%MONO_VERSION%%.msi
+PLIST_FILES= ${DATADIR}/mono/wine-mono-${DISTVERSION}.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/mono
diff --git a/emulators/wine-mono/Makefile b/emulators/wine-mono/Makefile
index b232ad7670f9..91465f58c99f 100644
--- a/emulators/wine-mono/Makefile
+++ b/emulators/wine-mono/Makefile
@@ -16,10 +16,12 @@ LICENSE_COMB= multi
PORTSCOUT= ignore:1 # for newer versions see emulators/wine-mono-devel
+CONFLICTS_INSTALL= wine-mono-devel-[0-9]*
+
NO_BUILD= yes
PLIST_SUB+= MONO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
-PLIST_FILES= %%DATADIR%%/mono/wine-mono-%%MONO_VERSION%%.msi
+PLIST_FILES= ${DATADIR}/mono/wine-mono-${DISTVERSION}.msi
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/mono